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License Agreement 
By downloading or using this Software, you agree to be bound by the following legal agreement 
between you and the Alfred-Wegener-Institute for Polar and Marine Research (AWI). If you do 
not agree to the terms of this Agreement, do not download or use the Software. 

1. SCIENTIFIC USE AND TEACHING 

Ocean Data View can be used free of charge for non-commercial, non-military research and 
teaching purposes. If you use the software for your scientific work, please cite Ocean Data View 
in your publications as follows: Schlitzer, R., Ocean Data View, https://odv.awi.de, 2018. 

2. COMMERCIAL USE 
For the use of Ocean Data View or any of its components for commercial applications and prod-
ucts, a special, written software license is needed. Please contact the address below for further 
information. 
 

3. MILITARY USE 
AWI focusses its activities on civil purposes. Licenses for the Ocean Data View Software for mili-
tary purposes will only be granted after case-by-case assessments of the requests. Please con-
tact the address below for further information. 

4. REDISTRIBUTION 

Redistribution of the Ocean Data View software on CD-ROM, DVD, or other electronic media or 
the Internet is not permitted without the prior written consent of the AWI. Please contact the 
address below for further information. 

5. WARRANTY DISCLAIMER 

THE ODV SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER 
EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  THE ENTIRE RISK AS TO 
THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU.  SHOULD THE 
SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, 
REPAIR OR CORRECTION. 
 
IN NO EVENT WILL AWI, ITS CONTRIBUTORS OR ANY ODV COPYRIGHT HOLDER BE LIABLE 
TO YOU FOR DAMAGES, INCLUDING ANY DIRECT, INDIRECT, GENERAL, SPECIAL, EXEMPLARY, 
INCIDENTAL OR CONSEQUENTIAL DAMAGES HOWEVER CAUSED AND ON ANY THEORY OF 
LIABILITY ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE (INCLUDING BUT 
NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES 
SUSTAINED BY YOU OR THIRD PARTIES, A FAILURE OF THE SOFTWARE TO OPERATE WITH 
ANY OTHER SOFTWARE OR BUSINESS INTERRUPTION). 
 
 
© 1990 -2018 Reiner Schlitzer, Alfred Wegener Institute, Am Alten Hafen 26,  

27568 Bremerhaven, Germany.  E-mail: Reiner.Schlitzer@awi.de 
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1 General Overview 

Ocean Data View (ODV) is a computer program for the interactive exploration and 
graphical display of oceanographic and other geo-referenced profile, trajectory or time- 
series data. The software is available for Windows, Mac OS, Linux, and UNIX systems. 
ODV data and settings files are platform independent and can be exchanged between all 
supported systems.  

ODV lets the user maintain and analyze very large datasets on inexpensive and portable 
hardware.  Various types of graphics output can be produced easily, including high-
quality station maps, general property-property plots of one or more stations, scatter 
plots of selected stations, section plots along arbitrary cruise tracks and property distri-
butions on general isosurfaces. ODV supports display of original scalar and vector data 
by colored dots, numerical data values or arrows. In addition, there is a choice between 
three different gridding algorithms, providing estimates on automatically generated 
grids, and allowing color shading and contouring of fields along sections and on isosur-
faces. A large number of derived quantities can be calculated on the fly. These variables 
can be displayed and analyzed in the same way as the basic variables stored on disk.  

ODV 4 is based on object oriented C++ software code and overcomes many limitations 
of previous ODV versions. To ensure backwards compatibility, ODV continues to sup-
port existing data collections and configuration files (now called views) created under 
ODV3. All newly created collections, however, now use a new and more general data 
model and internal storage format. As before, ODV data collections maintain platform 
independence and may be moved between supported systems. Among the novel fea-
tures of the new data model are more flexible metadata schemes, support for an unlim-
ited number of data variables, user specified data types, and custom quality flag 
schemes for metadata and data variables. 

1.1 Ease of Use 

ODV is designed to be flexible and easy to use. Users need not know the details of the 
internal data storage format and are not required to have programming experience. 
ODV always displays a map of available stations on the screen and facilitates navigating 
through the data by letting the user select stations, samples, sections and isosurfaces 
using the mouse. The layout of station map and data windows on the ODV drawing can-
vas as well as many other view settings can be modified easily, and favorite settings can 
be stored in view files for later use.  

ODV can handle very large data collections containing millions of stations on relatively 
inexpensive and portable hardware, and any existing data collection can be extended 
when new data become available. With its wide range of plot types and flexible interac-
tive controls, ODV greatly facilitates data quality control and is also useful for training 
and teaching. 



Version 5.1.0 

 2 

1.2 Dense Data Format 

The ODV data format is optimized for variable length, irregularly spaced profile, trajec-
tory, and time-series data. It provides dense storage and allows instant access to the 
data of arbitrary stations, even in very large data collections. The data format is flexible 
and accepts data for virtually unlimited numbers of stations, samples and variables. The 
lists of metadata and data variables of an ODV collection are defined by the user at col-
lection create time. Different ODV collection may be created to store the data of very 
different data types, such as profiles, trajectories or time-series.  

In addition to the actual data values ODV also maintains quality flags for all individual 
values. These quality flags may be used for data quality filtering to exclude, for instance, 
bad or questionable data from the analysis. Numerical values and quality flags may be 
edited and modified. All modifications are logged, thus allowing unintentional changes 
to be reversed, if necessary. 

1.3 Extensibility 

ODV allows easy import of new data into collections and also allows easy export of data 
from a collection. Oceanographic data in the following widely used formats can directly 
be read into the ODV system: 

• ASCII spreadsheet data,  
• Argo profile and trajectory data,  
• GTSPP data, 
• SeaDataNet data, 
• Sea-Bird data in .cnv format, 
• WOCE and CLIVAR data in WHP exchange format, 
• World Ocean Database data. 

1.4 Derived Variables  

In addition to the basic measured variables stored in the data files, ODV can calculate 
and display a large number of derived variables. Algorithms for these derived variables 
are either coded in the ODV software (potential temperature, potential density, dy-
namic height (all referenced to arbitrary levels), neutral density, Brunt-Väisälä Fre-
quency, sound speed, oxygen saturation, etc.) or are defined in user provided macro 
files or expressions. The macro language is easy and general enough to allow a large 
number of applications. Use of expressions and macro files for new derived quantities 
broadens the scope of ODV considerably and allows easy experimentation with new 
quantities not yet established in the scientific community. ODV provides a built-in 
macro editor that facilitates creation and modification of ODV macros.  
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1.5 Plot Types 

Any basic or derived variable may be displayed in one or more data windows. In addi-
tion, any variable can be used to define isosurfaces, such as depth horizons, isopycnals, 
isothermals, or isohalines. Property minimum or maximum layers like, for instance, the 
intermediate water salinity minimum layer, can be selected as isosurface by finding 
zero-values of the vertical derivative variable of these variables.  

ODV displays data in two basic ways: (1) either by showing the original data at the data 
locations as colored dots of user-defined size (see Figure 1-1a), numeric values, or ar-
rows (see Figure 1-2); or (2) by projecting the original data onto equidistant or variable 
resolution rectangular grids and then displaying the gridded fields (see Figure 1-1b). 
Method 1 produces the most elementary and honest views of the data, instantly reveal-
ing occasional bad data values and regions of poor sampling. In contrast, method 2 pro-
duces nicer plots and avoids the overlapping of the colored dots that occurs with 
method 1, especially for large dot-sizes. Users should note, however, that the gridded 
fields of method 2 are actually data products and that small scale or extreme features in 
the data may be modified or lost as a consequence of the gridding procedure.  

For both display modes, ODV allows the export of window data and gridded fields to 
ASCII files or the clipboard for subsequent use outside ODV.  
 

 
Figure 1-1: Data displayed as (a) colored dots and (b) gridded field. 

 

In addition to scalar property fields, ODV also supports the display of vector fields for 
datasets providing the X and Y vector components as distinct variables (see Figure 1-2).  

1.6 Window Scopes 

The ODV application window always displays a map of available stations. In addition, 
the user may define an unlimited number of other windows for the display of the actual 
data. Each of these data windows can have one of the following scopes: STATION, 
SCATTER, SECTION, or SURFACE. Each window has its own scope, and the scopes of the 
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different data windows may be different. 

 

 
Figure 1-2: Arrow plot of historical wind field. 

1.6.1 STATION Scope 

A STATION scope window (see Figure 1-3) provides a X/Y plot showing only the data of 
stations in the map’s pick list. You can add the current station to the pick list by press-
ing ENTER, or you can remove it by pressing the Delete button. You can edit the station 
pick list using the Manage Pick List > Edit Pick List option of the map popup menu. 
Among other things, this lets you adjust the graphics style for each individual picked 
station. As for all other data window types, STATION windows allow you to assign arbi-
trary data variables (basic or derived) on the X and Y axis. For easy identification, 
picked stations are marked in the map using the same symbol and color as in the data 
windows. If the map has station annotation switched on, the picked stations positions 
are also labeled with the station label. 

1.6.2 SCATTER Scope 

SCATTER scope windows (see Figure 1-4) display the data of all stations currently 
shown in the map, thereby providing overviews over potentially very large data sets. 
SCATTER windows are particularly useful for data quality control. Like for all subse-
quent scopes, SCATTER windows support a Z variable, in addition to variables on X and 
Y. Values of the Z variable determine the colors drawn at given X/Y data locations. Plots 
with Z-variables (for SECTION and SURFACE modes as well) can be displayed in two 
ways: (1) by placing colored dots or the actual data value at the X/Y locations (default) 
or (2) as continuous gridded fields, estimated on the basis of the observed data. Gridded 
fields can be color shaded and/or contoured.  
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Figure 1-3: Example window layout with an orthographic map and six data windows using STATION scope. 
The pick list stations are marked in the map for easy identification. 

 

 
Figure 1-4: Example window layout with two data windows using SCATTER scope. The data of one station 

are highlighted using symbol set graphics objects. 
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1.6.3 SECTION Scope 

SECTION scope windows (see Figure 1-5) display the data of all stations belonging to 
the section currently defined in the map, e.g., all stations inside the red section band. 
Sections are defined or modified using the Manage Section options of the map popup 
menu. SECTION windows also support Z variables and the display of original data or 
gridded fields. SECTION windows are most useful to display along-track property distri-
butions or property/property plots for the stations of a given expedition following a 
given track.  

 

 

Figure 1-5: Example window layout with two data windows of scope SECTION (1 and 2) and one SCATTER 
data window (3). Note that the SCATTER window 3 displays all data of all stations in the map, while the 

SECTION windows 1 and 2 only show the data of the stations inside the section band. 

 

1.6.4 SURFACE Scope 

In addition to metadata and data variables, ODV defines a third set of variables, isosur-
face variables. Isosurface variables provide values of a given data variable (e.g. Temper-
ature or Depth in Figure 1-6) on specific isosurfaces. Isosurfaces are layers of constant 
values of another data variable, such as, constant depth or density layers.  

SURFACE scope windows show isosurface values of all stations in the map. SURFACE 
windows support X, Y and Z isosurface variables. If Longitude and Latitude isosurface 
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variables are assigned to the X and Y axis, the window will become a map displaying the 
selected Z variable (see Figure 1-6). Such map data windows use the projection and lay-
ers settings of the station map. It is also possible to assign other isosurface variables to 
the X and Y axis of the SURFACE data window, resulting in general isosurface variable 
correlation plots, possibly colored using another isosurface variable as Z variable. 

 

 

Figure 1-6: Example window layout with two data windows of scope SURFACE showing property distribu-
tions on isosurfaces. 

 
Station maps and data distributions in map data windows can be plotted as global interrupted 
maps as shown in the figure below. Use the Save As Interrupted Map option of the data 
window’s context menu to produce gif, png, jpg, tiff or eps image files of the interrupted 
maps. The Interrupted Map Properties dialog appears and lets you define properties, 
such as title, copyright message and whether the Arctic and Antarctic sub-windows 
should be included or not. The color shading and contour properties are inherited from 
the parent data window. 

1.7 Graphics Output 

You can produce gif, png, jpg, tiff and eps image files of the canvas, the map or of individ-
ual data windows using the File > Save Canvas As option of the main menu or the Save 
Canvas As, Save Map As and Save Plot As context menu options of the canvas, map and 
data window, respectively. Press the Ctrl-S shortcut key with the mouse over the can-
vas, map or data window to quickly activate these options. The saved image or eps files 
can then be incorporated in documents and web-pages. The resolution of the image files 
is specified by the user and not limited by the graphics resolution of the screen. Canvas 
options of the File and canvas menus. 
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Figure 1-7: Oxygen distribution on the 500 m depth isosurface shown as interrupted map. Interrupted maps 
are produced via the "Save As Interrupted Map" option of the plot’s context menu. 

 

1.8 Data Statistics 

Statistics information for the X, Y, Z data of a data window or the position and date/time 
metadata of the stations in the map can easily be obtained by pressing F4 while the 
mouse is over the respective data window or the map. A dialog will appear showing 
mean, standard deviation, number of data points as well as minimal and maximal values 
for X, Y and Z variables separately. In addition, histograms of X, Y and Z data as well as 
X/Y data distribution plots can be obtained by simple button clicks. For the map you 
can also obtain station coverage histograms over time or season. 

1.9 Estimation and Averaging 

ODV can be used to estimate values of any basic or derived variable at arbitrary longi-
tude-latitude-depth points (3D point estimation). 3D point estimation is implemented 
as a fast weighted averaging procedure and uses the currently valid station and sample 
set together with user specified longitude, latitude and depth averaging length scales. 
The coordinates at which estimation is requested are provided in ASCII files. The points 
can be irregularly spaced or may form a uniform or non-uniform, rectangular or curvi-
linear grid. You invoke 3D point estimation from the main menu through Tools > 3D Es-
timation. 
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For data windows with a Z variable, another method, 2D point estimation, can be used 
to estimate Z values at arbitrary X/Y points. As for 3D estimation, the X/Y coordinates 
are provided in ASCII files. The points can be irregularly spaced or may be on a uniform 
or non-uniform, rectangular or curvilinear grid. Choose Extras > 2D Estimation from the 
respective data window popup menu to invoke 2D point estimation. 

A third estimation method, 1D Estimation, is available for data plots that have the pri-
mary variable on their X or Y-axis. For every station contained in the plot, this option 
allows estimation of the other variable at user-specified values for the primary variable. 
These user-specified coordinates have to be provided in ASCII files, one coordinate per 
line. The results of the estimation (one requested station after the other) are written to 
ODV spreadsheet format files, e.g., these files themselves can be imported easily and vis-
ualized with ODV. You can use the 1D Estimation option to obtain, for instance, stand-
ard depth (pressure) profiles of a variable stored in your collection. Choose Extras > 1D 
Estimation from the respective data plot popup menu to invoke 1D Estimation. 

In addition to the various point estimation methods described above, ODV can also be 
used to calculate averages and standard deviations for user-specified longitude/lati-
tude/depth boxes. All currently valid samples inside a given box are used for the aver-
aging. Box-averaging differs from point estimation: whereas all point estimation meth-
ods always yield a value (potentially of poor quality, if no data are found nearby), the 
box averaging procedure only returns results, if data values are actually found inside 
the box. 

1.10 NetCDF Support 

In addition to native ODV data collections, ODV can also access and visualize data in lo-
cal or remote netCDF files, widely used for platform independent storage of gridded 
data as well as model output. ODV prompts the user for identification of key dimensions 
and variables in the netCDF file via a four-step netCDF emulation wizard. The content of 
the netCDF file is then presented to the user as if the netCDF file was a native ODV col-
lection. All ODV analysis and visualization options are available for the exploration of 
the data in the netCDF file. NetCDF files are platform independent and can be used on 
all ODV supported systems. 
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2 First Steps 

2.1 Installing Ocean Data View 

You must install ODV on your computer before you can use the software. The latest ODV 
installation files for Windows, Mac OS, Linux, and UNIX systems can be downloaded 
from https://odv.awi.de/en/software/download/. Note that you have to register and 
use your personal login data to get access to the download pages. Detailed installation 
instructions are provided in INSTALL.txt files. Please see the License Agreement for 
ODV usage rules. 

SUPPORTED PLATFORMS: ODV runs on the following platforms: Windows (all ver-
sions); Mac OS 10.5 or higher; Linux distributions released since June 2006 running 
kernel version 2.6.15 or higher. ODV was tested under Debian 7.7, Ubuntu 14.0.4 and 
16.0.4, and CentOS 7. 

Sub-directory ODV in the user’s document directory serves as ODV user directory. This 
directory is automatically created when ODV is installed, and map resources as well as 
palette, macro, gazetteer, command or graphics objects files are copied from the instal-
lation package into this directory.  The user may create custom versions of these files in 
the ODV user directory. It is important to save the customized files under new names; 
otherwise the modified versions will be overwritten and lost the next time a new ODV 
software version is installed. The full user directory path as well as other ODV installa-
tion settings can be retrieved via Help > About ODV or odv > About odv on Mac OS sys-
tems.  

Complementary high resolution coastline and topography packages can be installed us-
ing the View > Settings (ODV > Preferences on Mac OS) option. See section 2.12 below for 
further information. 

The ODV user directory can be moved to a different location on your system disk via 
View > Settings > System > User Directory. For performance reasons please do not move 
the user directory to a network drive. 

2.2 Running Ocean Data View 

Once ODV is installed on your system you can start the software in a number of ways.  

On Windows, the installation procedure will create an ODV icon on your desktop and 
will automatically associate .odv and .var collection file types with the ODV application. 
To launch ODV double-click a .odv or .var file or double-click the ODV desktop icon.  

You can also drag and drop any ODV supported file onto the ODV icon. This will start 
ODV and open the dropped file. With ODV running, you can drag and drop any ODV sup-
ported file onto the ODV window to open this file. Supported file types include ODV col-
lections (.odv and .var), netCDF files (*.nc, *cdf) and ODV spreadsheet files (.txt). 

On Mac OS, Linux, and UNIX systems you can create aliases or icons of the ODV executa-
ble odv or the ODV startup script file run_odv using methods specific to your operating 

https://odv.awi.de/en/software/download/
https://odv.awi.de/en/software/register/terms/
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system. The ODV executable odv is located in the bin_... directory of your ODV installa-
tion (e.g., bin_macx on MacOS X, bin_linux-i386 on Linux systems, etc.). Once a desktop 
or taskbar/dock icon is created, you start ODV by double or single-clicking on the ODV 
icon. On most systems you can also drag-and-drop ODV collection .odv and .var files, 
netCDF files or any supported data import file onto the ODV icon. 

ODV can also be started from DOS boxes or terminal windows by entering the path-
name of the executable together with (optional) arguments. On some systems a script 
file run_odv is available to start ODV from the command line. If you start ODV from the 
command line the following arguments are supported. Note that file and path names in-
cluding spaces must be enclosed within quotation marks “ “. 

There are two ways of starting ODV from the command line: 
(1) odv  file  [ -access accessMode ] [ -view view_file ] 

or 
(2) odv  -x cmd_file  [ -q ] 

The first case opens an ODV collection (.odv or .var collection files) or netCDF .nc or .cdf 
file file using access mode accessMode (possible values are ReadOnly or ReadWrite; de-
fault is ReadWrite)) and loads the view from view file view_file. The -access and -view ar-
guments are optional. If no view file is provided a default view or the most recently 
used view is loaded initially. If the ODV binary directory is not in your PATH you have to 
specify the full pathname of the ODV executable, e.g., “c:\Program Files\Ocean Data 
View\bin_w64\odv” on Windows or “/Applications/Ocean Data View” on Mac OS sys-
tems. file has to be an absolute pathname, or a path relative to the current directory. 
view_file has to be an absolute pathname, or a path relative to the directory containing 
file. 

The second command line above opens the ODV command file cmd_file and executes the 
commands contained in the file. If the optional argument -q is provided, ODV is auto-
matically shut down after all commands have been processed. cmd_file has to be an ab-
solute pathname, or a path relative to the current directory. 

On some platforms ODV prompts for the following Quick Installation information when 
running for the first time: 

1. The full path-name of the directory that contains the bin directory (ODVHOME 
environment variable). 

2. The full path-name of a directory on your disk which will be used by ODV during 
runtime to write temporary files (ODVTEMP environment variable). Note that 
you must have write permission for this directory. You can use the system tmp 
directory, or you can create a special directory on a local disk (e.g., /odvtmp) for 
this purpose. The use of directories on network drives is not recommended be-
cause of potentially pour performance. 

3. The name of your computer. 
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4. Your user or login name. 

Press OK to finish the Quick Installation. Then customize ODV font and external pro-
grams settings using the View > Settings (on Mac OS: odv > Preferences) dialog.  

Once ODV is running, you open a data collection, netCDF file or any of the supported im-
port data files using the File > Open option. A standard file open dialog will appear, and 
you can choose the appropriate file type and file name to be opened. If you open a sup-
ported import data file, ODV will automatically create a new collection in the directory 
of the selected file, import the data from the file, and open the newly created data col-
lection.  

Note that after opening a collection, ODV loads the most recent view settings of the col-
lection. These view settings may include station and sample selection filters, and, there-
fore, only a subset of the stations and data values in the collection may be shown in the 
map and data windows. Use View > Station Filter to relax or modify the station filter set-
tings. 

You may load other, previously saved, view files by clicking on the plus button in the 
views bar or by using View > Load Views. You can change the window layout by clicking 
on the layout button in the views bar or via View > Window Layout. You load one of the 
pre-defined layout templates by right-clicking the plus button in the views bar or via 
View > Layout Templates > … . You change various view settings interactively using the 
View menu options or the context-specific popup menus that appear when right-click-
ing the canvas area, map, or one of the data windows. 

2.3 Getting Help 

Pressing F1 or using option Help > User’s Guide opens the ODV User’s Guide (this docu-
ment). Note that a pdf version of the User’s Guide is available on the ODV website. Con-
text sensitive help is provided by pressing the Help button on many ODV dialogs. This 
will invoke the web browser specified under View > Settings > Program Locations (on 
Mac OS: odv > Preferences > Program Locations), and the browser will jump to a particu-
lar chapter in the User’s Guide. On Windows, context sensitive help works best with 
Chrome and Firefox. When using Internet Explorer it may be necessary to click into ad-
dress field and to press ENTER. On Mac OS and some Linux systems, a running web 
browser may have to be closed before ODV context sensitive help will be displayed.  

2.4 Application Window 

The ODV application window consists of the following elements (see Figure 2-1): 

Menu Bar: The menu bar provides access to main menus. 

Views Bar: The views bar contains clickable tabs for each open view as well as a set of 
buttons for (1) opening more views (plus button), (2) saving modified views (save 
button), (3) undoing/redoing view modifications (history buttons), and (4) 
switching to/from layout mode (layout button). 

https://odv.awi.de/en/documentation/
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Canvas: The graphics canvas contains a map (always present) and an unlimited number 
of data windows. The canvas, the map, and the data windows may contain an un-
limited number of graphics objects, such as text annotations, symbols or user-de-
fined shapes. 

Status Bar: Separate panes providing (1) status information, (2) coordinates at current 
mouse position or a progress bar, and (3) the number of currently selected sta-
tions, the total number of stations in the collection, and the name of the current 
view. 

Current Station Window: Metadata values of the current station (marked in the map 
with a red cross).  

Current Sample Window: Data values and quality flags of the current sample (marked in 
data windows with a red cross). Only data satisfying the current sample filter set-
tings are shown. 

Isosurface Data Window: Isosurface values of the current station.  

 

 
Figure 2-1: Elements of the ODV application window. 

 

The views bar contains clickable tabs for each open view as well as a set of buttons for 
(1) opening more views (plus button), (2) undoing view modifications (undo button), 
(3) redoing view modifications (redo button), (4) switching to/from layout mode (lay-
out button), and (5) saving modified views (save button). 

Left-clicking on station or data marks in the map or any of the data windows selects the 
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respective station or sample. Right-clicking on most window elements brings up con-
text menus with different, element-specific options. Resting the mouse over data listing 
items brings up popup windows with detailed data information.  

The map displays stations that satisfy the current station filter settings. It maintains a 
pick station list and may have a section. Data windows have one of the following scopes: 
(1) STATION, showing X/Y data of the picked stations, picked stations are marked in the 
map using the same marks as in the data windows; (2) SCATTER, showing X/Y/Z data 
of all selected stations shown in the map; (3) SECTION, showing X/Y/Z data of all sta-
tions inside the section band; and (4) SURFACE, showing isosurface X/Y/Z data of all se-
lected stations shown in the map. The current window layout and parameter settings 
are collectively called a view. Views can be stored in files for later use. 

Some of the ODV window elements and popup menus are described in more detail be-
low. 

2.5 Menu Bar 

The main menu provides basic functionality: 

File: Open or create a collection; open netCDF file; open a ODV supported data file, exe-
cute ODV commands in batch mode; produce gif, png, jpg, tiff or PostScript files 
of current ODV graphics canvas; exit ODV. 

Collection: Copy, rename, delete collection; sort and condense data collection; delete 
current station or valid station subset; view collection info, inventory, and log 
files; add a comment to the collection log file; identify key variables, define good 
coverage criteria; view or edit the collection properties and variables. 

View: Change station and sample filter settings; define derived variables; define isosur-
face variables; change map and data window layout; change variable labels, nu-
meric format and display order in listing windows; undo/redo recent view-
mchanges; load and save view settings, define general ODV settings. 

Import: Import data into current collection (supported formats include various spread-
sheet formats,  Argo, MedAtlas, World Ocean Database, and WOCE). 

Export: Export data of currently selected stations to ASCII file, ODV collection or netCDF 
file; export window X, Y, Z data to ASCII files; export window X, Y, Z data as refer-
ence dataset; export of isosurface values to ASCII file. 

Tools: Calculation of geostrophic flows; 3D estimation; calculation of box average val-
ues; outlier and duplicate station identification; macro editor; color palette editor 
(Windows only); list file generator; Ocean Calculator. 

Help: Invoke ODV help system; visit the ODV web page; send bug reports; show ODV 
version and installation details. 

2.6 Views Bar 

When opening a data collection ODV also loads and shows the last view. This view is 
represented by a tab in the views bar just below the menu bar.  
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Figure 2-2: Example views bar with plus, undo, redo, layout and save buttons as well as tabs for three open 

views. 

 
You can open additional existing views by left-clicking the plus button and choosing a 
view file from the file open dialog that appears. You can choose one of the available 
template views as new view by right-clicking the plus button and choosing a template 
from the list. You switch between views by clicking on the respective tab, thereby mak-
ing this the current view. You close an open view by clicking on the x button in the tab. 
Note that the data collection is closed when you close the last open view. 
 
You save the current view by left-clicking the save button. Right-clicking the save button 
allows you to save the current view under a new name (save as). A red save button indi-
cates that there are unsaved changes to the current view. Clicking the undo or redo but-
ton undos or redos the last view modification. Right-clicking the undo or redo button 
shows the list of recent view modifications available for undo/redo actions. Clicking the 
layout button switches to/from layout mode and allows creation/deletion as well as 
resizing of windows. 

2.7 Metadata and Data List Windows 

The Current Station Window contains the metadata values of the current station 
(marked in the map with a red cross), the Current Sample Window contains the data val-
ues and associated quality flags of the current sample (marked in data windows with a 
red cross), and the Isosurface Data Window contains the isosurface values of the current 
station. Data values are shown in different colors to instantly reveal the quality of the 
values. The Current Sample Window also shows 1-σ data errors and/or the ⓘ symbol if 
data errors and/or data infos are provided with the actual data. Rest the mouse over 
the ⓘ symbol to see the data information value. If the information value is a URL or a 
reference to an information file in the collection (value starts with lf:) left-clicking on 
the (blue) ⓘ symbol will open the respective document in the web browser. See the de-
scription of the ODV generic spread sheet format for details on how to provide data er-
rors and data information values in spread sheet files.  

Tooltip messages containing the full variable label, the data value and associated data 
error (if available) as well as the quality flag text and the data information value (if 
available) appear automatically when resting the mouse over one of the Current Sample 
Window list items. 

Right-clicking the mouse on one of the list windows brings up window specific popup 
menus. In the Current Sample Window you get separate menus if you right-click on the 
variable labels in the first column, the data values and quality flags in columns 2 and 3, 
or on the 4th column containing the ⓘ symbols if data information is available. These 
menus let you define derived variables, change the display order of variables, change 
variable properties (labels and numeric format) or display data availability information 
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(column 1), edit data values, data errors or quality flags (columns 2 or 3), or edit the 
data information value (column 1). Right-clicking on the Sample .. /.. heading lets you 
add a new sample, delete the current sample or choose another sample as current. 

2.8 Graphics Canvas 

The canvas is the painting area of ODV and contains the station map and zero or more 
data windows. You can adjust the size of the canvas via View > Settings > Canvas (on 
Mac OS: odv > Preferences > Canvas). 

2.9 Popup Menus 

Clicking the right mouse button (on Mac OS systems with a single-button mouse hold 
down the Alt key and click the mouse) while over the canvas, the map, a data window, a 
graphics object or any of the list windows invokes different popup menus providing op-
tions specific to the clicked element. Most of the ODV functionality is available via these 
popup menus. 
 

 
Figure 2-3: The canvas popup menu 

The canvas popup menu offers the following op-
tions: 
 
• 1: Redraws the entire canvas and all its windows.  
• 2: Saves the entire canvas and all its windows in gif, 

png, jpg, tiff, or PostScript file. 
• 3: Adjusts the axis ranges of all windows to full-range. 
• 4: Allows adding or managing the graphics objects of 

the canvas. 
• 5: Allows modifying the properties of the map and data 

windows.  
• 6: Changes the map and data window layout and im-

plements window layout templates. 
• 7: Allows undo/redo of the most recent view changes. 
• 8: Saves/loads a view to/from a file. 
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Figure 2-4: The map popup menu 

The map popup menu offers the following options: 

 
• 1: Redraws the map.  
• 2: Saves the map in gif, png, jpg, tiff or PostScript file. 
• 3: Redraws and saves the map as interrupted map. 
• 4: Manually zoom in or out the map’s domain. 
• 5: Automatically zoom in or out. 
• 6: Set domain of the currently valid stations. 
• 7: Set full domain of the collection. 
• 8: Set global map domain. 
• 9: Select new current station by station ID, accession 

number or name. 
• 10: Change the station filter settings. 
• 11: Manipulate the map’s station pick list.  
• 12: Define a section and modify its properties. 
• 13: Access the map’s Extras menu.  
• 14: Modify the properties of the map. 

 
  

 
Figure 2-5: The data window popup 

menu 

The data window popup menu offers the following options: 
 
• 1: Redraws the data window.  
• 2: Saves the data window in gif, png, jpg, tiff or PostScript 

file. 
• 3: Redraws and saves the data window as interrupted 

map (map data windows only). 
• 4: Manually zoom in or out the data window’s X/Y do-

main. 
• 5: Zoom into the window’s color bar and modify the Z-

range. 
• 6: Automatically zoom in or out. 
• 7: Move this window to the fore- or background. 
• 8: Adjusts the axis ranges of this window to full-scale. 
• 9: Sets axis ranges manually. 
• 10: Selects new variables on X, Y, or Z axis. 
• 11: Access to the data window’s Extras menu.  
• 12: Allows modifying the data window’s Sample filter set-

tings.  
• 13: Allows modifying the properties of this data window.  
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2.10 Status Bar 

The ODV status bar displays help, status and progress information. The right-most pane 
of the status bar indicates the number of currently shown stations in the map, the total 
number of stations in the collection, and the name of the current view file. Resting the 
mouse over this pane brings up a popup window with more detailed information on the 
current view. 

An S in the station filter pane indicates that a station selection filter is active and that 
only a subset of the available stations in the collection is currently shown in the map. 
The station filter pane is empty if no station filter is active. Station filter settings can be 
relaxed or modified via View > Station Filter.  

The sample filter pane indicates whether range and quality sample filters are active in 
one of the data windows (move mouse over the particular data window) or for the cal-
culation of isosurface variable values (move mouse over the Isosurface Data Window). 
Possible values in the sample filter pane are -|-, Q|-,  -|R, and Q|R. A quality and/or range 
filter is active in the item with the mouse if Q and/or R are present. -|- indicates that no 
sample filter is active. Sample filter settings can be relaxed or modified by right-clicking 
on the item (data window or Isosurface Data Window) and choosing the Sample Filter 
option. 

The access indicator pane shows the current collection access mode. RW indicates Read-
Write access, while R stands for ReadOnly. Please note that metadata and data cannot be 
edited and additional data cannot be imported if a collection is opened in ReadOnly 
mode. All editing and import options are disabled. If a collection is open in one ODV in-
stance and the same collection is opened in a second ODV instance, the second instance 
will be granted ReadOnly access only.  In addition, once a second instance starts using a 
collection a ReadWrite access mode of the first instance is down-graded to ReadOnly un-
til the second instance shuts down. A temporarily down-graded ReadOnly access is indi-
cated as R-. The first instance will automatically regain full ReadWrite access once all 
other ODV instances using the collection have terminated. The described access man-
agement strategy ensures that modifications to a collection can only be made if the 
given ODV instance is the only one currently using the collection. 

Note that access management is only available for ODVCF6 and ODVCF5 .odv collec-
tions. NetCDF files are opened in ReadOnly mode by default. 

2.11 Current Station and Sample 

ODV always points to a current station. This station is marked in the map with a red 
cross, and its metadata are listed in the Current Station Window. You can select a new 
current station by clicking with the left mouse button on a station mark in the map. If 
you suspect more than one station at the same location, for instance, because of re-
peated observations at the same site, you can hold down the SHFT key while clicking on 
the station position. If there are indeed multiple stations at the clicked position, a list of 
these stations is shown, and you can select the new current station from the list.  
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You can also use keyboard keys to select new current stations: the right arrow key will 
select the next station (according to the station order in the collection), while the left ar-
row key will select the previous one.  

Choosing option Current Station by Name from the map popup menu lets you specific 
cruise label, station label and station type making the matching station the current sta-
tion. Choosing option Current Station by ID from the map popup menu (or simply press-
ing the # key while the mouse is over the map) lets you select a new current station by 
entering its internal ID number (not to be confused with the station label).  

One of the samples of the current station is the current sample. The current sample is 
marked in the data windows by a red cross, and its data values as well as its quality 
flags are shown in the Current Sample Window. To select a new current sample (and 
possibly new current station) left-click with the mouse on any data point in any of the 
data windows. The down arrow key will select the next sample (in ascending order of 
primary variable values), while the up arrow key will select the previous one. Pressing 
the PgUp or PgDn keys will move the current sample forward or backward in larger 
steps. Pressing Pos 1 or End will move to the first or last sample of the station. 

2.12 Map and Data Window Drawing 

The map and data windows automatically draw or redraw themselves at program start, 
or whenever a view is loaded or one of the many layout or display properties is modi-
fied. Data windows of scope STATION or SECTION remain empty if the list of picked sta-
tions is empty and no section is currently defined. 

To add a station to the pick list either double-click on the particular station mark in the 
map or click on the mark to make the station the current station and then press ENTER. 
Repeat this procedure for other stations that you want to add to the pick list. The pick 
list can hold an unlimited number of stations. You delete a station from the pick list by 
making it the current station (e.g., click on one of its data points in a STATION window) 
and pressing the Delete button. You can edit the properties of pick list entries via the 
Manage Pick List > Edit Pick List option of the map popup menu.  

To define a section or change section properties use options from the Manage Section 
menu of the map popup menu. Once a section is defined the along-section coordinate is 
available as a derived variable. This can be Section Longitude, Section Latitude, or Sec-
tion Distance, depending on your choice of the Section Coordinate. If you want to pro-
duce property distributions along the section, put the section coordinate on the X axis of 
the plot. 

2.13 Settings 

You can customize general ODV settings such as the graphics and text fonts, the size of 
the canvas, or the browser and text file viewing commands using option View > Settings 
(on Mac OS odv > Preferences). 
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Canvas Size: 
Adjust the width and height of the ODV graphics canvas, e.g., the white area onto which 
the map and data windows are drawn. Click on Fit to screen to establish optimal settings 
for the current screen. Note that it may be necessary to adjust the Graphics Font Size on 
the Font tab after large changes of the canvas size. 

Fonts: 
Choose a font family and various font properties and set a global font scaling factor Size. 
Increase the Size value, if you want larger graphics text and axis annotations, or de-
crease it otherwise. Note that some fonts may not be supported in ODV’s PostScript out-
put. Also note that Graphics Font Size adjustments may be necessary after large changes 
of the canvas size (see below). 

The Text Font Size entry determines the font size used for menus, dialogs and the cur-
rent station and sample list windows. 

Highlighting:  
Choose the color to be used for highlighting the position of the current station in the 
map and the current sample and data of the current station in the data windows. 

Axis Synchronization: 
Switch on or off the range synchronization between different data windows. If range 
synchronization is on and the axis range of a variable is changed in one window, the 
range of this variable in other windows will be changed accordingly. Other windows re-
main unchanged if range synchronization is switched off. Note that this setting is per 
collection and that the entry is disabled if no collection is currently open. 

Gridded Bathymetry Resources: 
Install or uninstall optional global or regional gridded bathymetry resources for use as 
section bottom bathymetry, in DIVA domain setup as well as macros and expressions 
using the %H operand. Internet connection is required. 

Map Resources: 
Install or uninstall optional high-resolution coastline and bathymetry contour resources 
for the whole world or specific regions. The contour resources are used in ODV maps. 
Internet connection is required. 

The following map resources are available for download and installation: (1) the 
ETOPO1 global relief data of Amante and Eakins (2009) in 2’x2’ and 6’x6’ resolution, (2) 
the GEBCO_2014 global elevation data (version 2014-11-12, http://www.gebco.net/) in 
2’x2’ and 6’x6’ resolution, (3) the IBCAO V3 bathymetric data  
(http://www.ngdc.noaa.gov/mgg/bathymetry/arctic/) for the region north of 60N in 
30’’x30’’ resolution (taken from the ETOPO1 (2009) resource), (4) the RTOPO gridded 
relief data of Timmermann et al. (2010) for the region south of 45°S in 1’x1’ , 2’x2’ and 
6’x6’ resolution and (5) regional series for the Baltic, North Sea, Mediterranean, and Ker-
guelen areas.  

 

http://www.gebco.net/
http://www.ngdc.noaa.gov/mgg/bathymetry/arctic/
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Figure 2-6: Example maps of the Fram Strait region using (a) GlobHR, (b) ETOPO1_6min, and (c) 
ETOPO1_2min. 

These extra series can be installed (or uninstalled) at any time from within ODV using 
the View > Settings > Map > Resources (odv > Preferences > Map > Resources on Mac OS) 
option. Manual download and installation of optional packages is no longer needed.  

The ETOPO1, GEBCO_2014, IBCAO and RTOPO map data are organized in tiles. These re-
sources may be installed in two ways: as (1) complete or (2) download-on-demand pack-
age. In case (1), pressing the Install button will start the download and unpacking of the 
complete package. This may take several minutes. Afterwards all map data for the 
whole series domain are instantly available on your system and map drawing will pro-
ceed immediately. In case (2) the installation is very quick. However, when drawing the 
station map ODV will have to download all required tile data for the current map do-
main not already on the system before any drawing can start. Downloaded tiles are 
cached on your system and will not be downloaded a second time.  

If disk space is not a limiting factor it is recommended to install the complete ETOPO1 
or GEBCO_2014 6min and 2min packages. Administrators of systems used by more than 
one ODV user should move the downloaded map data from the ODV user directory 
<ODV user directory>/coast/*_?min to the ODV installation directory <ODV installation 
directory>/coast/*_?min to make these map resources available to all ODV users on the 
system and to avoid multiple individual installations in the users ODV directories. 

Regional packages should be installed if the package domain covers your region of in-
terest. Again, administrators of multi ODV user systems should move the resources 
from the ODV user’s directory to the ODV installation directory. 

The ETOPO1 and GEBCO_2014 2min packages replace many of the previously existing 
regional optional packages and provide equal or better quality.  

If you only need high-resolution map support for a specific small domain it is recom-
mended to install the ETOPO1 or GEBCO_2014_2min (download-on-demand) packages 
instead of the complete packages to reduce download time and storage space. 

Obviously, Internet connection is required to perform any of the map layer series instal-
lations. Information on how to use map resources in automatic or manual mode can be 
found in chapter 9.1. 

Resource Priorities: 
If Automatic selection of map layers is active and more than one installed map resource 
is available for the current map domain, the particular resource providing high resolu-
tion at moderate drawing cost is chosen by default. You can express preferences by 
specifying the map resources priority on the Resource Priorities page. Resources at the 
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top of the list are preferred over ones further down. 

Spreadsheet Import: 
Specify position (in degrees longitude or latitude) and time (in hours) difference limits 
between lines. Station breaks will always occur if these limits are exceeded, even if sta-
tion labels are provided and remain the same on both lines. If no station labels are pro-
vided in the import file, station breaks will occur whenever position and/or date and 
time change. 

SDN Import: 
Specify the output parent directory for SeaDataNet data imports. The actual SDN im-
ports occur in a subdirectory yyyy-mm-ddThh-mm-ss of the parent directory, where yyyy-
mm-ddThh-mm-ss represents the date and time when the import was initiated. 

Sea-Bird CNV Import: 
Specify whether splitting of up and down casts into separate stations and averaging of 
values in pressure bins should be performed. 

WOD Import: 
Choose between short cruise labels, such as WOD13_GR, consisting only of the WOD 
identifier and a two-character country code and long cruise labels, which also contain 
the OCL cruise number (e.g., WOD13_US014887). Choosing long cruise labels may lead 
to a very large number of cruises when importing large amounts of data and is not rec-
ommended. 

Program Locations: 
Specify the full paths of your Web browser (needed for ODV help) and text viewer 
(needed for viewing text files).  

On Mac OS, Linux and UNIX platforms the text viewer command can have zero or more 
arguments separated by spaces. The path of the text viewer and of arguments may con-
tain spaces, which have to be escaped by backslashes. 
 
Example: Use emacs installation in "/usr/local/My editor path" as text viewer and call 
the emacs client to reuse an already open emacs editor. 
 
/usr/local/My\ editor\ path/emacsclient -a /usr/local/My\ editor\ path/emacs 
 
Note that on Mac OS it is not possible to specify a Web browser; ODV will call the sys-
tems default browser instead. 

Sidebar Folders: 
The file-open and file-save dialogs of ODV provide quick access to a number of directo-
ries listed in the left sidebar of the dialog. You may specify up to two often-used directo-
ries of your choice to become part of the sidebar list (not used on Mac OS systems).  

User Directory: 
Specify the full path of the ODV user directory. ODV uses this directory for map and ba-
thymetry resources as well as for custom data collections, palettes, macros and com-
mand files.   
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To change the ODV user directory press the Change User Directory button and select the 
parent directory of the new ODV user directory. For best performance choose a direc-
tory on a fast, local disk and avoid network and USB drives. 

Note: This option is only available when no collection is open. Please ensure that no 
other ODV instance is running.  The contents of the previous user directory must be 
manually moved to the new location.  Then exit and re-start ODV. 

Web Links: 
Specify the URL of the ODV website, the root URL for file download from the ODV web-
site, and the root URL of the NERC vocabulary server. 
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3 ODV Collections 

ODV uses a special data storage format that can handle very large datasets efficiently. 
This format is optimized for irregularly spaced, variable length data and provides dense 
storage and fast data access. In a way, the ODV data storage model is complementary to 
the netCDF data format optimized for gridded data.  

The ODV collection format supports a wide range of environmental data, including pro-
files, trajectories and time series. Initially, ODV development focused on oceanographic 
data, however, due to the generic design of the collection format, data from various 
other areas such as atmosphere, sediment or ice-sheets can be handled equally well.  
Typically, observational data handled by ODV are irregularly distributed in space and 
time. In addition, ODV can also maintain gridded data and numerical model output.  

ODV supports a new collection data format (ODVCF6) that is more powerful than its 
predecessor formats ODVCF5 and ODVGENERIC used by previous versions of ODV, and 
overcomes many limitations of the previous formats. There is now support for virtually 
unlimited sets of metadata and data variables as well as virtually unlimited numbers of 
stations and samples in a collection. ODVCF6 supports data quality flags for metadata 
and data variables, and the user may choose custom quality flag schemes from a set of 
16 popular oceanographic schemes. Metadata and data variables may be numeric (1 to 
8 bytes per value) or contain text of user specified fixed maximal length (value type 
TEXT) or of arbitrary length (INDEXED_TEXT). 

ODV is backwards compatible and fully supports ODVCF5 and ODVGENERIC collections 
and view or configuration files created with previous versions of ODV. When creating 
new collections, ODV will always use the ODVCF6 format providing all the new features 
and allowing more flexible definitions of metadata and data variables.  

In particular, ODVCF6 provides the following features: 
1. New Accession Number metadata variable providing a unique and non-modifiable identi-

fication number for every station in a collection. The Accession Number of a station is as-
signed when a station is added to the collection (normally during import) and preserved 
during Sort and Condense operations. This is in contrast to Station IDs, which change 
when the order of stations in the collection changes. 

2. New value types for metadata and data variables: SIGNED_BYTE, UNSIGNED_SHORT, 
UNSIGNED_INTEGER, INDEXED_TEXT (see Table below). INDEXED_TEXT supports 
UNICODE strings of arbitrary lengths. Strings occurring many times (e.g., cruise labels) 
are handled very efficiently. 

3. Per-station history records. All import and data edit actions are remembered in the his-
tory of the given station. History information is maintained when exporting data to col-
lection or ODV spreadsheet file. 

4. Every data variable now can hold data error values and data info strings in addition to 
the actual data values and quality flags. Data errors and info strings can be provided in 
spreadsheet files using STANDARD_DEV and INFOS columns. 

5. Proper ReadWrite or ReadOnly access management. ReadWrite access to a collection is 
only granted if the application is the only one currently working with the collection. A 
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second application opening the same collection will only have ReadOnly access. Once a 
collection is open in more than one application, the access rights of the first application 
are dynamically reduced to ReadOnly. An original ReadWrite access is dynamically re-
stored when all other applications using the collection have terminated. 

6. Collection password protection. ODVCF6 collections can now be password protected to 
prevent unauthorized use. 

 

3.1 Data Model 

ODV can handle a very wide range of data types, such as profiles (ocean, atmosphere, 
lakes, marine and lacustrine sediments, ice sheets, etc.), trajectories (underway data) or 
time series from fixed or drifting stations in the ocean, on ice floats or on land.  

The basic data entity maintained by ODV is the station, representing a 2D table of data 
obtained at a given geographical location and date/time. ODV collates the data of poten-
tially very large numbers of stations in ODV data collections. Users typically open a data 
collection and work with the station data in this collection. Collections are expandable, 
and new station data can be appended at any time.  

Stations are described by various metadata variables, such as cruise and station names, 
as well as space and time coordinates. In addition to the set of mandatory metadata var-
iables described below, ODV collections can have an unlimited number of other meta 
variables. Meta variables may contain numeric values or text.  

In addition to the metadata, each station also contains a 2D data table consisting of one 
or more lines and two or more columns (Table 3-2). Each line holds the data of a given 
sample and each column represents one of the data variables stored in the collection. 
The number and type of data variables is user-defined and may differ from one collec-
tion to another. One of the data variables, the primary variable, is special and serves as 
ordering variable for the samples of a station. Usually, but not necessarily, this is the 
first data variable. The sets of metadata and data variables are defined when the collec-
tion is created, but may be modified later at any time. 

For every station, ODV maintains data values for all meta variables and also for all data 
variables and all samples. In addition, ODV also maintains quality flag values associated 
with every individual metadata and data value. There are additional quality flags de-
scribing the overall quality of a station (station quality flag) and of each individual sam-
ple (sample quality flags). Quality flag values reflect the degree of confidence in the data 
and are an extremely valuable part of the data set.  

ODV supports 15 widely used quality flag schemes in the oceanographic community. 
ODV also defines its own simple and generic quality flag scheme that can be applied to 
oceanographic and other kinds of environmental data. ODV exploits data quality flag 
values for data filtering. Data quality flag values of data variables can also be used or 
plotting and other purposes by means of quality flag derived variables. 

Individual metadata and data variables may use different quality flag schemes. 
Metadata (except longitude and latitude) as well as sample data values may be missing. 
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3.1.1 Meta-Variables 

ODV defines a set of mandatory meta-variables containing information about cruise and 
station names as well as geographic location and date/time of occupation of a given sta-
tion (see Table 3-1). Every ODV collection contains the mandatory meta-variables, and 
it is desirable to provide values for all to describe the stations stored in the collection.  
Date and time of observation, or the names of the station and cruise (or expedition) it 
belongs to are needed to fully identify the station and to be able to apply powerful sta-
tion selection filters. If not provided in the datasets, all metadata except longitude and 
latitude may remain empty. Longitude and latitude must always be provided, stations 
without this information cannot be imported into ODV collections. 

In addition to the mandatory meta variables, ODV collections may have an unlimited 
number of extra meta variables of numeric or text value type. The value type of the 
mandatory meta-variables cannot be changed, but the value byte size can. As an exam-
ple, the user may set the value type of the longitude and latitude meta variables to 8 
byte double precision to accommodate high-resolution position information of better 
than a few centimeters. Meta variables with values in the ranges [0 to 255] or [-32,768 
to 32,767] may be represented as 1 or 2 byte integers, respectively, to reduce required 
disk storage space. 

 
Table 3-1: Mandatory and optional ODV meta-variables. 

Meta-variable Recommended Label 

Mandatory 
Cruise label (text). Cruise 
Station label (text). Station 
Station type (text). Type 
Date and time of observation (numeric year, month, day, hour, mi-
nute and seconds). 

yyyy-mm-ddThh:mm:ss.sss 

Longitude (numeric). Longitude [degrees_east] 
Latitude (numeric). Latitude [degrees_north] 

Optional 
SeaDataNet station identifier (text). LOCAL_CDI_ID 
SeaDataNet institution identifier (numeric). EDMO_code 
Bottom depth at station, or instrument depth (numeric). Bot. Depth [m] 
…  
Additional user defined meta-variables (text or numeric).  
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3.1.2 Data Variables 

ODV data collection typically contain one data variable for every measured parameter 
provided in the data files (e.g., pressure, temperature, salinity, etc.). The total number of 
data variables as well as their names, units and value properties are user-defined, and 
may vary from one data collection to the next. Like meta variables, data variables can 
have numeric or text values. One of the data variables (the primary variable) is special 
and is used for sorting the samples in ascending order of primary variable values. By 
default, the first data variable serves as primary variable, but any other variable can be 
chosen for this purpose. The primary variable is defined when the collection is created. 

3.2 Example Collection Types 

The ODV data model described above is flexible and supports a wide range of different 
data types, including the examples described below.  

3.2.1 Profile Data 

This category covers a wide range of observations, including, for example, oceano-
graphic profiles made at fixed positions or along steered or passive (current following) 
tracks by moored or drifting instruments, or from ships. In all these cases each individ-
ual profile should be treated as an individual station, using the metadata and data varia-
ble assignments from Table 3-2. Profile data in the atmosphere, ice sheets or sediments 
can be organized in similar ways, the only difference being in the choice of the primary 
variable (e.g., height in the atmosphere, or depth in the ice or sediment core). 

 
Table 3-2: Recommended metadata and data variables for profile data. 

Meta-variables Values 

Cruise Cruise, expedition, or instrument name (text) 
Station Unique station identifier (text) 
Type B for bottle or C for CTD, XBT or stations with >250 samples 
yyyy-mm-ddThh:mm:ss.sss Date and time of station (instrument at depth) 
Longitude [degrees_east] Longitude of station (instrument at depth) 
Latitude [degrees_north] Latitude of station (instrument at depth) 
  
Bot. Depth [m] Bottom depth of station 
Unlimited number of other 
meta-variables 

(text or numeric) 

  

Data Variables Comment 

Depth or pressure in water 
column, ice core, sediment 
core, or soil; elevation or 

To be used as primary variable 
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height in the atmosphere; etc. 
Unlimited number of other 
measured or calculated varia-
bles 

(text or numeric) 

 

3.2.2 Time Series Data 

This category covers observations at a given (fixed) location that are repeated over 
time. Examples are measurements of currents and hydrographic parameters on moored 
oceanographic sensors, sea level height measurements at coastal stations or meteoro-
logical observations on land stations.  In all these cases the entire time series of a given 
instrument or station should be treated as an individual station, using a decimal time 
variable as primary variable and the other metadata and data variable assignments 
from Table 3-3.  

 
Table 3-3: Recommended metadata and data variables for time series data. 

Meta-variables Values 

Cruise Cruise, expedition, or instrument name (text) 
Station Unique station identifier (text) 
Type B for bottle or C for CTD, XBT or stations with >250 

samples 
yyyy-mm-ddThh:mm:ss.sss Deployment date and time of instrument 
Longitude [degrees_east] Deployment longitude of instrument 
Latitude [degrees_north] Deployment latitude of instrument 
  
Bot. Depth [m] Bottom depth at station 
Unlimited number of other meta-variables de-
scribing the instrument and its deployment 
depth 

(text or numeric) 

  

Data Variables Comment 

Continuous decimal time variable  
or  
ISO8601 dates of the form 2003-02-
17T13:57:12.3 in a single column with column 
label time_ISO8601. 

To be used as primary variable 

Unlimited number of other measured or calcu-
lated variables 

(text or numeric) 

3.2.3 Trajectory Data 

This category covers observations made from a moving platform (e.g., ship, drifter, 
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float, glider, airplane, etc.) that are repeated over time. Examples are underway meas-
urements of hydrographic parameters at a given depth made during a ship expedition 
and from actively moving or passively drifting Lagrangean instruments.  In all these 
cases each individual measurement made at a given location and time should be treated 
as an individual station, using the depth or elevation of the measurement as primary 
variable and the other metadata and data variable assignments from Table 3-4. Trajec-
tory data of this form have exactly one sample per station. The number of stations 
equals the number of observation along the trajectory, which is usually large. 

 
Table 3-4: Recommended metadata and data variables for trajectory data. 

Meta-variables Values 

Cruise Cruise, expedition, or instrument name (text) 
Station Unique station identifier (text) 
Type B 
yyyy-mm-ddThh:mm:ss.sss Date and time of the measurement 
Longitude [degrees_east] Longitude of the measurement 
Latitude [degrees_north] Latitude of the measurement 
  
Bot. Depth [m] Bottom depth or elevation at station 
Unlimited number of other 
meta-variables describing the 
individual measurement 

(text or numeric) 

  

Data Variables Comment 

Continuous, decimal time vari-
able  

To be used as primary variable 

Unlimited number of other 
measured or calculated varia-
bles 

(text or numeric) 

 

3.3 Creating Collections 

New ODV collections can be created in a number of ways: (1) Using the File > New op-
tion, (2) opening a spreadsheet data file with File > Open, (3) by dropping spreadsheet 
data files onto the ODV icon (Windows only) or the ODV application window when no 
collection is open, or by using any of the Import main menu options. 

When using the File > New option a file-open dialog appears, and you specify a collec-
tion name and directory in which the collection will be created. The following charac-
ters are not allowed in collection names: \ / : * ? “ < > | SPACE.  

ODV then lets you define the metadata and data variables that will be stored in the col-
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lection. Both types of variables can be specified in a number of ways. You may use varia-
ble names taken from a supported template file (.txt, .odv, .var, or an ASCII spreadsheet 
file with arbitrary extension), you may enter the variable labels manually, or you may 
use pre-defined sets of variables (standard and user-supplied templates) suitable for 
various published oceanographic datasets (see Figure 3-1). The list of standard tem-
plates includes templates for Argo profile and trajectory data, World Ocean Database 
data published by the U.S. NODC and various data types from the World Ocean Circula-
tion Experiment (WOCE) as well as the Medatlas project.  

 

 
Figure 3-1: Collection template selection dialog. 

In addition to the pre-defined standard templates, the user may prepare custom collec-
tion templates and store these templates in the templates/collections subdirectory of 
the ODV user directory. User collection template files have the .odv extension and follow 
the format of .odv collection files. 

 

3.3.1 Using a File as Template 

If you are using a .txt, .odv, .var or other file as template (first option in Figure 3-1) a file 
open dialog will appear that lets you select the template file. ODV will then present the 
Metadata and Data Variables dialog (Figure 3-2) that allows modifying the metadata and 
data variables in different ways. 

Note that the first eleven meta-variables (up to and including Accession Number) are 
mandatory. Except for Accession Number you may change properties of mandatory 
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meta-variables (select the variable and press Edit), but you may not delete or reorder 
them. Other meta-variables may be reordered, deleted, or their properties may be ed-
ited. To add a not already used spreadsheet column label as meta-variable, select this 
label in the Spreadsheet Column Labels list and press the Meta Variables >> button. To 
add an additional meta-variable press New and define the properties of the new meta-
variable (see Properties dialog below). The total number of meta-variables is unlimited. 

 

 

Figure 3-2: The Metadata and Data Variables dialog. 

To inspect or modify the properties of a meta-variable select the variable and press 
Edit. A Properties dialog (Figure 3-3) appears that lets you specify label and units of the 
variable, the number of significant digits used to display values in the current station 
window (if numeric), the quality flag scheme to be used for this variable, and the data 
type and byte length (if text). 

When entering a label or units for the meta-variable you may use formatting control se-
quences to create subscripts, superscripts, and special symbols. Labels and units may 
not contain ‘;’ or ‘TAB’ characters. If you need better than about 100 m precision for 
station positions, make sure to use datatype DOUBLE for the longitude and latitude 
meta-variables. Also make sure not to use datatype TEXT for longitude, latitude, or any 
of the time meta-variables. For a description of the supported quality flag schemes and 
the mappings between the schemes see file ODV_QualityFlagSets.pdf. 
 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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Figure 3-3: Properties dialog for metadata and data variables. 

 
Once the set of meta-variables is defined you continue defining the data variables by 
adding, deleting, reordering variables or modifying their properties. When entering a 
label or units for the variable you may use formatting control sequences to create sub-
scripts, superscripts, and special symbols. Labels and units may not contain any of the 
following characters ‘;’ or ‘TAB’. For a description of the supported quality flag schemes 
and the mappings between the schemes see file ODV_QualityFlagSets.pdf. 
 
 

Table 3-5: ODV data value types for metadata and data variables. 

Name Bytes 
per 

Value 

Value Range Comment 

BYTE 1 0 to 255  

SIGNED_BYTE 1 –128 to 127  

SHORT 2 –32,768 to 32,767  

UNSIGNED_SHORT 2 0 to 65,535  

INTEGER 4 –2,147,483,648 to 2,147,483,647  

UNSIGNED_INTEGER 4 0 to 4,294,967,295  

FLOAT 4 3.4E +/- 38 (7 digits) default numeric type 

DOUBLE 8 1.7E +/- 308 (15 digits)  

TEXT 
 

ASCII + local charset user specified character length; 
add 1 byte for string termination 
character 

INDEXED_TEXT 
 

UTF-8 encoded strings of  arbi-
trary length 

4 byte string index stored in 
metadata file; actual strings are 
held in the stringpool file. 

 
 
Table 3-5 summarizes the different value types available for ODV metadata as well as 
data variables. The default type for numeric variables is FLOAT providing sufficient 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf


Version 5.1.0 

 34 

precision for most cases. Type DOUBLE should be used when more than 7 digits are 
required, for instance, for very precise longitude/latitude specifications. For variables 
with integral numbers of limited range consider using one of the 1 or 2 byte types to re-
duce collection storage size.  
There are two data types for storing text: TEXT and INDEXED_TEXT.  
 
You should use TEXT (and specify a maximal text byte length, add 1 byte for the text 
termination character) if 

• all text values have similar length, 
• the maximal text length is less than 10, 
• most text values differ, 
• the text contains only ASCII characters or local charset extensions and the 

collection is not meant for international distribution. 
 
You should use INDEXED_TEXT if 

• text values have highly variable length, 
• the same text values are used again and again, 
• the text contains non-ASCII characters. 

 
By default, ODV uses INDEXED_TEXT for cruise labels (same cruise label is usually used 
for many stations) and all metadata variables containing links to websites or web docu-
ments. 
 
 

3.3.2 Manual Entry 

If you choose manual entry of variables (option 2 in Figure 3-1) you will be prompted 
with separate Meta Variables and Data Variables (Figure 3-4) dialogs that allow modifi-
cations of meta- and data variables in ways similar to the ones described in section 3.3.1 
above.  

 

3.3.3 Using a Pre-defined Template 

If you choose one of the standard or user-supplied collection templates, ODV loads the 
lists of metadata and data variables from the template. Changes of the properties of the 
variables by the user are not supported. If you want to adapt standard variable tem-
plates, you should create a custom template and place the template in the tem-
plates/collections subdirectory of the ODV user directory. User collection template files 
have the .odv extension and follow the format of .odv collection files. 

As last step in the definition of new collections ODV presents the Collection Properties 
dialog (Figure 3-5), on which you can specify the field and type of data to be stored in 
the collection. You also select the primary variable, which is used to sort the data.  
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Figure 3-4: Dialogs for the definition of metadata and data variables.  

 
ODV then creates the collection and draws a global map on the canvas. Note that at this 
stage the collection is still empty and does not contain any station data. You must im-
port data into the collection using options from the Import menu on the menu bar. Note 
that all dialogs that appear during collection creation contain meaningful initial set-
tings. If you don’t have special requirements you can simply press OK on all these dia-
logs to generate perfectly valid collections. 

 

 
Figure 3-5: Dialog for the definition of collection properties. 

 

3.4 Collection Files 

This section provides an overview over the directory structure and the various files that 
make up an ODVCF6,  ODVCF5 or ODVGENERIC collection, respectively. The information 
is provided for expert users and may be useful in case of problems or unexpected be-
havior. Normally, a user need not be concerned with the collection file structure.  



Version 5.1.0 

 36 

3.4.1 ODVCF6 and ODVCF5 

The information about metadata and data variables is stored in file <col>.odv. This is 
the definition file of the collection <col>, and this file has to be selected when opening a 
collection. On Windows the .odv file type is associated with the ODV executable, e.g., 
double clicking on a .odv file will start ODV and open the collection. The directory con-
taining the .odv file is the collection’s root directory. All other files of the collection are 
contained in a subdirectory of the collection’s root directory named <col>.Data (collec-
tion base directory).  

The collection base directory contains the collection’s metadata and data files as well as 
a number of subdirectories for view, section or graphics object files. Subdirectory xview 
stores view files that define the way a user views the data in a collection. View files de-
fine settings such as map domain, station and sample filter settings, window layout and 
many other parameters.  

To copy, move or rename an ODVCF6 or ODVCF5 collection you use the Collection > Copy 
or Collection > Move/Rename options.  When copying or moving a collection manually 
please make sure to copy or move the .odv file as well as the <col>.Data directory, in-
cluding all the subdirectories. ODV collection files should not be edited manually. 

 
Table 3-6: Summary of ODVCF6 or ODVCF5 collection files. Collection names <col> may not contain charac-

ters / or \, and should not contain spaces.  

File Format Comment 

   

Collection file 
<col>.odv ASCII Defines metadata and data variables, collection field and type. On Windows 

this file type is associated with the ODV executable, e.g. double-clicking on 
the .odv file will start ODV and open the collection.  

   

Subdirectory <col>.Data 
metadata binary Stores the station metadata (name, position, date, etc.).  
data binary Stores the station data and quality flags. 
   
info ASCII Description of the collection (free form text format; file is optional).  
inventory binary Collection’s inventory listing by cruises. 
logfile ASCII Collection’s log file. Keeps records of data changes. 
settings ASCII Contains settings, such as key variable identifications, name of most recently 

used view file, or recent import and export directories.  
stringpool binary Contains INDEXED_TEXT string values and associated indexes.  
history binary Contains history string indexes.  
historypool binary Contains history strings.  

 
stringpool, history and historypool files only exist for ODVCF6 collections. 
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Table 3-7: Summary of ODVCF6 or ODVCF5 view and section files. File names <name> are arbitrary. Default 
location of xview and sec files is directory <col>.Data/views, but these files may also be stored in any other 

directory. 

Extension Format Comment 

<name>.xview ASCII View files storing layout, value ranges, derived and isosurface variable selec-
tions, and many other settings. The name of the parent collection is recorded 
inside the xview file. Derived variable settings are lost, if other collections 
use the xview file.  

<name>.sec ASCII Stores section outlines and characteristics. 
 

3.4.2 ODVGENERIC 

The ODVGENERIC collection format was introduced with the older ODV3 software and 
is still supported for backwards compatibility. Note that all new collections created by 
ODV are ODVCF6 collections.  

The list of data variables, the station metadata and the actual station data are stored in 
separate .var, .hob and .dob files. cfg files store view settings that define the way the 
user looks at the data in a collection. View settings include items such as map domain, 
station filter settings, window layout and many other parameters. The required .var, 
.hob and .dob files of a collection must all be located in the same directory (collection di-
rectory). cfg files may be stored anywhere on the disk.  

ODV collection files should not be edited manually. 

 
Table 3-8: Summary of ODVGENERIC collection files. Collection names <col> may not contain / or \, and 

should not contain spaces.  All files must be located in the same directory (collection directory). 

File Format Comment 

   

Basic files  Must be present.  
<col>.var ASCII Defines data variables, stores collection name and number of stations. On 

Windows this file type is automatically associated with the ODV executable, 
e.g. double-clicking on the .var file starts ODV and opens the respective col-
lection.  

<col>.hob binary Stores the station meta-data (name, position, date, etc.). 
<col>.dob binary Stores the actual station data and quality flags. 
   

Info File  Optional 
<col>.info ASCII Description of the collection (in freeform text format). ODV automatically 

creates an .info file containing information on dimensions and variables, 
when opening a netCDF file. 

   

Auxiliary Files  Automatically created if not present 
<col>.inv ASCII Collection inventory listing by cruises. 
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<col>.cid binary Cruise ID numbers 
<col>.log ASCII Collection log file. Keeps records of data changes. 
<col>.idv ASCII Lists IDs of key variables used as input for derived variables (depth, temper-

ature, oxygen, etc.) 
<col>.cfl ASCII Contains names of most recently used configuration file and output direc-

tory. 
 
 

Table 3-9: Summary of ODVGENERIC view and section files. File names <name> are arbitrary. cfg and sec 
files may be located in any directory. 

Extension Format Comment 

<name>.cfg binary Configuration files storing layout, value ranges, derived and isosurface vari-
able selections, and many other settings. The name of the collection that 
owns a configuration is recorded inside the cfg file. Certain restrictions ap-
ply, if a different collection uses the cfg file. 

< name >.sec ASCII Stores section outlines and characteristics. 
 
 

3.5 Platform Independence 

All ODV data collections and view files are platform independent and can be used on all 
supported systems (Windows, Mac OS, Linux, and UNIX) without modification.  
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4 Importing Data 

ODV can import new data and append the imported data to existing collections or add 
the data to automatically created new collections. Support is provided for a large vari-
ety of data file formats, including many common oceanographic data formats and a 
wide range of column-oriented spreadsheet files. Data imports can be done one file at a 
time, or, alternatively, by processing a possibly large number of import files in one go. 
The import files may be selected manually via file selection dialogs or by providing a list 
of file names in a separate file. File lists can easily be generated using the built-in list file 
generator. You may specify archives of import files (zip, gz, or tar.gz), unpacking is per-
formed automatically. 

All the importers described below can be run in two ways: (1) with or (2) without a col-
lection open at the time the import is initiated.  

(1) Collection open 

If a collection is open at the time an import is initiated ODV will analyze all selected im-
port files and construct the superset of variables contained in the files (source varia-
bles). ODV then presents dialogs allowing users to associate metadata and data varia-
bles in the import files with variables of the currently open collection (target variables). 
ODV then imports the data from all import files into the currently open collection.  

 (2) No collection open 

If no collection is open at the time an import is initiated ODV will also analyze all se-
lected import files and construct the supersets of metadata and data variables (source 
variables) contained in the files. Then ODV automatically creates one or more suitable 
target collections to receive the imported data. The target collections contain the sets of 
variables found in the import files during analysis. Associations between source and 
target variables are established automatically and the import proceeds without further 
user intervention.  

Data imports with automatically created target collections (type 2; no collection open 
when initiating the import) actually import all data of all metadata and data variables 
found in the import files. This should be the preferred import type when completeness 
of the imported data is the main concern. Importing into an existing collection (type 1; 
the collection is open when initiating the import) should only be used when the main 
concern is to extend the existing collection with new data. Note that in this import type, 
metadata or data in the import files for variables not included in the existing collection 
will not be imported. 

Table 4-1 below provides an overview of the different importers and ways of initiating 
data imports.  
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Table 4-1: ODV importers and ways of initiating the imports. 
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Import menu option          
File > Open option  ­ ­ ­ ­ ­ ­ ­ ­ 
File Drag and Drop  ­ ­ ­ ­  ­ ­  
Command File      ­ ­  ­ 

 

Import menu: This is the normal way of initiating an import. Select the appropriate en-
try from the Import menu and then select the files to be imported. When importing into 
an open collection some importers may be disabled to prevent import of incompatible 
data. For instance, time series data cannot be imported into a collection containing pro-
file data. 

File > Open option: The import via File > Open menu entry is a convenient way to initi-
ate the import of a single spreadsheet file. Once the Open dialog is shown, switch the 
type filter to Data Files and select a spreadsheet file. 

Drag and Drop: Some importers allow data import by simply selecting one or more 
files in the file browser and dropping these files onto the ODV window. ODV choses the 
appropriate importer based on the file type of the first dropped file. For unknown file 
types ODV Spreadsheet import is assumed. 

Command File: Some importers can be run in batch-mode by invoking an ODV com-
mand file. See chapter ODV Command Files for more information. 

Multi-file import: All importers allow multiple files per import. The import files may be 
selected manually via file selection dialogs, multi-file drag and drop or by providing a 
list of file names in a separate file. You can generate file lists easily with the built-in list 
file generator. This is useful if you want to import many files from more than one direc-
tory, or, simply, if you plan to repeat the import and don’t want to manually select a 
large number of files repeatedly. 

File-specific variables: All importers automatically construct lists of import metadata 
and data variables by analyzing the import files and collecting supersets of variables 
found in the files. Type 2 imports (no collection initially open) automatically create suit-
able target collections receiving the imported data for all variables in the import files. 
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4.1 ODV Spreadsheet Files 

ODV can read and import data from a variety of spreadsheet-type files. If the format of 
the import file is ODV generic spreadsheet format compliant, the data import will be 
fully automatic and no user interaction is required. Spreadsheet files can be opened and 
imported using menu options Import > ODV Spreadsheet and File > Open, or the import 
files can simply be dropped on the ODV window or icon. Non-compliant spreadsheet 
data files can be imported by ODV, however, ODV will prompt for user feedback, for in-
stance by identifying columns in the import file containing data for required metadata 
variables, such as longitude, latitude, date, or time. 

It is possible to import spreadsheet files with or without station metadata information 
and with or without column labels. ODV spreadsheet files may contain comments, and 
the column separation character may be TAB or semicolon. Missing data may be indi-
cated by special numeric or text indicators or by empty data fields. The spreadsheet 
files may contain data for many stations from one or more cruises. Each station may 
contain an unlimited number of samples (one line per sample). The samples of a station 
must be in consecutive order but need not necessarily be sorted.  

When reading a spreadsheet file, ODV breaks the data into stations whenever one or 
more of the entries for Cruise, Station, Type, and, if it exists, LOCAL_CDI_ID change from 
one line to the next. A station break also occurs if the date/time, longitude and/or lati-
tude change by more than some specified tolerances, even if Cruise, Station, and Type 
remain unchanged. The default tolerance values are one hour and 0.1 degrees longitude 
or latitude. These values may be modified via the View > Settings  > Spreadsheet Import 
option. 

If Station information is not provided in the data file, the Date, Time, Longitude and Lati-
tude values are checked, and a station break occurs whenever one or more of these val-
ues change. All metadata of a station, such as date/time, longitude, and latitude, are 
taken from the first sample line of the station in the import file. 

Imported data from the file are added to the currently open data collection, or, if no col-
lection is currently open, are added to a suitable, newly created collection. 

To import data from a spreadsheet file into the currently open collection choose Import 
> ODV Spreadsheet and use the standard file-select dialog to identify the data file. Spec-
ify import options and press OK to start the data import.  Spreadsheet files can also be 
dragged and dropped onto the ODV icon or an open ODV window. 
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Figure 4-1: The spreadsheet file properties dialog. 

 

If the file is not a generic ODV spreadsheet file, a Spreadsheet File Properties dialog box 
appears and lets you specify the column separation character and one or more missing 
data values. Note that multiple missing data values must be separated by one or more 
spaces. Fields in the import file that are empty or contain one of these values are con-
sidered missing data. You can also specify the first data line and the lines containing the 
column labels and units. The latter two line numbers should only be different if labels 
and units are on separate lines. ODV provides reasonable defaults for all items and only 
a few changes should be necessary in most cases. For the Column separator choose the 
character that will give a vertical list of labels in the Column labels box. Press OK when 
all spreadsheet file properties are set, or press Cancel to abort the import. 

If the labels for the metadata columns differ from the recommended labels defined in 
the ODV generic spreadsheet format (see below), a Meta Variable Association dialog box 
appears. This dialog lets you associate input columns with the collection meta-varia-
bles, or it lets you set defaults for those meta-variables not provided in the input file. Al-
ready associated variables are marked by asterisks (*). See chapter Meta Variable Asso-
ciation Dialog for more details. 
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4.2 SDN Spreadsheet and netCDF Files 

The European SeaDataNet (SDN) project allows retrieval of oceanographic data from a 
network of European data centers (http://www.seadatanet.org). As the result of a data 
query SDN delivers a number of zip files, one from every data center responding to the 
query. These zip files contain a potentially large number of individual data files, each 
one holding the data of a single profile, time-series or trajectory.  

SDN data files are delivered in ODV spreadsheet format or as netCDF files. The Import > 
SeaDataNet Formats option allows to import both types of data files and provides an 
easy data import procedure, even for very large numbers of files. All selected individual 
import files (you can combine zip, csv, txt and nc files in a single import step) will be 
processed in one step, and separate ODV data collection will be created and filled for 
every data type found in the SDN import file set.   

Once you have downloaded the SDN data .zip files invoke Import > SeaDataNet Formats. 
Then navigate to the directory containing the downloaded files and select the files that 
you want to import. Note that every time you initiate a SDN import, a subdirectory will 
be created in the SDN parent directory, and the output from the import process will be 
written to this subdirectory. The name of the SDN parent directory can be inspected 
and modified via View > Settings > Import > SDN Import. The name of the subdirectory 
into which the new collections are written consists of the current date and time and will 
be unique for all SDN imports that you perform.  

ODV will automatically unzip all selected SDN .zip archive files and will analyze the con-
tents of all individual extracted spreadsheet or netCDF files. This includes analyzing the 
SDN semantic header lines as well as the column header lines of the input files, testing 
for SDN spreadsheet format compliance (non-compliant files are excluded), gathering 
information about available variables and grouping of files according to the primary 
variables encountered in the files. In addition, ODV will search for .csv metadata files 
and extract its contents into additional meta-variables. The contents of  
//<SDN_REFERENCES> and //<sdn_reference> comment lines is extracted and pro-
vided in the Reference meta variable. LOCAL_CDI_ID, EDMO_code and URL entries in the 
Reference meta variable are clickable, thereby opening documents with more in-depth 
information in the web-browser. The contents of the readme.txt file (if any) is extracted 
and used for the usage agreement dialogs of all created collections. 

ODV will create separate data collections for every data type encountered and will im-
port the data of the matching files into the particular collection. Once the SDN import 
process has finished you can open the newly created collections via the File > Recent 
Files option. Use Collection > Move / Rename if you want to move the collections to a dif-
ferent directory and/or give them names of your choice.  

Following below is a detailed description of the strategies applied by ODV for the crea-
tion of target collections and the composition of variable sets in each of them.  

As first step, ODV parses the column header lines of all SDN import files, detects the pri-
mary variable (first variable after the meta-variables) used in any given file and groups 

http://www.seadatanet.org/
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the import files according to their primary variable. For every file group ODV then com-
piles the superset of variables occurring in these files and subsequently creates one 
ODV collection consisting of all variables in the compiled superset. Data from all files in 
the group are finally imported into that particular collection. 

While compiling the superset of variables of a given file group, a new variable is created 
whenever a new variable label is found in the column header line of a file, regardless of 
its SDN parameter code in the semantic header. If, for instance, the two labels Tempera-
ture_sensor1 and Temperature_sensor2 (both with semantic header entry 
SDN:P01::TEMPPR01) are found in a single file or in separate files of the group, ODV will 
create separate variables Temperature_sensor1 and Temperature_sensor2 in the target 
collection. 

Separate variables are also created if the same variable name but different units appear 
in different files. Encountering, for instance, Phosphate [umol/l] and Phosphate 
[umol/kg] in two files will result in two separate variables. Note that in any given file 
the variable names in the header line must be unique. Using the same name more than 
once in a given file (as in Phosphate [umol/l] and Phosphate [umol/kg]) is not supported 
by ODV. Two variants of a given variable may appear in a single file but the variable 
names must be different (e.g., Phosphate_1 and Phosphate_2). 

The rules above for creating separate variables do not apply for variables listed in the 
Labels group of the sdn_import_settings.xml file located in the <install>/include/import 
directory. Note that users may create an additional sdn_import_settings.xml file in the 
<user>/import directory containing additional, user specific settings. User settings pre-
vail in case of conflicts. 

Whenever a variable included in the Labels group of the sdn_import_settings.xml file is 
encountered in a SDN import file the variable label specified in the settings file is used 
rather than the label in the SDN import file. For instance, variables with codes 
SDN:P01::PRESPR01, SDN:P01::PRESPS01, and SDN:P01::PRESPS02 are all assigned the 
label Pressure, and only one data variable Pressure is created. During import, data from 
all three import variables will be assigned to the single Pressure target variable.  

The combination of several individual variables into one target variable only works for 
individual variables using the same units. Separate variables are created if different 
units are found. If, for instance, in the example above the SDN:P01::PRESPR01 and 
SDN:P01::PRESPS01 variables use dBar, while SDN:P01::PRESPS02 uses Bar, two target 
variables Pressure [dBar] and Pressure [Bar] are created. During import 
SDN:P01::PRESPR01 and SDN:P01::PRESPS01 are loaded into Pressure [dBar] and 
SDN:P01::PRESPS02 is loaded into Pressure [Bar]. 

If you want to ensure that data for two or more SDN parameter codes are merged into a 
single data variable you should create a user settings file 
<user>/import/sdn_import_settings.xml and add entries for the particular codes. For 
instance, if you know that different codes SDN:P01::ODSDM021, SDN:P01::PPSUCS01, 
SDN:P01::PSALCC01, etc. are used for Salinity in different SDN import files and you want 
to merge all these data into a single variable Salinity you should add the following lines 
to the <Labels> tag of your user sdn_import_settings.xml file: 
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<Entry code="SDN:P01::ODSDM021" value="Salinity" /> 
<Entry code="SDN:P01::PPSUCS01" value="Salinity" /> 
<Entry code="SDN:P01::PSALCC01" value="Salinity" /> 

 
As noted above, the merging into a single target variable only works for individual vari-
ables using the same units. 
 
The sdn_import_settings.xml file also contains the <PrimaryVarAttributes> tag specifying 
target collection names, collection field (one of the following: GeneralField, Ocean, 
Atmosphere, Land, IceSheet, SeaIce, Sediment) and collection data types (one of the fol-
lowing: GeneralType, Profiles, Trajectories, TimeSeries) for known primary variables. 
You may specify additional entries in your user sdn_import_settings.xml file. 

Once you have imported SDN data files you can open any one of the produced collec-
tions and perform automatic aggregation of variables using the Export > Station Data > 
SDN Aggregated ODV Collection option. 

4.3 World Ocean Database Data 

You can use ODV to import original hydrographic data from the  World Ocean Database 
(WOD) of the U.S. NODC into existing or new data collections. A WOD import can also be 
invoked without open collection; then a suitable target collection receiving the im-
ported data is created automatically. ODV supports WOD versions 2013, 2009, 2005, 
2001 and 1998. You can use data files either from the WOD CD-ROMs or files down-
loaded from the WOD web site. Please make sure to obtain data files in WOD native 
ASCII format; WOD data as netCDF or csv files cannot be imported. 

To import WOD data into an existing collection, open the collection. To import into a 
new collection, create the collection and make sure you choose World Ocean Database 
variables when defining the data variables. To manually select one or more WOD data 
files for import into the currently open collection choose Import > U.S. NODC Formats > 
World Ocean Database. Use the standard file open dialog to select one or more WOD .gz 
data files to be imported. Choose file-type All Files (*.*) if you want to select WOD files 
that are already unzipped.  

Then specify import options and press OK to start the data import. ODV will read the se-
lected WOD data files and import all stations that satisfy the station filter settings. The 
cruise labels of the imported stations consist of the WOD identifier (WOD13, WOD09, 
WOD05, WOD01 or WOD98) followed by the two character NODC country-code and the 
unique OCL cruise number. Individual entries are separated by underscores “_”. (Note: 
To create simplified cruise labels without the OCL cruise number modify the WOD Im-
port settings via the View > Settings option and check the Short WOD cruise labels box.) 

The unique OCL profile number is used by ODV as station number. ODV recognizes and 
uses the NODC data quality flags found in the import files (see below). Quality flags pro-
vided by the data originators are ignored. OCL cruise number, the originator’s cruise 
and station names and the name of the investigator are provided as additional 
metadata. 

http://www.nodc.noaa.gov/OC5/WOD13/
http://www.nodc.noaa.gov/OC5/WOD13/
http://www.nodc.noaa.gov/OC5/WOD09/pr_wod09.html
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As an alternative to manual selection of import files using the file open dialog, you can 
prepare an ASCII file containing the names of all the files that you want to import and 
then select the list file on the file open dialog. This is useful if you want to import many 
files from more than one directory, or, simply, if you plan to repeat the import and don’t 
want to manually select a large number of files again. The filenames in the list file must 
be absolute pathnames, one filename per line. Default extension of ODV list files is .lst. 
You can generate file lists easily with the built-in list file generator. 

Once the list file is created you choose Import > U.S. NODC Formats > World Ocean Data-
base and select the previously created list file. As before, you then specify import op-
tions and press OK to start the data import. ODV will read all the files listed in the list 
file and will import all stations into the currently open collection. 

Please note that WOD data have been quality controlled and often contain significant 
amounts of data that have been flagged by data originators or by the U.S. NODC as being 
of poor or questionable quality. ODV imports and maintains the data quality infor-
mation in the WOD files, and automatically maps WOD quality flags to the quality flag 
scheme used in the target data collection. If the target collection was created using 
World Ocean Database variables, the data variables use the WOD quality flag scheme, 
and the original WOD quality flags in the import files will be maintained in the ODV col-
lection. When viewing the data, you should consider applying data quality and range fil-
ters via option Sample Filter to exclude questionable and bad data from the analysis.  

4.4 Argo Float Data 

You can use ODV to import profile and trajectory data from single or multiple Argo core 
and bio netCDF version 3.1 format files into ODV float profile or trajectory data collec-
tions. Argo imports can also be invoked when no collection is open; a suitable target col-
lection receiving the imported data is created automatically in such a case. Argo files 
can be downloaded from the Coriolis and GODAE data centers at http://www.corio-
lis.eu.org/  and http://www.usgodae.org/argo/argo.html. ODV accepts Argo .nc files as 
well as .gz or .zip packages. 

Argo data should be imported into data collections using the Argo profile or trajectory 
variable sets. If you don’t already have such a collection open, create one using the File > 
New option. When prompted to define the data variables choose Argo Profile or Argo 
Trajectory depending on the type of data that you want to import. If you want to also 
import data for Argo intermediate parameters choose Argo Profile (including intermedi-
ate variables). Once the receiving collection has been created and is open initiate the 
data import by choosing Import > Argo Formats > Float Profiles (netCDF v3.1) or Import 
> Argo Formats > Float Trajectories (netCDF v3.1). ODV then presents a standard file 
open dialog and lets you select one or more Argo netCDF data files in a given directory. 
Alternatively, you may select an ASCII file containing the list of file names to be pro-
cessed. This list file has to be prepared before you start the import. It must contain one 
absolute filepath entry per line. The list file must have extension .lst. You can generate 
file lists easily with the built-in list file generator.  

http://www.coriolis.eu.org/cdc/argo.htm
http://www.coriolis.eu.org/cdc/argo.htm
http://www.usgodae.org/argo/argo.html


ODV User’s Guide  
 

    47 

ODV then displays the import options dialog. If you import into a collection created spe-
cifically for Argo float profile or trajectory data (see above) simply press OK to start the 
data import. 

The variables in Argo profile or trajectory collections include pressure, temperature, sa-
linity, oxygen, and many bio-optical variables provided in bioArgo files. These variables 
come in two versions: (1) the real-time or original data (first group; suffix (original) in 
the variable label), and (2) the delayed-mode or adjusted data (second group; suffix 
(adjusted)). Adjustment error data found in the files are used as 1-σ error data for the 
respective adjusted variable. Note that real-time data files do not contain adjusted data.  

Argo data quality flags in the netCDF file are recognized and converted to the quality 
flag schemes of the target variables during import. If the target collection is an Argo 
profile or trajectory collection the original Argo quality flag values are used and no 
quality flag conversion occurs. For details of the quality flag mapping see the file 
ODV_QualityFlagSets.pdf.  

For Argo profile data, the ODV station name consists of cycle number, an optional sub-
cycle indicator (a, b, c, etc.), the data mode indicator (R real time data, D delayed mode 
data, A real time data with adjusted values) and the profile direction code (A ascending, 
D descending). For Argo trajectory data, the ODV station name consists of trajectory in-
dex and the data mode indicator (R real time data, D delayed mode data, A real time 
data with adjusted values). The suffix _bio is appended to the station name if the data 
are imported from a bio Argo file. As an example, the station label 71a_R_A denotes a 
station containing the real time data from the second ascending profile of float cycle 71. 
Label 15_D_A is for delayed mode data of the first ascending profile of float cycle 15. See 
the value of the Vertical Sampling Scheme meta variable for a description of the respec-
tive profile measurements. 

The Argo platform number is used for the Cruise meta variable in all cases. When im-
porting Argo trajectory files only cycles with valid geographical position are imported. 

Argo profile and trajectory imports following procedures above exclude the intermedi-
ate Argo parameters (see Argo reference table 3) that are defined for many bio-optical 
and bio-chemical parameters and are contained in some bioArgo files. You can include 
the intermediate parameters in the import by first creating a new target collection via 
File > New and selecting the Argo Profile (including intermediate variables) collection 
template. With this collection open then initiate the Argo import via Import > Argo For-
mats > … and then proceed as above. 

Once imported, you may filter the data and exclude bad data from the analysis by set-
ting appropriate quality flag selection criteria via the View > Sample Filter option. 

4.5 GTSPP – Global Temperature-Salinity Profile Program 

You can use ODV to import data from GTSPP netCDF version 3.8 and 4.0 format files 
into ODV data collections. A GTSPP import can also be invoked without open collection; 
a suitable target collection receiving the imported data is created automatically in such 
cases. GTSPP files can be downloaded from the US National Oceanographic Data Center 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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at http://www.nodc.noaa.gov/GTSPP/. 

GTSPP data should be imported into data collections using the GTSPP variables. If you 
don’t already have such a collection open, create one using the File > New option. When 
prompted to define the data variables choose GTSPP (Global Temperature-Salinity Pro-
file Program). To initiate the data import choose Import > U.S. NODC Formats > GTSPP. 
ODV then presents a standard file open dialog and lets you select one or more zipped 
GTSPP package files (.tgz or .zip) or GTSPP netCDF data files (.nc) in a given directory. 
Alternatively, you may select an ASCII file containing the list of file names to be pro-
cessed. This list file has to be prepared before you start the import. It must contain one 
file path entry per line and the file paths must be absolute pathnames. The list file must 
have extension .lst. You can generate file lists easily with the built-in list file generator. 

ODV then displays the import options dialog. If you import into a collection created for 
GTSPP data (see above) you may simply press OK to start the data import. 

The variables in GTSPP collections are depth, temperature and salinity. Any pressure 
values in GTSPP files are converted to depth during import. GTSPP collections have an 
additional metavariable called Data Type. This variable holds information about the in-
strument type or type of IGOSS radio message used. You need ODV version 4.4.2 or 
higher to access this information. Previous versions do not display these values. 

GTSPP data quality flags in the netCDF file are recognized and converted to the quality 
flag schemes of the target variables during import. If the target collection is a GTSPP 
collection (recommended) created by ODV or later, no quality flag conversion occurs, 
and the original GTSPP quality flag values are stored in the collection. For details of the 
quality flag mapping see the file ODV_QualityFlagSets.pdf. 

Once imported, you may filter the data and exclude bad data from the analysis by set-
ting appropriate quality flag or range sample filter settings.  

4.6 GOSUD – Global Temperature-Salinity Underway Data 

You can use ODV to import data from GOSUD netCDF version 3 format files into ODV 
data collections. A GOSUD import can also be invoked without open collection; a suita-
ble target collection receiving the imported data is created automatically in such cases. 
GOSUD real-time and delayed-mode files can be downloaded from 
http://www.gosud.org/.  

GOSUD data should be imported into data collections using the GOSUD variables. If you 
don’t already have such a collection open, create one using the File > New option. When 
prompted to define the data variables choose GOSUD (Global Ocean Surface Underway 
Data). To initiate the data import choose Import > GOSUD netCDF v3. ODV then presents 
a standard file open dialog and lets you select one or more GOSUD netCDF data files 
(.nc) in a given directory. Alternatively, you may select an ASCII file containing the list of 
file names to be processed. This list file has to be prepared before you start the import. 
It must contain one nc file path entry per line and the file paths must be absolute path-
names. The list file must have extension .lst. You can generate file lists easily with the 
built-in list file generator. 

http://www.nodc.noaa.gov/GTSPP/
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.gosud.org/
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ODV then displays the import options dialog. If you import into a collection created for 
GOSUD data (see above) you may simply press OK to start the data import. 

The variables in GOSUD collections are depth, temperature and salinity. Quality con-
trolled delayed-mode data usually contain adjusted temperature and salinity data in ad-
dition to the original values. 

GOSUD data quality flags in the netCDF file are recognized and converted to the quality 
flag schemes of the target variables during import. If the target collection is a GOSUD 
collection (recommended) created by ODV or later, no quality flag conversion occurs, 
and the original GOSUD quality flag values are stored in the collection. For details of the 
quality flag mapping see the file ODV_QualityFlagSets.pdf. 

Once imported, you may filter the data and exclude bad data from the analysis by set-
ting appropriate quality flag or range sample filter settings.  

4.7 WOCE Hydrographic Data 

You can use ODV to import original hydrographic data in WHP exchange format into ex-
isting or new data collections. WOCE imports can also be initiated with no collection 
open. In these cases the superset of variables contained in the import files is deter-
mined and a suitable receiving collection is created automatically. 

WHP exchange format data files can be found at the CLIVAR & Carbon Hydrographic 
Data Office (CCHDO).  

To import the data into an existing collection, open the collection. To import into a new 
collection, create the collection and make sure you choose either WOCE WHP Bottle var-
iables or WOCE WHP CTD variables when defining the variables to be stored in the col-
lection. To automatically create a suitable collection based on the content of the se-
lected WOCE import files, simply initiate the appropriate WOCE import using Import > 
WOCE Formats > ... without any open collection and specify name and location of the 
new ODV data collection. 

To import WHP exchange format bottle data into the currently open collection choose 
Import > WOCE Formats > WHP Bottle (exchange format) from ODV’s main menu. Use 
the standard file-selection dialog to select the WHP data set. The default suffix of WHP 
bottle exchange files is _hy1.csv. If your data file has a different extension, choose file-
type All Files in the file-selection dialog. Then specify import options and press OK to 
start the data import. ODV will read and import all stations in the data file. ODV identi-
fies and imports the WOCE data quality flags in addition to the actual data values. These 
quality flags can later be used to filter the data by excluding, for instance, bad or ques-
tionable data from the analysis. You can modify the data quality filter by choosing selec-
tion criteria from the map popup menu (choose the Sample Selection tab). 

When importing files with more than one station, ODV will break stations whenever 
cruise names or station numbers change. Station longitude, latitude and time of occupa-
tion are obtained as averages of individual sample values. Samples with invalid longi-
tude or latitude values are not imported.  

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://whpo.ucsd.edu/format.html
http://cchdo.ucsd.edu/
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Comments at the top of WOCE WHP Bottle files are extracted and stored in separate 
text files as part of the collection. Links to these files are recorded in meta-variable Com-
ments and the contents can be viewed by simply clicking on the Comments link. Cruise 
reports found alongside the data files are also added to the collection and links to the 
cruise reports are maintained in meta-variable Report. Clicking on the Report item 
brings up the document in your web browser. 

To import CTD data into the currently open collection, choose Import > WOCE Formats > 
WHP CTD (exchange format) from ODV’s main menu and select the _ct1.zip file that con-
tains the CTD data to be imported. After setting the import options ODV will then un-
pack the zipped file and import all CTD stations into the currently open collection. Im-
port files with different extensions can be selected by switching the file-type filter to ei-
ther _ct1.csv for single CTD profiles or All Files. 

You can import data from multiple WHP Bottle or CTD exchange files in a single import 
operation. One way to do so is to prepare an ASCII file with default extension .lst that 
contains the names of the files to be imported. Use full pathnames, and specify one file 
name per line. Then choose either WOCE formats > WHP Bottle (exchange format) or 
WOCE formats > WHP CTD (exchange format), change the file-type filter to .lst, select 
your list-file, specify import options and press OK to start the data import. Another way 
of multi-file data import is to simply select multiple WHP bottle or CTD exchange files 
on the file-open dialog. When selecting multiple .lst list files only the first one will be 
recognized for data import. 

4.8 Medatlas Format Data 

The Medatlas format was used to create the MEDAR/Medatlas 2002 data compilation, 
containing water column data for the Mediterranean and Black Sea (MEDAR Group, 
2002 - MEDATLAS/2002 database, Mediterranean and Black Sea database of tempera-
ture salinity and bio-chemical parameters. Climatological Atlas. IFREMER Edition (4 
CDs)). The Medatlas format is also used for various types of time series data, ranging 
from current meters, thermistor chains, sea level gauges, meteorology buoys to sedi-
ment traps.  

ODV lets you import all these diverse data types. Because variable sets for the different 
data types differ greatly, it is essential to ensure that the receiving data collection uses a 
matching set of variables. There are predefined variable sets for Medatlas bottle and 
CTD profile data, as well as two variable sets for time series data (one for sediment trap 
data and one for all other time series data). When creating new collections for Medatlas 
data the user should choose the appropriate variable set (see below). 

Medatlas formatted data can be imported into arbitrary ODV data collections; however, 
manual associations of Medatlas import variables with the collection target variables 
are usually required. Note that Time in Medatlas time series collections is always pro-
vided as years since 1900-01-01 00:00. It is not possible to use other units (e.g., days) or 
use a different reference date. To facilitate data import and avoid manual variable asso-
ciations you should create target collections using the appropriate Medatlas variables 
sets. To create such collections use the File > New option. When prompted to define the 
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data variables choose Medatlas Bottle variables for Medatlas bottle data, Medatlas CTD 
variables for Medatlas CTD, XBT or MBT data, Medatlas Sediment Trap variables for 
Medatlas sediment trap data, or Medatlas Time Series variables for all other Medatlas 
time series data (e.g., data from current meters, thermistor chains, sea level gauges, or 
meteorology buoys).  

A Medatlas import can also be invoked without open collection; a suitable target collec-
tion receiving the imported data is created automatically in such cases. 

To initiate the data import choose Import > Medatlas Formats > Profile Data for bottle, 
CTD, XBT or MBT data or Import > Medatlas Formats > Time Series Data for any kind of 
time series data. Both import types allow selection of one or more Medatlas data files to 
be imported. Alternatively, you may also select a text file containing the list of file 
names to be processed. This list file has to be prepared before starting the import. It 
must contain one file entry per line and the file names must be absolute pathnames. The 
list file must have extension .lst. You can generate file lists easily with the built-in list file 
generator. 

Note that Medatlas time series and sediment trap data collections created by ODV con-
tain a meta-variable Instrument Depth that contains the deployment depths of the re-
spective instruments, such as current meters, thermistors, sea level gauges, meteorol-
ogy buoys or sediment traps.  

The GTSPP quality flags in Medatlas data files are recognized and converted to the qual-
ity flag schemes of the target variables during import. If the target collection is a Medat-
las profile, time-series or sediment trap collection created by ODV or later, no quality 
flag conversion occurs, and the original GTSPP quality flag values are stored in the col-
lection. For details of the quality flag mapping see the file ODV_QualityFlagSets.pdf.  

4.9 Sea-Bird CNV Files 

You can use ODV to import data from Sea-Bird .cnv files into an existing collection or an 
automatically created new ODV data collection suitable for the particular contents of 
the import files.  Sea-Bird .cnv files are created from raw Sea-Bird files using Sea-Bird’s 
SBE Data Processing software. When importing such files, ODV can split down- and up 
casts into separate stations. ODV can also bin-average the data using a user specified 
pressure bin-size. 

To import data from Sea-Bird .cnv files into an existing ODV data collection, first open 
the receiving collection in ODV. Then drag and drop one or more Sea-Bird CNV files 
onto the ODV application window. Alternatively, select Import > Sea-Bird CNV from the 
main menu and select one or more Sea-Bird .cnv files. You may also select an ASCII file 
containing the list of .cnv file names to be processed. This list file has to be prepared be-
fore you start the import. It must contain one file path entry per line and the file paths 
must be absolute pathnames. The list file must have extension .lst. You can generate file 
lists easily with the built-in list file generator. ODV then displays the import options dia-
log and, if accepted, will then import all selected files. 

If no collection is open when you drop Sea-Bird .cnv files onto the ODV window or you 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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select Sea-Bird .cnv files via the Import > Sea-Bird CNV option ODV will analyze the con-
tents of the Sea-Bird files and will automatically create a collection with all the variables 
contained in the import files. This collection will then receive the data from the files. 
ODV will display a standard file save dialog and you may specify name and path of the 
newly created data collection.  

The first variable in the .cnv files containing one of the following strings depth, pressure, 
time, or julian days as part of their name becomes the primary variable of the newly cre-
ated collection. This should be pressure or depth in case of profiles or a time variable in 
case of time-series. If the depth, pressure or time variables in the .cnv files use different 
names and are not automatically identified you must manually set the collection’s pri-
mary variable once the import has finished. See chapter Changing Collection Properties 
for instructions on how to do this and ensure that pressure or depth are chosen for ver-
tical profile files and a time variable, such as Julian Days, for time series data. 

ODV can bin-average profile Sea-Bird data using a user-specified pressure bin width. 
For each file, ODV will search for a vertical coordinate variable, convert the data to pres-
sure, if necessary, and perform the bin-averaging. Presently, ODV searches for the fol-
lowing Sea-Bird parameter codes in the specified order: 

1. Pressure [db]: prM, prDM, pr50M, prSM, prdM (no conversion) 

2. Pressure [psi]: prE, prDE, pr50E, prSE, prdE (multiplied by 0.0689476) 

3. Pressure, FGP [KPa]: fgp0-fgp7 (multiplied by 0.001) 

4. Depth [m]: depSM, depFM, dNMEA  (TEOS10 conversion) 

5. Depth [ft]: depSF, depFF (multiplied by 0.3048 , TEOS10 conversion) 

For each file containing pressure or depth data, ODV can check whether the file contains 
down and up casts and store the data in two separate stations. In the target collection 
up and down casts are marked by up-cast and down-cast strings in the Cast Type meta 
variable. Splitting up and down casts can be switched on or off on the settings dialog. 

Sea-Bird .cnv file headers may differ considerably in the number and format of 
metadata items provided. ODV recognizes metadata items, such as cruise name, station 
name, date and time, longitude and latitude, if the following rules are satisfied: 

1. The metadata lines must start with ‘**’ (user metadata) or ‘* NMEA’. 

2. NMEA metadata must contain the ‘=’ character to separate name and value parts 
(e.g. * NMEA Latitude = 44 01.58 N), while user metadata must use ‘:’ as separator 
(e.g., ** Latitude: 44 01.58 N). 

3. The following NMEA metadata are supported: NMEA Latitude, NMEA Longitude and 
NMEA UTC (Time). 

4. The cruise name must be labeled Cruise. 

5. The station name must be labeled Station or contain the word Station. 

6. Longitude and latitude must be labeled Longitude and Latitude. 
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7. Longitude and latitude values must follow the format ‘(D)DD MM.mm O’, where 
(D)DD represents a two or three digit degrees value, MM.mm represents decimal 
minutes and O represents the orientation N, S, E or W. 

8. Date and Time must be labeled UTC (Time). 

9. Date and Time must follow the format ‘MMM dd yyyy hh:mm:ss’ where MMM rep-
resents the 3-character English month abbreviation (e.g. May). 

10. Bottom depth information must be labeled as Bottom Depth [m]. 

 
Sea-Bird .cnv files may contain the data of multiple casts. A multi-cast .cnv file must con-
tain special cast description lines in the header of the file. There must be one cast de-
scription line for every cast in the file. Cast description lines must be of the following 
form: 
* cast   4 07 Jul 2015 09:00:29 samples 6415 to 7768, avg = 1, stop = mag switch 

where the samples entry specifies the first and last data line index of the respective cast. 
The first data line after the *END* header termination has data line index 1.  

Please note that the data of a Sea-Bird .cnv file are not imported if longitude or latitude 
cannot be retrieved from the file. If the cruise and/or station names are not found ODV 
assigns unknown and the file’s name, respectively.  

Collections created during import of Sea-Bird .cnv files contain an additional Comments 
meta variable holding for every station the name of an automatically created comments 
file located in the misc/comments directory of the collection. The comments file contains 
all header lines extracted from the top of the .cnv file, usually containing important in-
formation such as sensor identification and calibration data. Clicking on the Comments 
metadata value shows the contents of the comments file in your web-browser. ODV also 
extracts operator and ship/vessel metadata from the cnv file and provides the values in 
the Operator and Ship meta variables. 

4.10 Associate Meta-variables Dialog 

When importing data, ODV tries to automatically locate the mandatory metadata in the 
import file, such as cruise and station names, date of observation as well as longitude 
and latitude. If this automatic association of meta-variables is not successful and the im-
port is into an existing collection (import type 1) the Associate Meta Variables dialog ap-
pears (see Figure 4-2), asking the user to identify the sources of metadata manually.  

To define a new association select items in the Source Variables and Meta Variables lists 
and press Associate. To invoke a conversion during import press Convert and choose 
one of the available conversion algorithms. To delete an existing association, select the 
respective variables and press Undo. If the import file does not contain information for a 
given meta-variable you can specify a default value as follows: (1) select the respective 
meta-variable; (2) press Set Default and (3) enter the default value. Note that the speci-
fied default settings are used for all data lines in the file. Press OK when done or Cancel 
to abort the import procedure. Note that the Longitude and Latitude meta-variables 
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have to be associated (ODV cannot handle stations without given geographical posi-
tion), and that the OK button will remain disabled otherwise. 

Note that associations or conversions of composite source variables, such as the ISO 
8601 date and time specification YYYY-MM-DDTHH:MM:SS.SSS will automatically con-
nect with multiple target meta-variables (e.g., Year, Month, Day, etc.). 

 

 
Figure 4-2: The Associate Meta Variables dialog 

 

4.11 Import Options Dialog 

When importing data into an existing collection (import type 1), ODV will present an 
Import Options dialog that lets you connect source data variables in the import files with 
the data variables in the target collection. You can also select the import mode and spec-
ify parameters required for checking whether stations being imported already exist in 
the target collection (see Figure 4-3). 
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Figure 4-3: The Import Options dialog 

 

Import Mode 

Add/Replace Station Data: Choose this option if you want to add data from the im-
port file to the collection. If the Check for existing stations box is checked, ODV 
searches the target collection for matching stations by applying user-specified cri-
teria, and, if found, asks for permission to replace the existing station in the target 
collection with the new data from the import file (see Station and Sample Match-
ing Criteria below for a description of the station search procedure). 

 
Merge Data (selected variables): Choose this option if you want to add data for one 
or more variables (merge variables) and leave existing data for other variables 
unchanged. A merged value of a merge variable at a given sample depends on ex-
isting and new data values as shown in table 4-2. Note that the Check for existing 
stations box cannot be unchecked for this mode. Before adding data, ODV searches 
the collection for matching stations (see Station and Sample Matching Criteria be-
low for a description of the station search procedure) and if found, reads the origi-
nal station from the collection, adds the data for the selected variables and re-
places the original station with the updated version. If no matching station is 
found, the user is notified. 
 
For Merge Data (selected variables) imports you must ensure that the primary var-
iable of the target collection is associated with one of the source variables. This 
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linkage is necessary for correct identification of the samples receiving the im-
ported data. The OK button on the Import Options dialog (see Figure 4-3) is disa-
bled if the primary variable is not associated. Use option Collection > Properties > 
General for determining the primary variable of your collection. 
 

Table 4-2: Results of merging existing and imported values. 

Existing value New value Merged value 

yes yes Average of existing and new values 

yes no Existing value 

no yes New value 

no no Missing value 

 
 
Update Data (selected variables): Choose this option if you want to update data for 
one or more variables (update variables) and leave existing data for other varia-
bles unchanged. An updated value of an update variable at a given sample only de-
pends on the new data values and existing values are discarded. Note that the 
Check for Existing Stations box cannot be unchecked for this mode. Before updat-
ing data, ODV searches the collection for matching stations (see Station and Sam-
ple Matching Criteria below for a description of the station search procedure) and 
if found, reads the original station from the collection, updates the data for the se-
lected variables and replaces the original station with the updated version. If no 
matching station is found, the user is notified. 

 
Variable Association 

Usually the number, order and meaning of variables in the import file differ from 
the number, order and meaning of variables in the target collection, and connec-
tions between source and target variables have to be established before the actual 
data import can take place. ODV first tries to automatically connect variables with 
matching labels (name and units) and marks the associated variables with an as-
terisk * in the source and target variable lists of the dialog. You can click on 
marked variables to identify the connected partner variable.  

The Import Options dialog allows you to manually create additional connections or 
to undo existing connections. Note that a given target variable can be connected to 
more than one source variable. 

To establish a connection between a source/target variable pair click on the re-
spective target variable, then click on the source variable to be associated with the 
target variable and either press the Associate or Convert buttons. Use Associate if 
the data values in the import file should be imported without modification, or Con-
vert if transformations need to be performed during import. When using Convert, 
you can choose between predefined, commonly used transformations (e.g., unit 
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conversions) or, alternatively, you can establish your own general linear transfor-
mation formula.  

A constant density value of ρ=1.025 [kg/l] is used for conversions between per 
mass (e.g., µmol/kg) and per volume (e.g., µmol/l) units. This particular density 
value represents the average ocean seawater density at laboratory conditions 
(p=0 dbar; T=20°C) needed for the conversion. The error introduced by not using 
the actual salinity value of the sample is smaller than 0.2% in the marine environ-
ment. The oxygen unit conversions between µmol/kg and ml/l also use a density 
value of ρ=1.025 [kg/l] and a molar O2 volume at STP of 22.391 l. Depth/pressure 
conversion use the appropriate TEOS-10 functions. 

You can connect more than one source variable with a given target variable. This 
is useful if the data for a given target variable (e.g., Oxygen) are located in different 
columns (and possibly different units, e.g., Oxygen [µmol/kg] and Oxygen [ml/l]) 
for the different stations in the import files.  
 
As alternative to source/target variable connections, you can specify default val-
ues for target variables for which no corresponding source variable is provided in 
the import files. To set a default value for a given target variable, select the target 
variable in the Target Collection list, press the Set Default button and enter the de-
sired default value for the target variable. Target variables using default values 
are marked with a + sign. The specified value will be used for every sample of 
every station imported during this operation. 
  
Source variables not associated with a target variable will not be imported into 
the collection. If you merge data into the collection, you should establish associa-
tions for the primary variable of the target collection and the set of variables that 
should be added to the collection. Do not associate variables, which already have 
data in the collection that should remain unchanged.  
 
Note that the OK button of the Import Options dialog will remain disabled until the 
primary variable of the target collection is associated with one of the source varia-
bles. 
 

Station and Sample Matching Criteria 

If the Check for existing stations box is checked you may click on the Edit Matching 
Criteria… button to customize the tests that are performed to determine whether 
a station from the import files matches one of the existing stations in the target 
collection (Station Matching page; see Figure 4-4). You will also be able to modify 
the criteria for matching the samples of the import and target stations (Sample 
Matching page). Sample matching is performed during Merge Data (selected varia-
bles) and Update Data (selected variables) imports only.  
 
On the Station Matching page you can switch on or off various tests that compare 
position, date/time and names of import and target stations. The two stations are 

http://www.teos-10.org/
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considered to match if all requested tests succeed. For Longitude, Latitude and 
Time a match is obtained if import and target values agree within the specified tol-
erances.  
 
If the cruise labels in the import file differ from the cruise labels of the same sta-
tions in the target collection, you can establish cruise alias names by selecting a 
cruise in the Target collection cruise label combo-box, entering an alias name in 
the Source file cruise label field and pressing the Associate button.  Any alias cruise 
name found in the import file will be translated automatically to the correspond-
ing target cruise name before the station matching procedure is started. This is 
useful when different versions of the cruise name are used in the import file and 
target collection (e.g.,  ANT XV/4 versus SR04_06AQANTXV_4 in Figure 4-4). Exact 
cruise name matches are required if no aliases are defined. 
 

  
Figure 4-4: The two pages of the Matching Criteria dialog 

 
 
In addition to finding matching target stations in the collection, ODV also needs to 
match the samples of import and target stations when performing Merge Data (se-
lected variables) and Update Data (selected variables) imports. Sample matching is 
done by comparing the primary variable values of import and target samples and 
finding the closest matches. On the Sample Matching page you may specify param-
eters that determine how close import and target samples have to be in order to 
be considered a match. Non-matching samples will be added to the target station 
as new samples if the Add non-matching samples as new samples box is checked. 
Otherwise, non-matching samples are ignored and a warning message is written 
to the import log file. 

4.12 Generating File Lists 

ODV has a built-in list file generator, which can be used to create .lst files for multi-file 
data imports. These list files are useful if you want to import large numbers of Argo, 
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SDN, WOD, or WOCE data files into ODV in one step. To invoke the list file generator you 
use option Tools > List File Generator. 
 
The generation of these files is done by simply dragging and dropping files or entire di-
rectories of interest onto the dialog. When dropping a directory, all files in this direc-
tory or any of the sub-directories are added to the list. If you apply filters specifying the 
beginning or end of the filenames, only those files satisfying the filter are added to the 
list. These filters must be applied before dropping the files. This allows creating lists of 
files with different start and/or suffix. Note that you can activate case sensitive filtering 
by checking the Case sensitive check box. Once a file list is created, duplicates can be re-
moved or the current selection can be cleared by pressing the Validate or Clear buttons. 
Individual entries may be deleted or edited directly in the list.  
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5 Exporting Data  

5.1 Spreadsheet Files 

You can export the data of the currently selected stations into a single ODV generic 
spreadsheet file by choosing Export > Station Data > ODV Spreadsheet File. Then you 
choose a target directory and filename, select the variables to be included in the export 
file (default: all basic variables) and finally specify properties of the export file to be 
written. On the Spreadsheet File Properties dialog (see Figure 5-1) you may specify a 
missing value string (default: empty string), the range used for longitude values ( 0 to 
360°E or -180 to 180°E), the metadata date format (ISO8601 yyyy-mm-ddThh:mm:ss.sss 
or mon/day/year), the date/time format used for time-series date/time values 
(ISO8601 yyyy-mm-ddThh:mm:ss.sss or Chronological Julian Days or Decimal Time in 
years). Note that the Data date format entry is only enabled for time-series data. 

Under the Data filter entry you may specify whether all data should be exported or only 
samples satisfying quality and/or range selection criteria that can be specified on the 
Sample Filter Settings dialog immediately following the Spreadsheet File Properties dia-
log. Checking the Use compact format box causes station metadata to be exported for 
the first sample only, while metadata fields for all other samples remain empty. Using 
this option leads to significant reductions in export file size, especially for data with 
many samples per station, such as CTD, XBT and many kinds of time series data. If you 
do not want quality flag values of metadata and/or data variables to be exported, un-
check the Export metadata quality flags and/or Export data quality flags boxes.  

The history records of the exported stations are exported to the spreadsheet file if the 
Export history box is checked. History records are packaged into //<History> comment 
lines, and the history records of a given station are written after the data of the station. 

 

 
Figure 5-1: Spreadsheet File Properties dialog.  
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You can export the data of the currently selected stations into a new ODV collection by 
choosing Export > Station Data > ODV Collection. Then select the variables to be in-
cluded in the new collection (default: all variables) and specify destination directory 
and file-name using the standard file-select dialog-box.  

5.2 SDN Aggregated ODV Collection 

Data collections that have been produced via Import > SeaDataNet Formats can be fur-
ther processed by automatically aggregating variables and writing the results to a new 
collection via Export > Station Data > SDN Aggregated ODV Collection.  

Before performing the aggregation ODV first downloads the latest version of the P35 
vocabulary from http://vocab.nerc.ac.uk/collection/P35/current/. P35 defines numer-
ous aggregated variables by specifying the list of contributing variables as well as the 
preferred units of the aggregated variable. ODV also downloads the latest version of the 
list of unit conversions from the ODV website. If not connected to the Internet ODV uses 
the most recent versions of these files available on the system.  Required unit conver-
sions are applied automatically during aggregation. P35 aggregated variables use the 
SEADATANET quality flag scheme. 

The order of variables in the output collection is as follows:  

• the primary variable of the source collection, 
• the P35 aggregated variables for which contributing variables are found in the 

source collection, 
• the variables in the source collection not contributing to any P35 aggregated var-

iable. 

ODV offers two algorithms for the calculation of value and quality flag of a P35 aggre-
gated variable: (a) the Best-of aggregation algorithm using only those contributing val-
ues with the best available quality, and (b) the Use-all algorithm using all available con-
tributing values.  

ODV also allows creation of per-sample info strings containing the P01/P06 codes of the 
original variables used. This feature provides provenance information and allows trac-
ing back of the original data actually used for the calculation. Creation and storage of 
per-sample info strings require significant resources, therefore, it is recommended to 
use this feature only when detailed back traceability is important, and to avoid creating 
the info strings for large collections with millions of stations and/or very many varia-
bles. 

The value and quality flag of a P35 aggregated variable is obtained as follows: 

• if only one contributing variable contains data: use the value and SDN quality flag 
unchanged (same procedure for both, Best-of and Use-all algorithms), 

• if more than one contributing variable contain data: map all quality flags to the 
ODV scheme and determine the smallest (highest quality) and largest (poorest 
quality) flag values. Then proceed differently for the two aggregation algorithms.  

http://vocab.nerc.ac.uk/collection/P35/current/
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(a) Best-of algorithm: Only use the contributing values with smallest ODV quality 
flag value (highest available quality; best-of). Then calculate the median of the best-
of contributing values; take the smallest ODV quality flag and map back to the 
SEADATANET scheme. 

(b) Use-all algorithm: Calculate the median of all contributing values; take the maxi-
mum of the mapped ODV quality flag values and map back to the SEADATANET 
scheme. 

ODV presents the P35 Aggregation Properties dialog allowing algorithm selection and 
switching per-sample info creation on or off. 

 

 
Figure 5-2: The P35 Aggregation Properties dialog. 

 

You can view the list of unknown conversions (if any) and the list of constructed P35 
aggregated variables and their contributing input variables by opening the output col-
lection and using the Collection > Browse Info File option. 

If a contributing variable requires an unknown conversion, this input variable is ig-
nored and its data are not used in the aggregation. If you encounter missing conver-
sions please contact reiner.schlitzer@awi.de and request inclusion of the new conver-
sion in the ODV conversion database. 

5.3 SDN Harmonized ODV Collection 

Data collections that have been produced via Import > SeaDataNet Formats can be fur-
ther processed by automatically harmonizing variables and writing the results to a new 
collection via Export > Station Data > SDN Harmonized ODV Collection. Harmonization 
involves unit conversion to preferred target units as well as aggregation of variables 
with the same P01 code. Unit conversion factors and the list of P01 codes being harmo-
nized are loaded from file include/import/sdn_contaminants_conversions.xml. Variables 
not included in this list are written to the harmonized ODV collection in their original, 

mailto:reiner.schlitzer@awi.de
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unmodified form.  

When aggregating multiple source variables with the same P01 code into a single har-
monized variable ODV uses the Best-Of aggregation algorithm described above. The list 
of created harmonized variables together with list of contributing original variables  
can be viewed using the Collection > Browse Info File option. Info strings revealing the 
source variables of individual harmonized values are created automatically. 

The order of variables in the harmonized collection is as follows:  

• the primary variable of the source collection, 
• the harmonized variables for which contributing variables are found in the 

source collection, 
• the variables in the source collection not listed in the sdn_contaminants_conver-

sions.xml file. 

5.4 NetCDF Files 

You can export the data of the currently selected stations into a single NetCDF file by 
choosing Export>NetCDF File. Then choose a target directory and filename, select the 
variables to be included in the export file (default: all basic variables) and finally specify 
properties of the export file to be written. On the NetCDF File Properties dialog you may 
specify the range used for longitude values (0 to 360°E or -180 to 180°E) and whether 
all data (samples) should be exported or only those that satisfy the current quality 
and/or range filters. If you do not want quality flag values of metadata and/or data vari-
ables to be exported, uncheck the Export metadata quality flags and/or Export data 
quality flags boxes. Under the Data filter entry you may specify whether all data should 
be exported or only samples satisfying quality and/or range selection criteria that can 
be specified on the Sample Filter Settings dialog immediately following the NetCDF File 
Properties dialog. 

The structure of the exported netCDF file is as follows: 

Dimensions: 

• N_STATIONS contains the number of stations contained in the file. 
• N_SAMPLES contains the maximum number of samples per station.  
• In addition, there may be one or more dimensions of the form STRINGi, where i 

is an integer and represents the maximum number of characters in the associ-
ated text variables.  

Variables: 

• longitude and latitude store the station’s positions. 
• date_time contains the decimal time in Gregorian Days of the stations relative to 

a certain reference date, with the decimal part representing the fractional day. 
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The reference date is chosen as January, 1 of the year containing the oldest sta-
tion. 

• Variables with name metavari, with integer value i, store the values of other ODV 
meta-variables. All metavari variables as well as longitude, latitude and date_time 
only depend on dimension N_STATIONS. 

• Variables with names of the form vari store data values of ODV data variables. 
These variables depend on dimensions N_STATIONS and N_SAMPLES. 

• If requested, the quality flag values of metadata and/or data variables are stored 
in variables with names of the form vari_QC. 

Attributes (mostly standard NetCDF attributes): 

• As a minimum, all netCDF data variables except quality flag variables contain the 
attributes long_name and _FillValue. long_name stores the name of the variable 
as used in ODV. _FillValue stores the miss value used. Some variables also con-
tain the attributes units, C_format, FORTRAN_format, valid_min, valid_max and/or 
comment. 

• NetCDF quality flag variables have the attributes Conventions and comment that 
describe the quality flag scheme used.  

Information about the source of the data and the software used to produce the file is 
provided in global attributes (see table 16-6). 

An additional file <nc filename>_nc_variables.txt is produced in the output directory 
containing a list of netCDF variable names together with the associated ODV metadata- 
and data variable names, units and comments. 

ODV netCDF files use chunking and compression and require tools based on netCDF4 
for reading. 

5.5 WHP Exchange Format Export 

You can export the data of the currently selected stations into a WHP-Exchange Format 
file by choosing Export > WHP Exchange File. ODV supports both Bottle and CTD output 
files as specified in Description of WHP-Exchange Format for CTD/Hydrographic Data 
(James H. Swift & Stephen C. Diggs; September 2001, updated May 2006 & April 2008; 
http://cchdo.ucsd.edu/formats/exchange/index.html).  

To perform WHP Bottle or CTD exports proceed as follows:  

1. If necessary select the set of stations you want to export by adjusting the map’s 
domain and/or apply special station filter settings. 

2. Select Export > WHP Exchange File > Bottle or Export > WHP Exchange File > CTD 
from ODV's main menu. 

http://cchdo.ucsd.edu/formats/exchange/index.html
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3. In case ODV cannot automatically identify critical variables, you are prompted to 
identify these variables: 

a. WHP Bottle export: Key variable Pressure in Water Column [db] or alter-
natively Depth in Water Column [m] must be identified. 

b. WHP CTD export: When exporting as CTD the variables Temperature [°C] 
and either Pressure in Water Column [db] or Depth in Water Column [m] 
are required. In addition you may be asked to identify Salinity [psu] and 
Oxygen in [µmol/kg] or [ml/l]. 

4. Specify output directory and filename. 
5. Specify information required for the WOCE file header (first line of file) and ad-

ditional comments you want to be part of the output file. 

Once the export is finished a file will be written to the location specified in step 3. When 
exporting Bottle data the output file will be a single CSV-text file that ends with 
"_hy1.csv". When exporting as CTD the resulting file will be a ZIP-Package with suffix 
"_ct1.zip" containing one CSV-file for every exported station. 

Export to WHP exchange files is only possible or meaningful for ODV collections having 
pressure or depth as primary variable (profiles). Depth values in the collection are con-
verted to pressure before writing to the WHP parameter CTDPRS.  

ODV cruise names are exported under WHP parameter EXPOCODE, station names un-
der STNNBR and the station’s time and date information under DATE and TIME. Miss-
ing time and date information is indicated by zeros in the output file, so if the time is un-
known its value will be "0000". Positions are stored in the range of [-90, 90] for latitude 
and [-180, 180] for longitude. Bottom Depth, if present in the ODV collection, is mapped 
to WHP parameter DEPTH. If the ODV collection contains a meta-variable SECT_ID, its 
values are exported under WHP parameter SECT_ID.  

When exporting to WOCE WHP Bottle files the collection is scanned for variables 
CASTNO, SAMPNO und BTLNBR. If CASTNO (cast number) is missing in the collection, 1 
is used as default value. If SAMPLNO (sample number) is missing ODV assigns 1-based, 
sequential sample numbers. If BTLNBR (bottle number) is missing in the collection no 
such column will appear in the output file. All other variables are exported using the 
names in the collection. Variables that do not contain any data values for the set of sta-
tions being exported are excluded from the output file. Note that ODV derived variables 
are not exported. 

Quality flags are preserved if the collection already uses WOCE quality flags. Otherwise 
the quality flags in the collection are mapped to WOCE schemas before exporting (see 
ODV_QualityFlagSets.pdf for mapping details). In case of WHP CTD export the output 
quality flags are either WOCECTD or GTSPP (same as IGOSS). In case of WHP Bottle ex-
port the output quality flags are either WOCEBOTTLE or GTSPP, except for the CTDSAL 
or CTDOXY variables, which use WOCECTD or GTSPP and the BTLNBR variable, which 
uses WOCESAMPLE or GTSPP. 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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5.6 Clipboard Copy of Data and Gridded Field Values 
The X, Y, Z data of a data window as well as the gridding misfits at the data locations and the 
gridded values on the automatically generated grid (the latter two only if gridding is switched 
on) are copied to the clipboard using the Extras > Clipboard Copy option of the window’s 
popup menu. As a shortcut you may press Ctrl-C while the mouse is over the particular win-
dow. ODV will export the original X and Y values by default, but the user can also request 
projected values, as produced by the current projector of the window. Once ODV has copied 
the data to the clipboard you may paste the clipboard contents into your favorite software for 
further processing. Clipboard copy of the map window produces lists containing station posi-
tions and other metadata. 

5.7 Exporting Isosurface Data 

You can export the isosurface data of all stations currently shown in the map by select-
ing Export > Isosurface Variables and choosing a target directory and output filename. 
The output file includes the metadata of the stations and is ODV generic spreadsheet 
format compliant. 

5.8 Exporting X, Y, Z Window Data 

You can export the data values displayed in ODV plot windows to separate ASCII files by 
choosing Export > X, Y, Z Window Data from the ODV menu bar. Enter a descriptive text 
identifying the data of this export in the ID String field and click OK. ODV will create a 
sub-directory in the user’s ODV directory <documents>\ODV\export\< ID String>. All 
exported files will be written to this directory. If it already exists, ODV asks for permis-
sion to delete all files from the directory before continuing. Note that the names of the 
exported files start with win?, where ? represents the respective window number. The 
actual X, Y, Z data are found in files win?.oai (one data point per line; fourth column al-
ways 1). 

For windows with gridded fields, ODV also exports the results of the gridding operation 
(files win?.oao). The format of the .oao files is as follows: 
0     (ignore) 

nx  ny     (no of x and y grid-points) 

... nx X-grid values ...  (X-grid positions) 

... ny Y-grid values ...  (Y-grid positions) 

... nx*ny gridded values ... (estimated field, line by line starting at first Y-grid value) 

... nx*ny gridded values ... (estimation quality, line by line starting at first Y-grid value) 

5.9 Exporting Reference Datasets 

You can save the original data of the current plot windows in separate ASCII files and 
use these data later as reference datasets by choosing Export > X, Y, Z Window Data as 
Reference from ODV’s menu bar. Enter a descriptive text identifying the reference data 
in the ID String field and click OK. ODV will create a sub-directory in the user’s ODV di-
rectory <documents>\ODV\reference\< ID String> and writes all files to this directory. If 
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the directory already exists, ODV asks for your permission to delete the current con-
tents before continuing. Reference data are used by ODV for defining difference varia-
bles. 
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6 Derived Variables 

In addition to the basic variables stored in the collection files, ODV can calculate a large 
number of derived variables which (once defined) are available for analysis and use in 
the data plots in the same way as the basic variables. There are three types of derived 
variables: 

• built-in derived variables including many commonly used parameters from 
physical and chemical oceanography. 

• macro files of user defined expressions stored in files for use with arbitrary ODV 
collections. 

• expressions defined by the user on-the-fly for the current collection only. 

To define or delete derived variables choose the Derived Variables option from the Cur-
rent Sample Window popup menu or View > Derived Variables from the menu bar. To 
add a macro, choose Expressions, Derivatives, Integrals > Macro File from the Choices list; 
to add a user defined expression choose Expressions, Derivatives, Integrals > Expression. 
To add a built-in derived variable choose any other item in the Choices list.  

You may also load the derived variables from a view file by clicking on the Load from 
View File button. Note that the view file must belong to the currently open collection. 

6.1 Built-in Derived Variables 

Algorithms for many physical oceanographic parameters, such as potential tempera-
ture, potential density (relative to arbitrary reference pressures), neutral density, 
Brunt-Väisälä Freqency, and dynamic height, are built into the ODV software. In addi-
tion, various parameters of the carbon dioxide system in seawater, the saturation con-
centrations and partial pressures of many gases and many other variables from chemi-
cal oceanography are also available as easily selectable derived variables. Some useful 
mathematical expressions, such as the ratio of two arbitrary variables as well as vertical 
integrals and derivatives, are also available.  

The Physical Properties (TEOS-10) derived variables group (new in version 4.4.2) super-
sedes the previous EOS-80 based variables and adds more than 20 new variables. The 
Physical Properties (EOS-80) derived variables group is still maintained for the sake of 
backwards compatibility and to allow comparative studies. Normally the derived varia-
bles from the Physical Properties (TEOS-10) group should be used. 

Complete lists of available built-in derived variables are shown below.  All these varia-
bles can be requested by the user.  ODV will calculate values for all requested derived 
variables when station data are loaded into memory. Requested derived variables can 
be used and visualized in the same way as the basic variables stored in the collection 
files. 

To define or delete built-in derived variables choose the Derived Variables option from 
the Current Sample Window  popup menu. ODV will show lists of available and already 
defined derived variables. The available derived variables are organized in thematic 
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groups and are shown in the Choices list. The most recently used thematic group is ex-
panded initially. Other groups may be expanded by clicking on their name. 

To add a particular derived variable select this entry in the Choices list (you may need to 
expand the group the variable belongs to first) and press Add. If a derived variable re-
quires additional information, such as the reference pressure for potential temperature 
or potential density, ODV will automatically prompt for this information. Many derived 
variables also require identification of the input variable(s) needed for the calculation 
of the derived variable. Note that this identification of key variables has to be done only 
once and that the associations are remembered by ODV. Use option Collection > Identify 
Key Variables to verify and modify key variable associations if necessary. Note that the 
calculated values of derived variables may be wrong, if key variable associations are not 
correct.  

To delete a derived variable select this variable in the Already Defined list box and press 
Delete or simply double-click on the item to be deleted. Note that when deleting a varia-
ble that is required as input by other derived variables, these child variables are deleted 
as well. To edit the parameters of a derived variable or the expressions of ODV macros 
and expressions (for more information on these special derived variables see below) 
select the respective variable in the Already Defined list box and press Edit. 

 
Table 6-1: List of built-in derived variables 

Variable Comment 

Carbon 

Alkalinity (any C input pair) [µmol/kg] (details) 

CO*2 (any C input pair) [µmol/kg] (details) 

CO32- (any C input pair) [µmol/kg] (details) 

DIC (any C input pair) [µmol/kg] (details) 

fCO2 (any C input pair) [µAtm] (details) 

HCO3- (any C input pair) [µmol/kg] (details) 

OmegaA (any C input pair) (details) 

OmegaC (any C input pair) (details) 

pCO2 (any C input pair) [µAtm] (details) 

pH (any C input pair)  (details) 

Revelle Factor (any C input pair) (d fCO2 / d TCO2) / (fCO2 / TCO2). (details) 

Expressions, Derivatives, Integrals 

Derivative Any variable (details) 

Derivative (2nd) Any variable 

Expression User defined expressions 
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Integral Any variable (details) 

Macro File User defined expressions from macro files 

Ratio Any two variables 

Gases 

AOU [µmol/kg] Apparent oxygen utilization 

CFC-11 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 

CFC-12 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 

CFC-10 Saturation [%] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 

CFC-113 Saturation [%] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 

CH4 Saturation [%] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 

Oxygen Saturation [%] Weiss, Deep Sea Res., 17, 721-735, 1970 

pCFC-11 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 

pCFC-12 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 

pCFC-10 [pptv] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 

pCFC-113 [pptv] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 

pCH4 [ppbv] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 

pSF6 [pptv] Bullister, Wisegarver & Menzia, DSR-I, 49 (1), 175-187, 
2002 

SF6 Saturation [%] Bullister, Wisegarver & Menzia, DSR-I, 49 (1), 175-187, 
2002 

Metadata 

Cruise ID Unique ID per cruise 

Latitude Decimal latitude derived from station latitude 

Longitude Decimal longitude derived from station longitude (ad-
justed to current map domain) 

Meta Variable Value Numeric values of meta-variables 

Station Number Number derived from Station label 

Physical Properties (EOS80) 

Depth from Pressure (EOS80) [m] Saunders and Fofonoff, Deep-Sea Res., 23, 109-111, 1976 

Freezing Temperature (EOS80) [degC] F. Millero, UNESCO Tech. Papers in the Marine Science, No. 
28., 29-35, 1978 

In situ Density Anomaly (EOS80) [kg/m3] EOS80 

In situ Temperature (EOS80) [degC] EOS80 

Potential Density Anomaly (EOS80) [kg/m3] EOS80 (any reference pressure) 

Potential Temperature (EOS80) [degC] Bryden, Deep Sea Res.,20,401-408, 1973 (any reference 
pressure) 
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Pressure from Depth (EOS80) [dbar] Saunders, J. Phys.  Ocean., 1981 

Sound Speed (EOS80) [m/s] Fofonoff & Millard, Unesco Tech. Pap. in Mar. Sci._, No. 44, 
53 pp, 1983 

Specific Heat Capacity Cp (EOS80) [J/(kg 
degC)] 

F. Millero et al, J. Geoph. Res., 78, 4499-4507, 1973 

Specific Volume Anomaly (EOS80) [mm3/g] EOS80 (any reference salinity and temperature) 

Physical Properties (TEOS-10) 

Absolute Salinity SA [g/kg] TEOS-101) 

Absolute Salinity at Freezing Point [g/kg] TEOS-101) 

Adiabatic Lapse Rate Γ [mdegC/dbar] TEOS-101) 

Brunt-Väisälä Freqency [cycl/h] (details) 

Cabbeling Coefficient CΘb [10-6 K-2] TEOS-101) 

Conservative Temperature Θ[degC] TEOS-101) 

Depth from Pressure [m] TEOS-101) 

Dynamic Enthalpy [kJ/kg] TEOS-101) 

Dynamic Height [dyn m] TEOS-101, 3) (any reference pressure) 

Freezing Temperature Θf [degC] TEOS-101) 

In situ Density Anomaly σ [kg/m3] TEOS-101) (using in situ pressure, temperature and salin-
ity) 

In situ Temperature from Conservative Tem-
perature [degC] 

TEOS-101) (using in situ pressure and conservative tem-
perature) 

Isentropic Compressibility κ[10-10 Pa-1] TEOS-101) 

Latent Heat of Evaporation [kJ/kg] TEOS-101) 

Latent Heat of Melting [kJ/kg] TEOS-101) 

Neutral Density γn [kg/m3] Jackett & McDougall, J. Phys. Ocean., 237-263, 1997 (more) 

Potential Density Anomaly σ[kg/m3] TEOS-101) (any reference pressure) 

Potential Temperature θ [degC] TEOS-101) (any reference pressure) 

Potential Vorticity Q [10-12 m-1 s-1] Potential vorticity (derived from Brunt Vaissala Fre-
quency Q=f/g*N2) 

Practical Salinity from Absolute Salinity TEOS-101) 

Practical Salinity from Conductivity TEOS-101) 

Preformed Salinity S* [g/kg] TEOS-101) 

Pressure from Depth [dbar] TEOS-101) 

Reference Salinity SR [g/kg] TEOS-101) 

Saline Contraction Coefficient βΘ [10-3 kg/g] TEOS-101) 

Sound Speed [m/s] TEOS-101) 

Specific Enthalpy h [kJ/kg] TEOS-101) 
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Specific Entropy η [J/(kg*K)] TEOS-101) 

Specific Heat Capacity Cp  [J/(kg degC)] TEOS-101) 

Specific Internal Energy u [kJ/kg] TEOS-101) 

Specific Volume Anomaly  [mm3/g] TEOS-101,2) 

Spiciness π Flament, Progr. in Oceanogr., 54 (1-4), 493-501, 2002 

Stability Ratio Rρ TEOS-101) 

Thermal Expansion Coefficient αΘ [10-6 K-1] TEOS-101) 

Thermobaric Coefficient TΘb [10-12 K-1 Pa-1] TEOS-101) 

Turner Angle Tu [deg of rotation] TEOS-101) 

Special 

Aggregated Variable (details) 

Converted Variable (details) 

Data Error Value 1-σ data error values of any variable 

Difference from Reference Data (details) 

Interpolated Variable Missing data replaced by interpolated values 

Patches (details) 

Quality Flag Value Quality flag values of any variable 

String ID Integer ID values for  the different string values of any 
TEXT or  INDEXED_TEXT meta or data variable. 
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Time 

Day of Month (station date) Decimal day of the Month derived from station date4) 

Day of Month (time variable) Decimal day of the Month derived from a time variable4) 

Day of Week (station date) Decimal day of the Week derived from station date4) 

Day of Week (time variable) Decimal day of the Week derived from a time variable4) 

Day of Year (station date) [days] Decimal day of the Year [days] derived from station date4) 

Day of Year (time variable) [days] Decimal day of the Year [days] derived from a time varia-
ble4) 

Day Time (station time) [hours] Decimal time of day [hours] derived from station time 

Day Time (time variable) [hours] Decimal time of day [hours] derived from a time variable 

Month of Year (station date) Decimal month of year derived from station date5) 

Month of Year (time variable) Decimal month of year derived from a time variable5) 

Time (station date/time)  Decimal time derived from station date and time 

Time (time variable)  Decimal time derived from a time variable 

Year (station date) Integer year derived from station date 

Year (time variable) Integer year derived from a time variable 

1) IOC, SCOR and IAPSO, 2010: The international thermodynamic equation of seawater – 2010: Calculation and use of ther-
modynamic properties. Intergovernmental Oceanographic Commission, Manuals and Guides No.56, UNESCO (English), 
196 pp.  

2) Note that in TEOS-10 specific volume anomaly is calculated using absolute salinity SA=35.16504 g/kg and conservative 
temperature Θ=0 °C as reference. This differs from the traditional definition using a reference of practical salinity SP=35 
psu and in situ temperature t=0 °C. Relative differences of values can reach 25% in the deep ocean. 

3) Using TEOS-10 specific volume anomaly (see 2) above). 

4) Including fractional day according to daytime. 

5) Including fractional month according to day of the month and daytime. 

 

Brunt-Väisälä Freqency 

Brunt-Väisälä Freqency is calculated as follows: For a given profile, ODV first estab-
lishes a sequence of standard depths and projects the observed pressures, tempera-
tures and salinities onto these standard depths. Then Brunt-Väisälä Freqency is calcu-
lated (using vertical density gradients calculated from the new TEOS-10 equation of 
state 2010) for every standard-depth interval and assigned to the interval mid-point. 
Finally the mid-point Brunt-Väisälä Freqency values are projected back to the original 
pressure (or depth) values of the profile. Projection of values is done using linear least-
squares interpolation. Please note that ODV calculates N, not N2. In case of unstable 
stratification (negative value under the square root) the square root of the absolute 
value under the square root is taken and a negative sign is assigned. Thus, negative val-
ues for N in ODV indicate unstable conditions. Note that ODV verifies that the station 
contains sufficient input data (by checking the Good Coverage Criteria) before starting 
the calculations. Stations with large data gaps are skipped. 

http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
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Parameters of the carbon dioxide system in sea water 

The following parameters of the carbon dioxide system in sea water are provided as de-
rived variables:  

1. Alkalinity, 
2. Dissolved Inorganic Carbon DIC, 
3. Fugacity and partial pressure of CO2 (fCO2  and pCO2 ),  
4. Concentrations of CO*2, CO32-, and HCO3-,  
5. pH (on Total, SWS, or Free scale),  
6. Revelle, or homogeneous buffer, factor,  
7. Solubility ratios [CO32-]*[Ca2+] / Ksp for calcite and aragonite, OmegaC and Ome-

gaA.  
 
All these quantities can be calculated using one of the following carbon input data pairs: 

1. ALK, DIC 
2. ALK, pH 
3. ALK, fCO2 
4. ALK, pCO2 
5. DIC, pH 
6. DIC, fCO2 
7. DIC, pCO2 
8. fCO2, pH 
9. pCO2, pH. 

 
You define one of these carbon parameters by choosing the respective entry in the 
Choices list of the Derived Variables dialog and pressing Add. The carbon parameter set-
tings dialog in Figure 6-1 appears which lets you define various settings for the re-
quested variable.  
 
The Equilibrium constants combo-box allows choosing among different equilibrium con-
stants from the literature to be used in the calculations, the Input box allows specifying 
the data input pair as well as the conditions at which the input data were measured, and 
the Output box allows specifying output conditions at which the requested variable is to 
be calculated. Depending on the type of variable requested and depending on the cho-
sen Input variables, some of the entries are not relevant and are hidden. 
 
If one of the following variables pH, fCO2 or pCO2 is among the selected input variables 
you must specify pressure and temperature at which these variables have been meas-
ured. If pH is one of the input variables you must also specify the pH scale on which the 
pH values are reported. Possible choices for the input pressure are (1) In-situ pressure, 
(2) Select pressure variable, and (3) Enter your pressure value here. You choose (1) if the 
input values are at in-situ pressure, you choose (2) if one of the data variables contains 
the input pressure values (the respective variable will be identified later), and you 
choose (3) if the measurements were done at fixed pressure, e.g., laboratory conditions. 
To enter the value, select the Enter your pressure value here text and replace with the 
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numeric value. 
 
There are four possible choices for the input temperature: (1) In-situ temperature, (2) 
Potential temperature, (3) Select temperature variable, and (4) Enter your temperature 
value here. Choices and procedures are as for pressure above. 
 
If the requested derived variable is one of the following pH, fCO2 or pCO2 you must spec-
ify output pressure and temperature conditions at which these variables are to be cal-
culated. If the requested derived variable is pH you must also specify the output pH 
scale.  

The recommended choice of equilibrium constants (Best Practices Handbook 2007) fol-
lows Dickson et al. (2007), except for KF: K1 and K2 are from Luecker et al. (2007), K0 is 
from Weiss (1974), KB is from Dickson (1990), KS is from Dickson (1990), KF is from 
Dickson and Riley (1979), KW is from Millero (1995), K1p, K2p, K3p  and KSi are from Mil-
lero (1995), and the solubility products Ksp of calcite and aragonite are from Mucci 
(1983). The pressure dependence of the equilibrium constants is from Millero (1995). 
Typographical errors in various publications as summarized in Lewis and Wallace 
(1998) are considered. 

 

 
Figure 6-1: The carbon parameter settings dialog. 

 
If phosphate and/or silicate data are not available, concentration values of zero are as-
sumed. ODV uses the alkalinity definition of Dickson (1981) and treats all terms except 
HS, S and NH3. pH is calculated using an iterative Newton method. 

The SeaCarb version 2.1.2 software of Lavigne, et al. (2008) and the Matlab version  of 
CO2SYS v1.01 (Lewis and Wallace, 1998; ported to Matlab by Denis Pierrot, University 
of Miami) has been run on the same sample data and excellent agreement of results has 
been found for all parameters of the carbon system offered by ODV.  

Dickson A. G., Sabine C. L. & Christian J. R., 2007. Guide to best practices for ocean CO2 measurements. 
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PICES Special Publication 3:1-191. 

Lavigne, H., A. Proye, J.-P. Gattuso., 2008. SeaCarb: Calculates parameters of the seawater carbonate sys-
tem. R package version 2.1. http://www.obs-vlfr.fr/~gattuso/seacarb.php [Version: June/10/2009]. 

Lewis, E., and D. W. R. Wallace. 1998. Program Developed for CO2 System Calculations. ORNL/CDIAC-105. 
Carbon Dioxide Information Analysis Center, Oak Ridge National Laboratory, U.S. Department of Energy, 
Oak Ridge, Tennessee. http://cdiac.ornl.gov/oceans/co2rprt.html. 

Derivative 

Select the variable for which the derivative with respect to the primary variable is to be 
calculated (designated A in the following; any basic or already defined derived variable 
can be used). The calculations proceed in three steps: (1) the observed values of A are 
interpolated onto a set of densely spaced standard values of the primary variable; (2) 
derivatives are calculated at the standard mid-values, (3) the derivative values are in-
terpolated back to the original sample primary variable values. Note that ODV verifies 
that the station contains sufficient input data (by checking the Good Coverage Criteria) 
before starting the calculations. Stations with large data gaps are skipped. 

Integral 

Select the variable for which the integral along the primary variable is to be calculated 
(designated A in the following; any basic or already defined derived variable can be 
used) and specify the starting primary variable value z0 for the integral (default: 0). For 
each sample of a given station, ODV will calculate the integral A*dz from z0 to the re-
spective primary variable level.  

The units of the integral are the units of the quantity A times the units of the primary 
variable. If the primary variable is depth and variable A has volumetric concentration 
units (e.g., moles per cubic meter) the calculated integral is equivalent to the standing 
stock per square meters. Note that by definition the value of the integral at z0 is zero. 
Also note that ODV verifies that the station contains sufficient input data (by checking 
the Good Coverage Criteria) before starting the calculations. Stations with large data 
gaps are skipped. 

Example (assuming depth as primary variable): To obtain the salt content in the top 500 
m of the water column, select salinity as variable for the integral and use 0 as start 
value. Then look up the value of the vertical integral at 500 m (by interpolating between 
neighboring points) or in SURFACE mode define the integral at depth=500 as an isosur-
face variable. 

Aggregated Variable 

Aggregated derived variables combine data values of one or more input variables in a 
single variable. This is useful when a given parameter, such as oxygen, has been meas-
ured by different laboratories and is reported in separate original oxygen variables, 
possibly using different units.  Aggregated derived variables allow merging the various 
original variables (possibly involving unit conversion) into a single variable for scien-
tific analysis. Calculation of aggregated variable values occurs sample by sample using 
the values of the input variables for the given sample. 



Version 5.1.0 

 78 

To define an aggregated derived variable choose Aggregated Variable in the Special 
group and press Add. On the following, automatically appearing dialogs select all the in-
put variables contributing to the aggregated variable and enter name and units of the 
new variable.  

 

 
Figure 6-2: The Aggregated Variable dialog. 

 

Then the Aggregated Variable dialog appears (see Figure 6-2) that lets you fine-tune the 
properties of the aggregated variable. It is important that you specify for every contrib-
uting input variable the proper unit conversion to be used to transform values of the in-
put variable into the units of the aggregated variable. Initially all transformations are 
set to Identity Transformation, which means that the input values are used without 
change. You define a conversion for an input variable by selecting it in the Contributing 
Variables list and clicking the Conversion button. Then select one of the conversions 
from the Conversion combo-box. Choose General Linear Transformation and specify 
your own factor and offset, if the desired transformation is not included in the list. 

There are three different aggregation modes defining the way how the single aggre-
gated value is obtained from multiple input values: (1) Exclusive,  (2) Average and (3) 
Median. Exclusive aggregation uses the first available data value in the specified order of 
input variables, while Average or Median modes calculate the average or median of all 
available input values for a given sample.  

Use the Add and Delete buttons to add or delete an input variable. Click Conversion to 
modify the conversion for the selected input variable. The default conversion, Identity 
Transformation, leaves the input value unchanged. Use the Top, Up, Down, Bottom but-
tons to change the order of input variables if necessary. Note that for Exclusive aggrega-
tion (the default) the order of the input variables matters, because the first available 
value in the given order of input variables is used. Press OK to complete the aggregated 
variable definition. 
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Converted Variable 

Converted derived variables provide the data of a given variable in different units. To 
define a converted derived variable choose Converted Variable in the Special group and 
press Add. Then select the input variable to be converted, enter name and units of the 
new variable and specify the unit conversion to be used. Choose General Linear Trans-
formation and specify your own factor and offset, if the desired transformation is not in-
cluded in the list. 

6.2 Macros 

You can implement new derived variables not included in the list of built-in derived 
quantities provided that the value of your new derived variable for a specific sample 
only depends on other variable values of the same sample. For the definition of a new 
macro you use the ODV Macro Editor (see below) and specify the input variables on 
which the macro depends as well as the algebraic expression to be used to calculate val-
ues. You then save this information in a macro file. 

You activate a macro derived variable by selecting Derived Variables from the current 
sample window popup menu and choosing Expressions, Derivatives, Integrals > Macro 
File from the Choices list and selecting one of the saved macros.  You then identify the 
input variables needed for the calculation of the macro. If one of the required variables 
is not available, press Not Available to abort the macro setup. 

6.2.1 Macro Editor 

You edit or create Ocean Data View macro files using the Tools > Macro Editor option. 
Select an existing macro file or choose a new macro name and define the macro follow-
ing the instructions below. Press Save As and specify a macro name save the macro in a 
file.  

 

Macro Variable 
Label:  Enter the label of the macro variable. Use formatting control sequences 

for Greek symbols, exponents or indices. 

Units:  Enter the units of the macro variable. Use formatting control sequences 
for Greek symbols, exponents or indices. 

Digits: Enter the number of significant digits for the display of values in the cur-
rent sample window. 

Comments 
Enter one or more comments lines describing the macro variable. 

Input Variables 
Specify the input variables needed for the macro variable. To add an input variable, en-
ter its label and units into the New field and press the << button. Use formatting control 
sequences for Greek symbols, exponents or indices. To delete a defined input variable, 
select the entry in the Defined list-box and press the >> button. The number of input 
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variables is unlimited. 
 

 
Figure 6-3: The macro editor dialog 

 

Expression 
In the Expression in Postfix Notation field you specify the algebraic operations to be per-
formed when the macro is evaluated. The expression has to be in Postfix Notation (also 
known as Reverse Polish notation) with operands preceding operators. The Tools > In-
fix-to-Postfix Converter option (only available on Windows) can be used for conversion 
of infix mathematical expressions to postfix notation for use in the Expression in Postfix 
Notation field. 

An expression consists of a sequence of operands and operators specified on one or 
more lines. All entries (operands and operators) must be separated by one or more 
spaces. As operands you can use constants, values of input variables, stored values, as 
well as metadata of the current station, such as longitude, latitude, date or the elevation 
at the current station position (see Table 6-2).  

As operators you can use any one of the algebraic and logical operators listed in Table 

http://en.wikipedia.org/wiki/Reverse_Polish_notation
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6-3. The operators differ by the number of required input values (unary, binary and ter-
nary), but all, except the =%n store operator, produce exactly one result value.   

The evaluation of macro formulas is implemented using a simple stack-based scheme:  

1. Operands are added at the top of the stack as they appear, 

2. Operators take their operands from the top of the stack and push the result of 
the operation back at the top of the stack. 

At the end of a successful calculation the only element remaining on the stack is the fi-
nal result. 

 
Table 6-2: Operands in ODV expressions 

Operand Meaning 

17.3 Numeric constants 

#n Value of input variable n (n=1,…; example:  #1) 

%n Value of stored value n (n=0,…; example:  %3) 

%x Longitude of the current station 

%y Latitude of the current station 

%t Decimal years since 1900 calculated from current station date and time metadata 

%d Day of the year  calculated from current station date and time metadata 

%H Elevation at the current station position (in meters above sea level; positive for land and 
negative for ocean) 

 

 
Table 6-3: Operators in ODV expressions 

Operator Result Comment 

Unary: x operator 

=%n - Stores x as stored value n (n=0,…). Use %n to retrieve 
value.  

abs abs(x) Absolute value 

arccos arccos(x) Arc cosine (in radians) 

arccot arccot(x) Arc cotangent (in radians) 

arcsin arcsin(x) Arc sine (in radians) 

arctan arctan(x) Arc tangent (in radians) 

ceil ceil(x) Ceiling of x (ceil(-1.3)=-1; ceil(3.5)=4) 

cos cos(x) Cosine (x in radians) 

cot cot(x) Cotangent (x in radians) 
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exp exp(x) Exponential 

floor floor(x) Floor of x (floor(-1.3)=-2; floor(3.5)=3) 

int int(x) Integer part of x (int(-1.3)=-1; int(3.5)=3) 

ln ln(x) Natural logarithm 

sin sin(x) Sine (x in radians) 

sqrt sqrt(x) Square root 

! !x Not x (!(0)=1; !(1)=0) 

? 
1 if x is valid value 

0 if x is missing value 
Test for missing value (ODV 5.0.1 or later) 

Binary: x y operator 

+ x+y Sum 

- x-y Difference 

* x*y Product 

/ x/y Ratio 

** xy Power 

min min(x,y) Minimum 

max max(x,y) Maximum 

== 
1 if x=y 
0 if x!=y 

Test for equality 

!= 
1 if x!=y 
0 if x=y 

Test for inequality 

>= 
1 if x>=y 
0 if x<y 

Test for bigger than or equal 

> 
1 if x>y 

0 if x<=y 
Test for bigger than 

<= 
1 if x<=y 
0 if x>y 

Test for less than or equal 

< 
1 if x<y 

0 if x>=y 
Test for less than 

& 
1 if x and y non-zero 

0 if x or y zero 
Logical And 

| 
1 if x or y non-zero 

0 if x and y zero 
Logical Or 

Ternary: b x y operator 

IFTE 
x if b is non-zero 

y else 
If-then-else logic 
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You use the operators + - * / ** for the basic arithmetic operations, sqrt for the 
square root, min and max for minimum and maximum of two operands, ln and exp for 
the natural logarithm and exponential, sin, cos, tan, and cot for sine, cosine, tangents, 
and cotangents (arguments in radians), arcsin, arccos, arctan, and arccot for the 
inverse sine, cosine, tangents, and cotangents (result in radians), abs for the absolute 
value, and int, floor, ceil for integer parts of the argument, respectively. In addition 
there are a number of logical operators and the IFTE operator for if-then-else con-
structs. 

You use terms of the form #1, #2, etc. to reference the values of the respective input var-
iable. Use the term %H for the elevation at the station position (given in meters above 
sea level; positive for land and negative for ocean), %t  for the time of observation (in 
years since 1900 calculated from station date and time metadata; e.g., %t=84.4877 for 
June 27 1984), %d for the day of the year  (also calculated from station date metadata), 
%x  for the (east-) longitude and %y for the (north-) latitude, respectively.  

You can store intermediate results of the calculations in internal variables %0, %1, etc. 
using the operators =%0, =%1, etc. Stored values can be used later in the calculation by 
typing %0, %1, etc. Note that the =%n operators consume their operands, e.g., the respec-
tive value is taken off the stack.  

Operands and operators must be separated by one or more spaces. You may continue 
the definition of the macro expression on following lines, if necessary.  

 
Table 6-4: Example expressions 

Postfix Expression Meaning 

135 #1 *  #2 + PO = 135 * PO4 + O2  (with: PO4 as #1 and O2 as #2) 

%t 80 - 17.6 / exp #1 * 𝑐𝑐 ∙ 𝑒𝑒(𝑡𝑡−1980) 17.6⁄    (tritium decay correction to 1980; c as #1) 

#1 ln ln(#1) (natural logarithm) 

#1 ln 0.43429 * log(#1) (base-10 logarithm) 

0 #1 max max(0,#1) (maximum value) 

#1 180 <  #1 365 +  #1 IFTE if #1<180: (#1+365); else #1 (if-then-else expression) 

 

6.3 Expressions 

Expression derived variables are similar to macros. They can be defined and edited 
with the ODV macro editor and they use the same syntax and operator set. To set up an 
expression, select Derived Variables from the current sample window popup menu, 
choose Expression from the Choices list and press Add. ODV will show a dialog similar to 
the macro editor dialog. You should enter the label of the new variable and the corre-
sponding units in the Label and Units fields. Then, select the input variables required by 
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the new variable, e.g., select a variable in the Choices list and press <<. Finally, specify 
the expression to be evaluated for the new quantity. See the paragraph Expression un-
der Macro Editor for a description of supported operators and general syntax guide-
lines. Press OK to finish the setup of the new expression.  

You can edit ODV macros and expressions by using the Derived Variables option from 
the current sample window popup menu. Then select the respective variable in the Al-
ready Defined list box and press Edit. You can save an expression in an ODV macro file 
by pressing Save As on the Edit Expression dialog. 

 

 
Figure 6-4: The edit expression dialog 

6.4 Difference Variables 

You can compare property distributions of the currently selected stations with previ-
ously saved reference data and produce difference fields by defining property differ-
ences as derived variables. Choose View > Derived Variables or press Alt+D and select 
Difference from Reference. Then choose the ExportID.txt file of the reference dataset that 
you want to use in one of the subdirectories of reference data directory tree. ODV will 
show a list of available reference data files from that directory. Select an .oal file that 
has the variable for which you want to produce the difference field as Z variable and ap-
propriate X and Y variables (e.g., for producing longitude vs. depth sections, make sure 
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the reference data file has longitude as X and depth as Y variable). Then identify the Z, X 
and Y variables in the current collection (if longitude or latitude are required, define 
them as derived variables prior to invoking the Difference from Reference option) to 
complete the definition of the difference variable. Note that the name of the new varia-
ble is composed of the name of the Z variable and the identification string of the refer-
ence data set. Once defined, you can use the difference variable in any data plot. 

6.5 Patches 

You can define water-mass patches by specifying polygons in the X/Y space of any data 
plot currently displayed on the screen. To do so, move the mouse over the data plot that 
you want to use for definition (e.g., theta/S plot) and click the right mouse button. From 
the popup menu choose Extras > Define Patch (note that the cursor changes to a cross-
hair) and define the nodes of the patch-polygon by clicking the left mouse button at the 
node positions. You may delete points by moving the mouse close to the respective 
point and clicking the right button. Terminate definition of the polygon by pressing En-
ter or double-clicking the left mouse button. Note that the polygon is automatically 
closed by ODV. ODV then prompts you for a patch name (no extension) and writes the 
patch definition to a file in the collection directory. 

 

 
Figure 6-5: Using patches to identify the extent of water masses 

 

Once you have defined one or more water-mass patches for a collection, you can use 
them to compose and activate the derived variable Patches. Choose View > Derived Vari-
ables and select Patches from the Choices list. You can compose the Patches variable by 
selecting one or more of the available water-mass patches (defined previously as de-
scribed above) into it. Press OK when you are done. To evaluate the Patches variable for 
a given sample, ODV determines whether the sample is inside one of the patch-polygons 
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selected into the variable, and (if found) assigns the number of the respective patch as 
Patches value. If the sample is outside all the selected patches, its value is set to the 
missing data value.  

Like all other variables (basic or derived) you can use the Patches variable on any axis 
of any data window. Use it, for instance, as Z-variable along sections or for isosurface 
variables in order to display the spatial extent of specific water masses (see Figure 6-5). 
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7 Isosurface Variables 

Often there is a scientific need to calculate and display the distribution of a variable on 
specific space or time surfaces or layers. Examples are constant depth or pressure lay-
ers, surfaces of constant density (isopycnals) or, in case of time series data, constant 
time slices. ODV provides isosurface variables for defining such distributions. By defini-
tion isosurface variables have exactly one value per station. Values of isosurface varia-
bles can be plotted in data windows of scope SURFACE. 

Isosurface variables are defined in ODV using View > Isosurface Variables or by right-
clicking on the Isosurface Data Window and choosing Isosurface Variables. ODV will 
show the Isosurface Variables dialog (Figure 7-1) that lets you define new isosurface 
variables and modify or delete existing ones. To delete one or more existing isosurface 
variables select the respective entries in the Already Defined list and press Delete.  

To add a new isosurface variable first construct the new variable inside the New box 
and then press Add. Constructing an isosurface variable requires specification of (1) the 
variable to be displayed on a given surface (display variable), (2) the variable that de-
fines the surface (surface variable) and (3) the value of the surface variable on the sur-
face (surface value). In addition to numeric surface values, you may also enter the key-
words first, last, minimum or maximum. You specify a numeric surface value by entering 
the number into this field. For keywords first and last ODV retrieves the first or last 
non-miss value of the display variable according to the sort order of the primary varia-
ble. For minimum or maximum ODV first determines the sample with the minimum 
(maximum) value of the surface variable and then uses the value of the display variable 
of the given sample. 

 

 
Figure 7-1: The isosurface variables dialog box 

 

If an isosurface variable is selected in the Already Defined box you can synchronize all 
other variables to use the same surface by clicking on the S-Sync button (surface syn-
chronization). You can synchronize all other variables to use the same display variable 
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by clicking on the V-Sync button (variable synchronization).  

Obviously, you must first define a derived variable, such as potential density or pres-
sure, before it can used as display or surface variable of an isosurface variable. The total 
number of isosurface variables is unlimited. Isosurface variable values for the current 
station are shown in the Isosurface Data Window. 

Calculation of isosurface variables with numeric surface value such as Salinity [psu] @ 
Depth [m] = 500 is performed by using the available sample (Salinity) values to obtain a 
linearly interpolated value on the isosurface. For stations with type B (bottle data) or 
with less than 100 samples interpolation is using piece-wise linear regression taking 
into account all data of the station. For stations with type C and more than 100 samples 
the linear interpolation involves only the two nearest samples on both sides of the sur-
face.  

Before performing the interpolation, ODV checks the data coverage of the display varia-
ble (Salinity), and, if data gaps are found to be too large, no interpolation will be at-
tempted and no isosurface value will be calculated for this station. The good coverage 
criteria used to evaluate the significance of data gaps can be inspected and modified us-
ing option Collection > Good Coverage Criteria.  

Station meta information, such as decimal time, day-of-the-year, as well as longitude 
and latitude of a station are always provided as automatic isosurface values. 

The quality of isosurface data using the first, last, minimum or maximum keywords de-
pends very much on the distribution of available data and on the presence or absence of 
pronounced extrema in the data. Therefore, these keywords should be used with care.  

Keywords first or last should only be applied when all stations have their first or last 
sample at similar values of the primary variable, or extent over the entire water column. 
Using first or last will then truly reflect surface or bottom conditions. These keywords 
should not be used if the depths of the first and last samples differ widely between sta-
tions, for instance, when some stations extend to the bottom while others only cover 
part of the water column.  

Keywords minimum or maximum should only be used in regions where the surface vari-
able exhibits pronounced minima (maxima) and the available data clearly resolve the 
features. For stations with multiple minima (maxima) the one with the smallest (larg-
est) value of the surface variable is selected. Note that for a set of stations the absolute 
minimum (maximum) could be attained in different minima (maxima) layers. You may 
specify range sample filters to restrict the search for extrema to a user-defined interval 
by right-clicking on the Isosurface Data Window, choosing Sample Filter > Customize 
Settings > Range and specifying range for one of the variable (e.g., depth, pressure or 
time). 

7.1 Drawing Isosurface Variables 

Once you have defined isosurface variables, you can use these variables on the Y, Y and 
Z axes of data windows with SURFACE scope. If plotting gridded fields on depth levels, 
the closest isobath will be used automatically as an overlay layer. If original data points 
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are plotted, a gray-shaded ocean bathymetry is used as background. 

8 Selection Criteria 

8.1 Station Filter 

While drawing the station map, ODV checks all stations in the currently open collection 
and determines whether the current station filter settings are satisfied. Only stations 
that pass this test are considered valid. Only these stations are marked in the map and 
only this station subset is available for subsequent browsing and plotting.  

 

  

  

  
 

Figure 8-1: The station filter dialog pages 
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You can modify the station filter settings by using Station Filter from the Current Station 
Window popup menu or View > Station Filter from the main menu. Choose the category 
that you want to modify by clicking on the respective tab, e.g., Name/Range, Date/Time, 
Domain, Meta Data or Availability, and modify the items of interest.  

The Meta Data page is subdivided into two parts, covering numeric and string meta var-
iables separately. In both cases you first select a variable from the combo-box on the top 
and then specify numeric ranges for numeric meta variables or wildcard expressions 
(string meta variables) to be satisfied. Wildcard expressions can have multiple entries 
separated by ‘ || ‘ as shown below. The syntax of wildcard expressions is summarized in 
Table 8-1. If you enter pure text (no wildcard characters included) and the meta varia-
ble has value type INDEXED_TEXT, ODV indicates whether the entered string exists in 
the collection or not. This allows for quick checks of whether specific terms are present 
in the collection. 

On the Availability page you can select one or more data variables as required variables. 
Stations are only considered valid if they contain data for the required variables. Multi-
ple required variables can be combined in two ways, using AND or OR logic. With AND 
logic, data must exist for all required variables, while with OR logic data availability for 
one of the required variables is sufficient.   

On the Name/Range tab you can select stations by cruise label, station label range, sta-
tion type, and range of internal station ID numbers. For the cruise label selection you 
may select a specific cruise label from the list or you may specify one or more regular 
expressions (wildcard patterns) in the Cruise Label field. In the latter case, any cruise 
label that matches one of the regular expressions will be considered valid. Example reg-
ular expressions that can be used for cruise labels are summarized in Table 8-1. If en-
tering more than one cruise label specification, use two bars “ || ” to separate the en-
tries.  

Example:  OCE13[34]   ||  A16N   ||  S05* 

Selects cruises OCE133 and OCE134 and cruise A16N and all cruises starting with S05. 

 
Table 8-1: Regular expression syntax for cruise labels 

Character Meaning 

Arbitrary character Any character represents itself apart from those mentioned below. 
Example: c matches the character c. 

? This matches any single character. 
Example:  SAVE_LEG? matches SAVE_LEG1, SAVE_LEG9, SAVE_LEGa, etc. 

* This matches zero or more of any characters.  
Examples: I01_*  matches any label that has I01_ at the beginning; *06AQ* 

matches any label that has 06AQ in the middle. 

[...] Sets of characters can be represented in square brackets. Within the character 
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class, like outside, backslash has no special meaning. The dash (-) is used to in-
dicate a range of characters; the caret (^) negates the character set if it occurs 
as the first character, i.e. immediately after the opening square bracket. 
Examples: I05[EW] matches I05E and I05W; LEG[0-2] matches LEG0, LEG1, 

LEG2; SAVE_LEG[^3] matches all SAVE_LEG? cruises except 
SAVE_LEG3. 

 

The Date/Time tab lets you specify a valid time interval (Period), a valid calendar inter-
val (Season), and a valid day time range (Day Time). A station must satisfy all three cri-
teria to be considered valid. The Season and Day Time ranges may span consecutive 
years or days, e.g. [Oct/20 - Feb/03] or [21:09 - 04:15] are acceptable season and day 
time ranges.  

In the Domain category you can define a rectangular sub-domain of the map by specify-
ing respective longitude/latitude values or you can press the Zoom button to define a 
rectangle by zooming. You can define a polygon as the valid domain by pressing the Pol-
ygon button and then entering the vertices of the polygon with the mouse. Note that the 
polygon is closed automatically.  

On the Meta Data tab you may specify ranges for numeric meta-variables and wildcard 
patterns for text meta-variables. To enter a specification first click on the combo boxes 
containing the lists of variables, choose your variable of interest, and then specify the 
acceptable value range or the wildcard pattern. See Table 8-1 for a summary of possible 
wildcard patterns. Note that you can enter more than one wildcard pattern, using two 
bars “ || ” as separation string. The entries are combined with OR logic, e.g., a meta value 
matching any one of the entries is considered valid. 

In the Availability category you can mark one or more variables for which data must be 
available for a station to be considered valid.  

On the Invert tab you can invert the station selection, e.g., all stations that do NOT sat-
isfy the criteria will be selected if the Invert Selection box is checked.  

Pages containing active station filter settings have an asterisk * appended to their page 
name and are easily identified. To remove the selection criteria of a given page, click on 
the respective page title and press the Relax Criteria, Map Domain or None Required but-
tons. 

Note that the selection criteria on the different pages are combined using the logical 
AND operator, e.g., a station is considered valid, only if it satisfies all station filter set-
tings. Press OK when you are done. ODV will rebuild the station map using the new se-
lection criteria. 

8.2 Sample Filter 
ODV maintains individual sample filters for each data window as well as for the isosurface 
value calculator. These filters accept and reject samples based on data values (range and 
wildcard filtering) and/or quality flag values (quality filtering). A quality filter specifies the 
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acceptable quality flag values. A range filter (numeric data variables only) specifies the mini-
mum and maximum acceptable values. A wildcard filter (string data variables only) specifies 
one or more wildcard specifications that must be matched by the respective string values (for 
details see below).  
Separate sample filters can be applied for the different data windows (see below). There is an 
additional sample filter that is applied during calculation of isosurface variable values. In all 
cases a given sample is considered valid only if it satisfies all the specified sample filter 
settings. Only valid samples are shown in the different data windows, and only valid 
samples are used for calculation of isosurface variable values. Please note that the Cur-
rent Sample Window always shows all data, and there is no sample filter applied. 

You can modify the sample filter of a data window by right-clicking on the window and 
choosing one of the options of the Sample Filter sub-menu: Accept All Data, Reject Outli-
ers and Customize Settings. The first two options are automatic and easy to use. Option 3 
provides the full control over all filter settings as via the Sample Filter dialog shown be-
low. You modify the sample filter settings used for isosurface variable calculation by 
right-clicking on the Isosurface Data Window and choosing one of the options. 

When using the Sample Filter dialog first choose the category you want to modify by 
clicking on the respective tab, e.g., Quality or Range, and modify the items of interest.  

On the Quality tab select the variable for which you want to establish a data quality fil-
ter, and then select the quality flags to be accepted. Click on Apply to all variables to ap-
ply the same quality filter for all variables using the same quality flag schema as the se-
lected variable. Click on Relax this quality filter if you want to accept all quality flags for 
the selected variable. Then also click on Apply to all variables if you want to relax all 
quality filters of all variables using the same quality flag schema as the selected varia-
ble. 

Use the filter settings on the Range tab, if you want to see only samples that have values 
(for one or more variables) in specific value ranges. For instance, if you are studying the 
upper water column and only want to see samples between 0 and 500 m depth, choose 
the depth variable and enter the desired range under Acceptable Range. You can specify 
range filters for more than one variable at a time. For text variables you can specify one 
or more wildcard expressions like this “N* || Gerard”. This will select only samples for 
which the variable’s text value starts with “N” or is equal to “Gerard”. 

When editing the sample filter of an overlay data window the modified sample filter of 
the overlay window is automatically also applied to the parent  window. 
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Figure 8-2: The sample filter dialog pages 
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9 Station Map 

9.1 Map Properties 

The properties of the station map can be modified via the Properties option of the map’s 
popup menu or via View > Window Properties > Map. This includes changing the map 
domain and projection, the appearance of ocean bathymetry, coastlines, and land topog-
raphy, the style of the station dots, as well as general properties such as graphics font 
size or the axis labeling color and style (Figures 9-1 and 9-3). 

 

   
 

Figure 9-1: The various pages of the Map Properties dialog (part 1 of 3). 

 

General  

On the General page you can define the color palette used by the map, the background 
color of the map window, a base font size and font size factor and the color of the axis 
and axis annotations. Grid-lines can be switched on or off. 

Display Style  

On the Display Style page you define the color and the size of the station marks in the 
map. Choosing (automatic) for the color will cause different colors for the different 
cruises in the data collection. 

Projection  

On the Projection page you choose the map projection and the longitude and latitude of 
the projection pole (position of the viewer).  The following projections are currently 
available: (1) Default Projection, (2) Orthographic (North Polar), (3) Orthographic 
(Equatorial), (4) Orthographic (South Polar), (5) Orthographic (Oblique), and (6) Moll-
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weide. The default projection is linear in longitude and latitude directions. The ortho-
graphic projections are hemispheric, while the default and Mollweide projections are 
global in extent. All projections allow zooming-in with the mouse or the definition of 
sub-regions using the Domain page of the map Properties dialog (see below). For the Or-
thographic (Oblique) projection you can specify an arbitrary longitude/latitude eye po-
sition (pole), from which the globe is then viewed. For the other projections the pole 
latitude is fixed and the user may only vary the pole longitude. 

Note that for projections (2) to (6) the definition of sub-domains by zooming can be 
tricky. If you need accurate results, either use the Domain page of the map Properties di-
alog (see below) or switch to default projection temporarily, then zoom (thereby defin-
ing the sub-region) and finally switch back to the desired map projection. 

Layers  

ODV comes with a large number of map resource packages (called Series) containing 
medium or high-resolution bathymetric and topographic contours as well as coastline, 
lake, river, and border data. The medium resolution, global GlobHR series is automati-
cally installed with the ODV software. For information on other available map resources 
and installation instructions see the Map Layer Series section in chapter 2.12. 

On the Layers page you select the bathymetry-coastline-topography Series and specify 
the layers within the different Layer Set categories. You switch on or off the drawing of 
the map’s color bar by checking or unchecking the Draw color bar box.  

There are two ways of selecting a Series for use in the ODV station map: automatic or 
manual. 

 

  

Figure 9-2: The various pages of the Map Properties dialog (part 2 of 3). 

 

Automatic Series Selection 

You switch automatic series selection on by checking the Automatic selection checkbox. 
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In this mode, ODV will automatically determine the best available series for a given map 
domain and use this series for the station map. Whenever the map domain is changed 
(e.g., by zooming or using the Full Domain or Global Map options on the map popup 
menu) ODV will find and use the best installed series for the new domain. ODV will also 
automatically select the ocean bathymetry and land topography layers suitable for the 
given domain. You switch on or off the drawing of ocean bathymetry, coastlines, land to-
pography, lakes and rivers, and national borders by checking or unchecking the respec-
tive checkbox.  

For automatic series selection to be useful you should install one or more of the high-
resolution bathymetry-coastline-topography series available from the ODV website. For 
information on other available map resources and installation instructions see the Map 
Layer Series section in chapter 2.12. 

If you have created your own custom coastline-bathymetry series and want to have it 
included in the automatic series search, you must create a settings file containing infor-
mation on the domain and spatial resolution of the series. See chapter Preparing Custom 
Coastline and Bathymetry Files for more information. 

Manual Series Selection 

Unchecking the Automatic selection checkbox lets you select the bathymetry-coastline-
topography series manually, and also allows composing individual layer sets and speci-
fying their graphical appearance. This mode gives you widest possible control over the 
design of the station map.  

You may select any of the installed series by clicking into the Series combo-box. Please 
note that some series are regional and that you may have to manually adjust the map 
domain to the respective series domain. Once a series is chosen, you may define the lay-
ers in the various Layer Set categories (see below). When the map is drawn, the layer 
sets (and the layers within the sets) are drawn in the given order. 

To obtain information on a selected layer set (e.g., Ocean Bathymetry), click on the Layer 
Set Info button. To define the layers of a selected layer set, click on the Compose button. 
Note that default layers are defined for all categories; if the resulting map display suits 
your needs you don’t have modify any layer set.  
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Figure 9-3: The map’s layer definition dialog. 

If you pressed the Compose button, the layer definition dialog (Figure 9-3) appears. You 
add layers by selecting them in the Available list and pressing the << button. Layers can 
be removed by selecting them in the Selected list and pressing the >> button. Depending 
on the properties in the Line and Fill boxes, a given layer may be filled and/or its outline 
may be stroked. The default color settings are (automatic) in which case an appropriate 
color will be chosen automatically (recommended). You may override these settings 
and choose specific colors by clicking into the respective combo-box. Choose (none) if 
you don’t want filling and/or stroking. Note that you may change the properties of a 
given layer in the Selected list by clicking on it, then modifying the settings under Line 
and Fill, and, finally, clicking << to implement the changes. 

 

Domain  

On the Domain page of the map’s property dialog you may specify the map domain by 
providing east and west longitudes and south and north latitudes. You may also choose 
the domain spanned by the stations in the collection (native domain) by clicking on Full 
Domain or a global domain by clicking on Global Map. 
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Figure 9-4: The various pages of the Map Properties dialog (part 3 of 3). 

 

Annotations 

On the Annotations page you may specify whether you want the picked stations (see be-
low) annotated in the map or not. Choose Station labels if you want the station labels of 
the picked stations drawn next to the station positions, choose Cruise and station labels 
if the annotations should also include the cruise label, or choose No annotations if you 
don’t want annotations. Note that you can change the position of the annotation relative 
to the station position using the Pick List Editor (see below). 

9.2 Picked Stations 

The station map maintains a list of picked stations. The data of the picked stations are 
drawn in STATION data windows, and the picked stations are also marked in the map, 
using the same color and symbol as in the data windows. You can add a station to the 
pick list by making it the current station (for instance by left clicking on that station) 
and pressing ENTER. Double-clicking a station with the left mouse button will also add 
the station to the pick list. Note that the data of the newly added pick station are added 
to all STATION data windows and that it is also marked in map. To delete a station from 
the pick list make it the current station (for instance by clicking on one of its data points 
in one of the STATION data windows) and press the Del button.  

You may edit the entire pick list using option Manage Pick List > Edit Pick List from the 
map popup menu. The Pick List Editor dialog will appear letting you edit the properties 
and graphical appearance of every station in the pick list. You may also change the or-
der in the list or delete individual stations from the list, or empty the list altogether. 
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Figure 9-5: The Pick List Editor dialog 

Note that if your current view contains picked stations but no STATION data window is 
displayed the picked stations are simply highlighted in the map by a black cycle around 
the station symbols. As soon as a STATION data window is created the chosen symbols 
are displayed again. Furthermore, note that for picked stations whose station type dif-
fers from ‘B’ no symbols are assigned initially and just the line between the station’s 
samples is highlighted. Once you define a symbol type manually it will be used perma-
nently (introduced in ODV version 4.2.0). 

9.3 Sections 

You must define a section in the station map before SECTION data windows can be plot-
ted. To define a new section or use a previously defined section right-click on the map 
to invoke the map popup menu. Choose Manage Section > Define Section if you want to 
define a new section or Manage Section > Load Section if you want to load a previously 
defined one. In the latter case simply select a section file from the file open dialog (e.g., 
by double-clicking on it). If you create a new section, ODV temporarily switches to a full 
page map for easier definition of the section spine. Note that the mouse cursor changes 
to a cross hair indicating that the user is expected to enter a sequence of points defining 
the centerline of the section. 

You enter a point by moving the cross hair to the desired location and clicking the left 
mouse button. To remove a point, move the mouse close to it and click the right mouse 
button. To accept the set of points press ENTER or specify the last point with a double-
click of the left mouse button. Note that you may construct rather complicated sections 
following arbitrary cruise tracks as shown in Figure 9-6.  
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Figure 9-6: The GEOSECS western Atlantic section 

 

After specifying the section spine, ODV assigns a default width to the section band and 
selects distance from the starting point (the first point entered) as the default along-
section coordinate. These and many other section properties may be modified on the 
Section Properties dialog (Figure 9-7) that appears automatically after specifying the 
section spine. The Section Properties dialog may be invoked at any time by choosing 
Manage Section > Section Properties from the map popup menu. 

On the Section Properties dialog, you may choose Distance, Longitude, Latitude or Time 
as along-section coordinate, you may set the width of the section band, choose the 
source of bathymetry values and select a color for the section bathymetry and specify a 
title for the section.  

 
Figure 9-7: The Section Properties dialog 
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Every section can have a bathymetry polygon, which can be defined in a number of 
ways: (1) using the station’s bottom depth metadata, or (2) using global or regional 
gridded bathymetric datasets provided in special netCDF files, or (3) using an ODV 
POLYGON graphics object from a .gob file. Gridded bathymetry files can be downloaded 
and installed using the View > Settings > Gridded Bathymetry > Resources option (on Mac 
OS odv > Preferences > …). An example of a section using shipboard bathymetric data 
from a .gob file as section polygon is shown in Figure 9-8.  

Note: For the bottom bathymetry to be shown in a section plot ensure that the Y varia-
ble of the plot has been identified as Depth in the Water Column or Pressure in the Water 
Column variable. Use option Collection > Identify Key Variables to inspect and verify the 
identification. 

 

 
Figure 9-8: Section using shipboard bathymetric data for the section bathymetry polygon 

 

You can save the current section in a file by choosing the Manage Section > Save Section 
As option. You can load saved sections later, by choosing Manage Section > Load Section. 
Select Manage Section > Remove Section to remove a section.  

Note that all stations inside the section band marked in the map belong to the section. 
The data of all these stations are plotted in SECTION data windows. 
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9.4 Station Distributions 

You can produce plots of the spatial and temporal distributions of the stations in the 
map by choosing Extras > Statistics from the map popup menu or by pressing F4 while 
the mouse is over the map. The Map Statistics dialog will appear that lets you view the 
distributions of the currently selected stations in the map versus time or season (press 
buttons Time Histogram or Season Histogram, respectively). The histograms are shown 
in separate dialog windows (see Figure 9-9). You may save the graphics in GIF, PNG, JPG 
or Encapsulated PostScript files by pressing Save As and choosing the appropriate file 
type.  

 

  

Figure 9-9: Example time and season histograms of stations in the map. 

 

Pressing X/Y Distribution on the Map Statistics dialog produces a plot showing the data 
density in the entire map domain via the number of stations within small tiles. This dis-
tribution plot allows easy identification of areas of dense station coverage, especially in 
cases with very large numbers of stations and many repeat stations plotting at the same 
location in the station map. You may zoom into the map and repeat the above proce-
dures to obtain station density information with higher spatial resolution (see Figure 9-
10). 
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Figure 9-10: Example station map and station distribution plots with different levels of spatial resolution.  
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9.5 Longitude Sign and Value Conventions 

1. Longitude metadata in ODV collections are stored in degrees East [0° – 360°]. 

2. The Export > Station Data > ODV Spreadsheet File and Export > Station Meta Data 
options let the user select the longitude output convention: (1) [0° – 360°] or (2) 
[-180° – 180°].  

3. The export of data from station maps and data window maps via Export > X, Y, Z 
Window Data and Extras > Clipboard Copy produce longitude values as currently 
used in the station or data window maps (see 4).  

4. Sign and value of longitude metadata in the station or data window maps depend 
on the fact whether the map domain spans across the Greenwich meridian (b) or 
not (a): 
• (a) Greenwich meridian not in map domain or as eastern or western bound-

ary,  
• (b) Greenwich meridian in the domain interior. 

In case (a) map longitudes are always positive and in the [0° – 360°] range (val-
ues represent degrees East). In case (b) longitudes east of the Greenwich merid-
ian are positive (degrees East), while longitudes west of the Greenwich meridian 
are negative (degrees West). In all cases map longitudes are monotonically in-
creasing from west to east as indicated in the figure below. 

 

  

Figure 9-11: Longitude conventions in ODV maps. 



Version 5.1.0 

 106 

  



ODV User’s Guide  
 

    107 

10 Data Windows 

10.1 Data Window Properties 

The properties of data windows may be modified by right-clicking on the respective 
window and choosing the Properties option. Alternatively, you may also use View > Win-
dow Properties > Window x, where x is the number of the window. Some of the window 
settings, such as value ranges or variables on the X, Y, and Z axis of the window may 
also be modified using the Set Ranges and X-, Y-, and Z-Variable options of the data win-
dow popup menu. 

 

   

Figure 10-1: The various pages of the Data Window Properties dialog (part 1 of 2). 

 

The data window Properties dialog consists of six separate pages (see Figures 10-1 and 
10-5). 

General  

On the General page you can define the color palette used by the data window, the back-
ground color of the data window, the highlighting style of the current station, a base 
font size and font size factor and the color of the axis and axis annotations. Grid-lines as 
well as the automatic variable labels on the axes can be switched on or off. You may cus-
tomize the text on the axes by switching off the automatic axis titles and creating your 
own annotation graphics objects. 

Data  

On the Data page you can define the scope of the data window, the variables on X, Y, and 
Z, as well as various axis properties. Normal axis orientation is to have increasing val-
ues from left to right for X, bottom to top for Y, and bottom to top in the color bar for Z. 
You may reverse the orientation on one or more axes, for instance, to create depth in 
the ocean values decreasing upward, by checking the respective Reverse range box. 



Version 5.1.0 

 108 

To modify X, Y, and Z axis properties click on X-Axis Settings, Y-Axis Settings, or Color bar 
Settings. The axis properties dialog (Figure 10-2) will appear, letting you specify the 
value range on the respective axis, a linear, logarithmic or stretched projection along 
the axis, the spacing of labeled and unlabeled tic marks and the position of the labeled 
axis. Choosing (automatic) for the tic mark spacing lets ODV determine the location and 
frequency of the marks automatically. The Position entry allows a choice of axis position 
(left or right; bottom or top) or lets you switch off the labeling of the respective axis al-
together. 

Note: ODV applies special labeling strategies if detects a decimal time variable on an 
axis. Label spacing may not be changed by the user in such cases. 

  

 
Figure 10-2: The Axis Properties dialog. 

 

ODV supports the following projections of the X- and Y axis: (1) Linear (the default), (2) 
Logarithmic, (3) Stretched Left (Upper) Part, (4) Stretched Left (Upper) Part (strong), 
(5) Stretched Middle Part, (6) Stretched Middle Part (strong), (7) Stretched Right (Top) 
Part, (8) (7) Stretched Right (Top) Part (strong). Following below are example figures 
showing the use of logarithmic and stretched upper Y-axis. Note the increased resolu-
tion in the upper water column in the section plot. 

Display Style  

On the Display Style page you can switch between the two fundamental plot types of 
ODV, Original data and Gridded field by clicking on the respective item. 

For Original data you may select display types Colored Dots, Sized Dots, Numbers, or Ar-
rows to obtain colored dots, sized dots, numerical values or arrows at the measurement 
locations. Specify the size and color of the dots or the font size and color for the numeri-
cal values in the two fields under Symbol size. Note that the selected color is only hon-
ored in SECTION, SCATTER, and SURFACE data windows without a Z-variable. In data 
windows with Z-variable the color (or size) of the dots is determined by the Z-values. In 
STATION windows the different picked stations use different colors. These colors are 
assigned automatically, but may be modified by the user at any time. The Line width en-
try is only honored in STATION data windows. 
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Figure 10-3: Example figures showing the use of logarithmic and stretched upper Y-axis. 

 

In case of Sized Dots the maximum size of the dots is taken as 10 times the specified 
Symbol size, the fill color is given by the Symbol color, the border color and border width 
are taken from the data mark color and Line width entries, respectively. A sample dot 
representing the maximum Z-range value is plotted in the lower left corner of the data 
window. You can adjust the maximum Z-range value using the Set Ranges option of the 
data window. The sample dot and the associated annotation can be dragged to other po-
sitions, and the new position is remembered in the view file.  

If you choose Arrows the Arrow Properties dialog (Figure 10-4) will appear, letting you 
select the variables providing x- and y-components of the arrows, as well as an arrow 
scale, line width and color for the arrows. If you choose Color (automatic) the arrow 
color is determined by the value of the Z-variable at the arrow location. Make sure that 
a Z-variable is defined if using (automatic) color. To bring up the Arrow Properties dia-
log again and modify the arrow settings click on the Arrows entry under Original data. 

Instead of showing colored dots at the sample positions you can also produce gridded 
property fields for any data window that has a Z-variable (property distributions along 
sections or on isosurfaces are examples) by clicking on Gridded field. Then choose one 
of the available gridding methods, Quick gridding, Weighted-average gridding and DIVA 
gridding. Then specify appropriate averaging length-scales for the X- and Y-axis, respec-
tively. Note that length- scale values are in per mille of the full axis range and that large 
values result in smooth fields. You should experiment using different length-scale val-
ues until an acceptable compromise between preservation of structure in the data and 
smoothness is achieved. If you check the Automatic scale lengths checkbox, ODV will an-
alyze the data distribution and choose the gridding length-scales automatically. 

In section windows ODV provides Isopycnic gridding as an advanced gridding procedure 
that will align property contours more along lines of constant density (isopycnals). This 
feature is available if neutral density γn or a potential density derived variable is defined 
and DIVA gridding is used. For more details see below. 

Note that gridded fields may be poor representations of the data if performed improp-
erly. 
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All ODV gridding methods assign for every estimate at a given grid point (x, y) a dimen-
sionless quality value. Quality values are based on the distances from the estimation 
point (measured in units of respective averaging scale lengths) of all data points used 
for the estimate. Quality values larger than about 3 should normally be considered as 
problematic, indicating that the nearest measurement is more than two length-scales 
away from the estimation point.  You can choose to hide bad estimates with large qual-
ity values by checking the Hide bad estimate box and specifying an appropriate Quality 
limit value.  

 

 
Figure 10-4: The Arrow Properties dialog. 

 

The gridded field is color shaded by ODV if Do color shading is checked. The positions of 
the actual data points are marked in the plot if Draw marks is checked and appropriate 
size and color are specified for the dots. Contouring (see below) and color shading of 
the property fields are supported for all gridding modes.  

 

   

 

Figure 10-5: The various pages of the Data Window Properties dialog (part 2 of 2). 

 

Contours 

The Contours page of the data window properties page allows you to define contour 
lines for the plot. This page is only enabled if Gridded field is choosen as display style 
(see above). To specify an automatic selection of contour lines, click the Auto Selection 
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button. To add sets of contour lines manually specify Start, Increment and End Z-values 
in the New group. Choose appropriate line and label properties and press the << button 
to add the set of contour lines to the Already Defined list. If necessary, repeat this proce-
dure with different Start, Increment and End values and possibly different line and label 
properties. You can modify the properties of an existing contour line by selecting it in 
the Already Defined list, modifying the properties in the New group and pressing the << 
button to implement the changes.  

In addition to stroking the contour line associated with a given Z-value z you can also 
ask ODV to fill the region defined by Z-values larger than z using an automatic or user 
specified color by choosing the color under Fill. Figure 10-6b was produced by using 
(automatic) under Fill for all contour lines. 

 
Figure 10-6: Comparison of (a) continuously shaded and (b) contour shaded fields. 

Color Mapping  

The Color Mapping page lets you manipulate the mapping between Z-variable values 
and associated color. This page is only enabled for data window with a Z-variable (e.g., 
color sections or color distributions on isosurfaces). Press the Auto Adjust button to es-
tablish a possibly non-linear mapping, automatically constructed on the basis of the dis-
tribution of Z-values. Pressing the Linear Mapping button will restore the default, linear 
color mapping. You may establish customized color-mappings by moving the Median 
trackbar to the Z-value to receive the highest color-resolution and increase the non-lin-
earity using the Nonlinearity trackbar.  

DIVA Settings  

The DIVA Settings page lets you manipulate parameters that control the DIVA gridding 
algorithm. For details see the description of the DIVA gridding method. Note that this 
page is disabled if the data window does not use DIVA gridding. 
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10.2 Zooming and Automatic Scaling 

You can change the variable ranges of any data plot by moving the mouse over this win-
dow, clicking the right mouse button to invoke the data window popup menu and 
choosing either Full Range or Zoom. For Full Range, the X- and Y-Ranges of the current 
window are adjusted to accommodate all plotted data values in this window. If you use 
Full Range (All) on the canvas popup menu you can auto-scale all data plots on the 
screen in one operation. 

If you select Zoom, a red zoom-frame appears around the current window. To manipu-
late this zoom-frame move the mouse over its edges, corners or interior, press the left 
mouse button and drag the edges, corners or the entire frame to the desired locations. 
Note that the x/y coordinates of the lower/left and upper/right corners are indicated in 
the middle part of the status bar. To accept the current setting of the zoom-frame and 
adjust the variable ranges accordingly double-click the left mouse button or press 
ENTER. If you want to abort the zoom operation and keep the original variable ranges, 
press ESC or click the right mouse button. 

In addition to the normal zoom procedure described in the previous paragraph there is 
an additional zoom method (quick-zoom) that may be even easier and quicker to use in 
many situations. While the mouse is over a data window or the map press and hold 
down the Ctrl key (on Macintosh systems use the cmd key), then press and hold down 
the left mouse button and move the mouse to open a zoom box. Releasing the left mouse 
button applies the zoom box settings to the window from which the quick-zoom was ini-
tiated. 

The changes are applied to the window that was zoomed into. If range synchronization 
is on (see the View > Settings > Windows dialog page; on Mac OS odv > Preferences > Win-
dows) the new ranges are also applied to other windows using one of the modified vari-
ables. 

10.3 Z-Zooming 

All data windows with a color bar allow modifications of the Z-variable range by zoom-
ing into the color bar (Z-zooming). To invoke Z-zooming move the mouse over such a 
data window and click the right mouse button to bring up the data window popup 
menu. Selecting Z-Zoom will draw a red zoom-frame around the color bar of the respec-
tive window. Manipulate and drag this zoom-frame as described above. To accept the 
current setting of the zoom-frame and adjust the Z-variable range accordingly, double-
click the left mouse button or press ENTER. If you want to abort the zoom operation and 
keep the original Z-variable range, press ESC or click the right mouse button. 

The changes are applied to the window that was zoomed into. If range synchronization 
is on (see the View > Settings > Windows dialog page; on Mac OS odv > Preferences > Win-
dows) the new ranges are also applied to other windows using one of the modified vari-
ables. 
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10.4 Changing Window Layout 

The position and size of the station map as well as the number, position and size of zero 
or more data windows can easily be modified using View > Window Layout from the 
main menu, the Window Layout option of the canvas popup menu or by pressing the 
shortcut key Alt-W. ODV will outline the current layout and lets you move, resize, delete 
or create windows. To perform one of these operations on a window, move the mouse 
over this window, click the right mouse button and select the appropriate option.  

If you choose Move/Resize a red zoom-frame appears around the respective window. 
You move and/or resize this zoom frame by moving the mouse over a corner, edge or 
the interior, press and hold down the left mouse button and move the mouse. To accept 
the new size and position for the window double-click the left mouse button or press 
ENTER. To abort the Move/Resize operation leaving the window position unchanged 
press ESC. Note that overlay windows (see below) cannot be moved or resized. 

You create new windows by moving the mouse over one of the existing windows, right-
clicking and choosing option Create New Window or Create Overlay Window. In both 
cases the initial properties of the new window are derived from the existing one. If you 
use Create New Window, the new window will be placed in the middle of the ODV 
graphics canvas and you have to position and resize it using the Move/Resize option de-
scribed above. If you use Create Overlay Window, some properties required for overlay 
windows will be set automatically, and the new window will be properly aligned with 
the existing one. You modify the properties of an existing or new window by right-click-
ing on this window and choosing option Properties. To select new variables on X-, Y- 
and Z-axis of the window, select the Data page of the Properties dialog and choose ap-
propriate variables in the combo-boxes of the different axes. Note that by default varia-
ble values increase to the right and upwards. If you want to reverse the direction (e.g., 
depth in depth profiles) check the respective Reverse range box. Press OK to accept the 
new properties. Note that the properties of the map or any data window may also be 
changed any time after leaving Window Layout mode (see above).  

In addition to manual arrangement of map and data windows, you may also implement 
a predefined window layout by choosing from a wide range of layout templates (choose 
Layout Templates from the View menu or the canvas or window layout popup menus 
and select one of the templates). 

Right-click the mouse and choose Accept to leave Window Layout mode and accept the 
new window layout. Choose Cancel if you want to discard the modification and keep the 
original window layout.   

10.5 Graphics Output 

GIF, PNG, JPG and Tiff Files 

You can save the entire canvas, individual data windows or the map in gif, png, jpg or 
tiff files by choosing Save Canvas As from the canvas popup menu, Save Plot As or Save 
Map As from a data window or map popup menu and selecting the respective file type. 
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These options can also be invoked by shortcut key-strokes:  (1) pressing Ctrl-S while 
the mouse is over the canvas area saves the ODV graphics canvas while (2) pressing 
Ctrl-S with the mouse over the map or a data window will save the respective data plot. 
ODV will present a file save dialog that lets you choose the appropriate output file type 
(GIF (*.gif), PNG (*.png), JPG (*.jpg) or TIFF (*.tif)). Note that the default output filename 
is derived from the current view name. If required, you can choose any other name or 
destination. ODV then lets you define the resolution of the output image. Note that the 
maximum achievable resolution is limited by the available memory on your system. 

PostScript Files 

To produce Encapsulated PostScript .eps files for the entire screen or any individual 
data window or the map, right-click on the canvas or the respective data window or 
map and choose Save Canvas As, Save Plot As or Save Map As (alternatively, you can also 
press Ctrl-S while the mouse is over the canvas, data window or map), choose PostScript 
(*.eps) for the file type and specify the name and destination of the output file. ODV then 
presents the PostScript Settings dialog that lets you specify the orientation and size of 
the PostScript output. The resulting Encapsulated PostScript files can be printed by 
sending it to a PostScript printer, or it can be imported into LaTex or Word documents, 
or may be opened with external graphics software, such as Adobe Illustrator or Corel 
Draw, for editing and processing. If you intend to include the ODV .eps output files in 
other documents, make sure to uncheck the Show Collection Info box on the PostScript 
Settings dialog. 

10.6 Data Statistics 

You can obtain statistics information for the data shown in a given data window by 
right-clicking on the window and choosing Extras > Statistics or by pressing F4 while 
the mouse is over the window. The window’s statistics page will appear (see Figure 10-
7) and show mean, standard deviation, number of data points as well as minimum and 
maximum values for the X, Y, and (if present) Z variables of the respective window. 
Note that mean, standard deviation, and number of data points are based on the cur-
rently visible data only, while minimum and maximum are using all available data.  

You obtain distribution histograms of the X, Y, and (if present) Z data by pressing on the 
respective Histogram button. An example histogram is shown below. Note that the his-
togram is based on the currently visible data only. You obtain plots of the data distribu-
tion in X/Y space by pressing the X/Y Distribution button. All histogram and distribution 
plots may be saved in GIF, PNG, JPG, TIFF or Encapsulated PostScript files. 
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Figure 10-7: The statistics dialog box (right) for a SCATTER data window showing oxygen data from the 
northeast Pacific versus depth (left). 

 

The Gridding Misfits button will be enabled if the parent data window currently uses 
Weighted-average or DIVA gridding. Pressing this button will produce a plot showing 
the estimate-data differences of the current gridding procedure (see Figure 10-9).  

ODV will also allow you to fit three types of curves through the data: (1) least-squares 
lines, (2) piece-wise least-squares lines, and (3) moving average curves. You may 
choose one of these curve types from the top combo-box of the Fitted Curves group. 
Then choose an orientation for the fit (in the example of Figure 10-7 we want oxygen as 
a function of depth, e.g., X ( Y )). For curve types (2) and (3) you may also specify the 
number of points at which the curve will be evaluated (default 30; choose a larger value 
for smoother curves). For moving average curves (type  3) you may specify an averag-
ing length scale (in per mille of the axis range of the variable between parenthesis, e.g. 
Y=Depth in Figure 10-7). Large averaging length scales will result in smooth, small val-
ues will preserve more of the structure in the data. Press Construct Curve to have the 
curve calculated and the results displayed in the box to the right. These results may be 
copied to the clipboard (by pressing Clipboard Copy) and then pasted into other docu-
ments or applications for external use. 

You may also add the constructed curve to the data window by pressing Show Curve. 
Note that the curve is added as a polyline graphics objects, which means that you can 
edit or delete the object at any time using the normal graphics object’s procedures. 
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Figure 10-8: The data distribution histogram for oxygen (left) and the oxygen/depth data distribution 
(right) for the data from Figure 10-7.  

 
 

 
Figure 10-9: Example plot showing the estimate-data differences at the data locations. 

 

10.7 Isopycnals 

You may add isopycnals to T/S data plots by choosing the Extras > Isopycnals option of 
the data plot’s popup menu. On the Isopycnal Properties dialog specify the reference 
pressure of the isopycnals as well as their graphical properties. Press the Switch On but-
ton to enable isopycnals. To switch off the isopycnals choose Extras > Isopycnals and 
press Switch Off. 

The Extras > Isopycnals option is only enabled for T/S plots of the following two kinds: 
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1. A basic salinity variable that has been identified as Practical Salinity key-variable 
is on the X axis and an ODV derived variable Potential Temperature is on Y. 

2. The derived variable Absolute Salinity is on the X-axis and the derived variable 
Conservative Temperature  is on Y. 

The Extras > Isopycnals option is disabled and isopycnal contours are unavailable for all 
other cases. 

10.8 Finding Outliers using Field Checks 

SECTION or SCATTER data windows using Weighted-average or DIVA gridding allow 
identification and editing of Z-variable data outliers using the Extras > Find Outliers 
(Field Check) option.  

After specifying name and location of the outlier output file ODV will start estimating Z-
values at the data locations (field values) and will calculate estimate-minus-data differ-
ences (misfits) as well as the misfit standard deviation. Data values deviating from the 
field values by more than 1.5 times the misfit standard deviation are considered outli-
ers and flagged. This procedure is repeated up to three times, each time ignoring the 
previously flagged data points. The list of identified outliers may then be viewed and 
the associated Z-variable values may be inspected and edited.   

Note that this method for identifying outliers works best if the percentage of dubious 
data is relatively small and the chosen gridding length scales of the data window corre-
spond to the typical length scales found in the data. Care should be taken in regions of 
sharp gradients that may not be correctly represented in the gridded field. In such areas 
a large misfit value may reflect a poor estimated field value rather than a problem with 
the data value itself. For efficiency reasons Weighted-average gridding is used for the 
field check, even if the data window itself uses DIVA gridding. 
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11 Graphics Objects 

You can add text annotations, symbols, lines and other geometric objects to the canvas, 
the map or any data window. Geographic feature data provided in ESRI shapefiles may 
be added to the station map. The following graphics objects are supported: (1) text an-
notations, (2) straight lines, (3) rectangles and squares, (4) ellipses and circles, (5) pol-
ylines (straight-line segments or Bezier smoothed), (6) filled polygons (straight-line 
segments or Bezier smoothed), (7) symbols, (8) symbol sets, (9) legends and (10) vari-
ous object types from files. Detailed descriptions of these objects follow below. 

A graphics object is owned by the canvas, the map or a specific data window on which 
the object was created. All graphics objects of the canvas, the map or a data window are 
drawn, whenever the respective parent window is drawn. The coordinates of a graphics 
object are either specified in the coordinate system of the owner window or of the can-
vas. Canvas coordinates are in cm from the lower left corner to the right or upwards.  

The initial ownership and coordinate system of an object are derived from the window, 
from which creation was initiated (see below). Like most other properties of a graphics 
object, ownership and the coordinate system may be edited and modified at any time. 
By default, graphics objects are clipped to the parent window. If you create objects out-
side the window’s viewport make sure to uncheck the Clip to window box on the object’s 
Properties dialog (see below).  

Graphics objects belong to the current view and are saved in view files. 

Creation 

Except for legends, which are created automatically, you create and add any other 
graphics object by choosing Extras > Add Graphics Object > ... (”...” representing the de-
sired object type) from the map or data window popup menus or by choosing Add 
Graphics Object > ... from the canvas popup menu. After initial creation, dialog boxes ap-
pear that let you define various properties of the object. These properties may later be 
changed again at any time (see Edit below). A graphics object is owned by the window 
(or canvas) from which the creation was initiated, and the coordinates of the graphics 
object are in the respective window coordinate system. As a consequence, all objects of 
a window follow automatically when the respective window is moved or resized. 

Graphics objects can also be created as copies of existing objects via the Copy Object op-
tion of the graphics object context menu, or the Copy button of the graphics objects 
management dialog (see below). You may also import graphics objects from ODV .gob 
files, previously created by exporting existing graphics objects. Other window objects, 
such as bathymetry polygons in section plots, contour lines in data windows showing 
gridded field, colored data dots in data windows showing original data, or the station 
selection polygons in the station map, may also be exported to .gob files. All these ex-
ported objects may later be imported and added as graphics objects to the canvas, the 
map or any data window. 
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Edit and Delete 

The properties of a given object can be modified by moving the mouse over it (for sym-
bol sets move the mouse over one of the symbols), clicking the right mouse button and 
choosing Properties from the popup menu. Some graphics objects, such as axis labels, 
unit arrow boxes or legends, are created and deleted automatically (automatic graphics 
objects). These objects may not be edited or deleted manually (automatic axis titles are 
switched on/off on the General page of the window’s Properties dialog). 

Dialog boxes (different for the different objects) appear and let you change properties 
easily and quickly. Graphics objects may be clipped to their parent window (check the 
Clip to window box), and they may be drawn before the data of the window are drawn 
(check the Pre-data plot box).You delete an object by moving the mouse over it, clicking 
the right mouse button and choosing Delete Object. 

Dragging 

If the attribute Allow dragging of a graphics object is set, the object can be re-positioned 
by simply dragging it to a different location. To drag an object, move the mouse over it, 
click and hold down the left mouse button and move the mouse. By default, dragging is 
switched on initially for all graphics objects except symbol sets, which are linked to ac-
tual data values. You can change the Allow dragging  attribute at any time using the ob-
ject’s Properties dialog (see above). 

Managing Graphics Objects 

You can manage the graphics objects of the canvas, map or any data window using the 
respective Extras > Manage Graphics Objects option. This includes changing the object’s 
properties (Edit), exporting, copying, deleting or changing the order in which the ob-
jects are drawn. 

11.1 Annotations 

You can add annotations by choosing (Extras > )Add Graphics Object > Annotation from 
the canvas, map or data window popup menus. A cross-hair cursor will appear, which 
you should move to the location where the annotation is to appear and then click the 
left mouse button. Note that the window from which the creation was initiated will own 
the respective object. When adding (or editing) annotations you may set the position, 
orientation (degrees, counter-clockwise), font size (pt), color and alignment parameter 
of the annotation text. Annotations can have a frame, and the annotation rectangle can 
be filled before drawing the text. You can choose different colors for all these items. In 
ODV annotations, you can use various formatting control sequences as well as functions 
for auto-text substitution.  

Like all graphics objects, you can drag an annotation to a different position by moving 
the mouse cursor over it, pressing and holding down the left mouse button and moving 
the mouse. You can edit an annotation by moving the mouse over it, clicking the right 
mouse button and choosing Properties from the popup menu. To delete an annotation 
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(all annotations) choose Delete Object (Delete All Objects) from its popup menu. 

Note that the axis labels of the data plot windows are implemented as automatic anno-
tations. They are created automatically when the plot window is drawn and they are de-
leted when the respective data plot window is deleted. You may not edit or delete auto-
matic axis titles. To change an axis label permanently, switch off automatic axis titles 
(see General page of the window’s Properties dialog) and create horizontally and verti-
cally oriented annotations manually by choosing Extras > Add Graphics Object > Annota-
tion from the canvas popup menu.  

11.2 Lines, Polylines and Polygons 

You add straight lines, polylines and polygons to the map, data windows or the canvas 
by choosing (Extras > )Add Graphics Object > Line, ... > Polyline or ... > Polygon from the 
map, data window or canvas popup menus. In all three cases the cursor changes to a 
cross hair, and you should proceed by specifying the nodes of the object. For a Line 
graphics object you must define starting- and endpoint: move the cross-hair to the start 
of the line and click the left mouse button, then move to the end-point and click the left 
button again. For Polyline or Polygon graphics objects you may define up 1000 nodes. 
Note that polygons are closed automatically by ODV. If you want to delete a point, move 
the cross hair close to it and click the right mouse button. You end the definition of poly-
gon or polyline points by pressing ENTER. 

Once you have specified the nodes of the line, polyline or polygon, ODV presents a prop-
erties dialog that lets you define color, width and type of the (poly)line and the fill color 
of the polygon (ignored for Line and Polyline; choose (none) as fill color to avoid filling 
of the polygon). Polylines and polygons may be smoothed by checking the Bezier 
smoothing box. 

Lines, polylines and polygons can have special symbols such as arrow heads, filled or 
open dots and bars at their start and/or end points. You select such symbols and specify 
their size via the property dialog.  

11.3 Rectangles and Ellipses 

You add rectangles (squares) and ellipses (circles) to the map, data windows or the can-
vas by choosing (Extras > )Add Graphics Object > Rectangle, or ... > Ellipse from the map, 
data window or canvas popup menus. A red zoom rectangle will appear that represents 
the bounding box of the new rectangle or ellipse. The zoom rectangle can be moved and 
resized, then press ENTER to accept a setting or ESC to abort creation of the object. A di-
alog box appears that lets you define properties of the rectangle or ellipse (for details 
see Lines and Polygons). 

11.4 Symbols 

You add symbols (dots, squares, diamonds, triangles, inverted triangles, stars, crosses, 
pluses) to the map, data windows or the canvas by choosing (Extras > )Add Graphics Ob-
ject > Symbol from the map, data window or canvas popup menus. A cross-hair cursor 
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will appear, and you should move it to the location where the symbol should appear. 
Then click the left mouse button. The Symbol Properties dialog box appears and lets you 
set various symbol properties.  

11.5 Symbol Sets and Legends 

You can highlight a subset of the data points in a data window or a subset of stations in 
the map by assigning a symbol to the selected data points (symbol set). To create a sym-
bol set for a data window or the map, move the mouse over this window and choose Ex-
tras > Add Graphics Object > Symbol Set. The Symbol Set Selection dialog appears and lets 
you select the subset of data points (select one or more cruises in the Cruises list, sta-
tions in the Stations list, and/or individual samples in the Samples list). Then press the 
<< button to add the selected data points to the Selected list. Press OK once all desired 
points are selected. The Symbol Set Properties dialog appears, which lets you define the 
symbol and line characteristics. A symbol set can have a descriptive text (legend), which 
will automatically be added to the legends of the respective window (check the Add to 
legends box). Unlike other graphics objects, symbol sets cannot be dragged, because of 
their association with the selected data points. You can change all symbol set properties 
at any time by moving the mouse over any one of its symbols, clicking the right mouse 
button and choosing Properties. 

 

 
Figure 11-1: Sample SCATTER plot using symbol sets and legends to highlight the data of a particular station  

 

If a data window or the map contains symbol sets, and the Add to legends option is 
switched on, a legend box containing the symbol and legend text of all symbol sets for 
this window appears automatically. Legend sets can be dragged to different locations 
and their properties (the size of the legend box is modified by changing the font size for 
the legend text) can be modified at any time (move mouse over legend set, click right 
mouse button and choose Properties). 
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11.6 Graphics Objects from Files 

ODV supports the import of bathymetry, coastline or topography contours from .cdt 
files, graphics objects from .gob files, and of geographical features from ESRI .shp shape-
files. You add graphics objects from these files to the map, data windows or canvas by 
choosing (Extras > )Add Graphics Object from File > [type] from the map, data window or 
canvas popup menus. ODV currently supports the following types: (1) Graphics Object 
File (*.gob), (2) CDT File (*.cdt), and (3) Shapefile (*.shp). In all cases a file open dialog 
will appear that lets you choose a file from which the graphics object(s) will be loaded.  
cdt and shp files can only be added to maps. 

When opening a shapefile the user is informed about the kind and number of objects in 
the file. ODV then allows specification of graphics properties, such as color, line type or 
width. These properties are applied to all objects in the shapefile, but can be changed 
later using the Manage Graphic Objects option (see below). 

If the shapefile has an accompanying .prj projection file, ODV will use the projection in-
formation and convert geographical coordinates to WGS84, if necessary. If the .prj pro-
jection file is missing, ODV assumes that all geographic coordinates are WGS84 and are 
within the -180 to +360 and -90 to +90 degree ranges. ODV currently supports shapefile 
points, multi points, lines, multi lines, polygons, and multi polygons. For polygons only 
the outer ring is drawn. Note that the drawing of very large shapefiles may be slow. 

11.7 Managing Graphics Objects 

You can obtain full lists of all graphics objects of the canvas, the map or any data win-
dow by right-clicking on the respective area and choosing Manage Graphics Objects or 
Extras > Manage Graphics Objects. 
 

 
Figure 11-2: The Graphics Objects dialog. 

 

The Graphics Objects dialog (Figure 11-2) appears, letting you select individual objects, 
sub-groups of objects, or the entire list of objects. If you have selected one or more ob-
jects you may delete all selected objects by pressing Delete or you may export all se-
lected objects to a .gob or .shp file for subsequent re-use by pressing Export. If you have 
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selected just one object you may also copy the object (by pressing Copy) or change the 
properties of the object (by pressing Edit). You may also change the drawing order and 
bring the object closer to the foreground (Foreground or Up) or background (Back-
ground or Down). 

If you are exporting multiple objects into a shapefile please note that ODV will create in-
dividual files for every object type in the selected set. For all created shapefiles except 
the first one, ODV will automatically append to the filename strings describing the ob-
ject type (e.g., _points, _polygons or _lines). Note that if at least one of the exported ob-
jects is a symbol set, all symbols and symbol sets are written to a shapefile with mul-
tipoint geometry. If at least one of the exported objects is a polygon, all lines and poly-
gons are written to the shapefile as polygons. 

The current shapefile export implementation has some limitations:  (a) CDT file objects 
and annotations cannot be exported to shapefiles yet; (b) no projection information .prj 
file is written (all geographic coordinates are assumed WGS84); (c) except for symbol 
sets no attribute .dbf file is written (for symbol sets the legend string is written to at-
tribute Name); (d) all objects are written to the first and only layer, multiple layers are 
not supported. 
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12 Working with Collections 

12.1 Copying, Packaging, Renaming and Deleting Collections 

You can create a copy of the currently open collection using Collection > Copy, you re-
name (and possibly move) the currently open collection using Collection > Move/Re-
name, and you delete the currently open collection using Collection > Delete. If you are 
deleting old ODVGENERIC collections view and section files of the collection may have 
to be deleted manually.  

Use option Collection > Create Snapshot to package a collection in a zip file. This is useful 
for making back-up copies of a collection or when sharing the collection with a friend. 
Packaging leaves the source collection unchanged. 

12.2 Sorting and Condensing 

The station search and selection algorithms of ODV work most efficiently if the stations 
in a collection are ordered by cruises. Therefore, it is recommended that you sort and 
condense your collections after importing, replacing, merging or deleting large numbers 
of stations. You invoke the sort and condense procedure by choosing Collection > Sort 
and Condense.  

12.3 Deleting Stations 

You can delete the currently selected stations from the collection by choosing Collection 
> Delete Station Subset from ODV’s main menu. To delete the current station only, 
choose Collection > Delete Current Station. Note that the data space of the deleted sta-
tions in the collection disk files is not freed until you sort and condense the collection. 

12.4 Changing Collection Properties 

IMPORTANT NOTE: Please produce a backup copy of the current collection by using the 
Collection > Create Snapshot option before applying any of the actions described in this 
section. 
ODVGENERIC and ODVCF5 collections can be converted into the new ODVCF6 collection 
format using the Collection > Properties > Convert to ODVCF6 option. 

The properties of an open ODVCF6 collection may be modified using the Collection > 
Properties options. There are three sub-options, General, Meta Variables, and Data Vari-
ables. With the General option you may define the field of the data (GeneralField, Ocean, 
Atmosphere, Land, IceSheet, SeaIce, Sediment), the type of the data (GeneralType, Pro-
files, Trajectories, TimeSeries) and the primary variable used to sort the data. The data 
field and type entries are not used presently. Future ODV versions, however, may offer 
different sets of derived variables depending on the data field, or may apply different 
default plotting styles depending on the data type. 

The Meta Variables and Data Variables options allow modifications of the metadata and 
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data variable sets. This includes adding new variables, deleting existing ones, re-order-
ing the variables or changing the properties of the variables, such as, data type, byte 
length as well as the quality flag schema used for the variable’s quality flags. Note that 
the first twelve meta-variables are mandatory and that they may not be deleted or re-
ordered. 

Some modifications, such as changes of the collection’s data field, data type, or the la-
bels, units, and number of decimal places of variables, are simple changes that can be 
dealt with by recording the new entries in the collection’s settings or variables files. 
Adding or deleting variables, changing the collection’s primary variable or altering the 
data type or quality flag schema of a variable are critical changes that require a com-
plete re-writing of the metadata and data files of a collection.  

Please note that if collection re-writing occurs, the new collection will always use the 
new ODVCF6 collection format (.odv collection), even if the original collection was 
ODVCF5 or ODVGENERIC. The new ODVCF6 collection format requires ODV 4.6.0 or 
higher. 

12.5 Key Variable Associations 

Many derived variables require identification of the input variable(s) needed for the 
calculation of the derived variable. This identification of key variables is done during 
the first definition of the derived variable, and the selected variables are remembered in 
the collection’s settings file. If the derived variable is requested again at a later time, the 
stored key variable information is used, and the user is not prompted again. 

You can inspect and modify the current key variable associations using Collection > 
Identify Key Variables. The Identify Key Variables dialog will appear, showing lists of key 
variables on the left and data variables on the right. Associated items are marked with 
an asterisk (*). You can click on such items in any of the lists and ODV will show the as-
sociated item in the other list. You may break the association by pressing Undo; press-
ing Undo All will break all association and leave all key variables undefined. You estab-
lish an association by selecting the relevant items in the two lists and pressing Associ-
ate. Items in the key variable list that are not included in the list of data variables may 
be marked as not available by pressing the Not Available button. Such items are marked 
in the key variable list by a minus sign (-). 

Important Note: Errors in the key variable associations can lead to wrong and meaning-
less values of affected derived variables. For instance, imagine the key variable Practical 
Salinity [psu] was erroneously associated to data variable Oxygen [µmol kg-1]. This 
would cause all derived variables requiring Practical Salinity [psu] as input variable 
(e.g., potential temperature, potential density, etc.) to use oxygen values instead of sa-
linities and return wrong values. Verifying the validity of key variable associations us-
ing option Collection > Identify Key Variables should be the first check, whenever you re-
ceive doubtful derived variable values. 
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Figure 12-1: The Identify Key Variables dialog. 

 

12.6 Good Coverage Criteria 

Some ODV operations, such as the interpolation to standard depths or the calculation of 
various derived variables require that there are sufficient input data available. Calcula-
tion of dynamic height, for instance, requires full profiles of temperature and salinity 
data, and gaps between the data points should not be too large. Using Collection > Good 
Coverage Criteria you may specify the criteria that must be satisfied to consider the data 
of a given variable sufficient. These criteria are applied to all variables required for a 
specific operation. If one or more required variables fail the test, the respective opera-
tion is not performed. 

Note that the tolerable gap specification is the minimum of two terms, one dependent 
on the primary variable value Z (depth or pressure in case of profile data collections) 
and a second constant term. Make sure to enter large values in the first fields on both 
lines if you want to allow large data gaps. 

12.7 Browsing Collection Information 

Collection Info  

Every collection may have a free-text description of the data in the collection. This in-
formation is stored in the collection’s info file. You may view or edit the info file of the 
currently open collection by choosing Collection > Browse Info File.  

Cruise Inventory  

You can view the cruise inventory table of the currently open collection by choosing 
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Collection > Browse Inventory. The following information is provided for every cruise: 
cruise ID, number of stations, number of samples, station IDs, longitude and latitude 
ranges, time period, and data availability indicators for each of the basic variables. Data 
availability indicators are single digit numbers, with, for instance, 9 indicating that 
more than 90 % of the samples containing data for the particular variable. There is a '.' 
separator every five variables and a '|' separator every ten variables. A '-' indicates that 
there are no data for the given variable in this cruise. A separate window shows lists of 
variables containing data for given cruises. 

Collection Logfile 

All actions that modify the contents of a collection (creation, import of data, station de-
letions, etc.) are logged in the collection’s logfile.  Editing of metadata or data is logged 
in the station’s history (ODVCF6) or the logfile of the collection (ODVCF5 and 
ODVGENERIC). The station’s history can be viewed by resting the mouse over the Sta-
tion ID heading of the Current Station Window. The collection’s logfile can be viewed us-
ing the Collection > Browse Log File option. 

12.8 Properties of Variables 

You may modify properties of meta- and data variables by right-clicking on the current 
station or current sample list windows and choosing the Properties option. From the list 
of variables choose the one you want to modify and press Edit. On the properties dialog 
of the selected variable you may edit the strings for variable label, units and comment. 
You may also modify the number of digits used to show values in the current station or 
sample windows.  

12.9 Editing Data 

You can edit the metadata and data values of the current station as well as their associ-
ated quality flags and save the modified values in the collection data files on disk.  

Station Metadata 

To modify the metadata of the current station, right-click on the current station list win-
dow and choose Edit > Metadata. The Edit Station Metadata dialog appears showing the 
metadata of the current station. You can edit an individual entry by double-clicking into 
the respective value field. You modify a particular quality flag by clicking on its field and 
then clicking the Change Quality Flag button and selecting the new quality flag. 

Press OK on the Edit Station Metadata dialog to write the new metadata to the collection 
files. Press Cancel to discard your modifications and leave the metadata of the current 
station unchanged. If OK is pressed and the edited variable has value type 
INDEXED_TEXT you have the option to modify the current instance only or all occur-
rences of the previous string. Choosing Modify all instances is a convenient way of cor-
recting mistakes in texts or to modify items such as cruise labels globally in the collec-
tion with just one edit operation. 
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Note that edit operations are logged in the station’s history (ODVCF6) or the logfile of 
the collection (ODVCF5 and ODVGENERIC). The station’s history can be viewed by rest-
ing the mouse over the Station ID heading of the Current Station Window. The collec-
tion’s logfile can be viewed using the Collection > Browse Log File option. 

 

 
Figure 12-2: The Edit Station Metadata dialog. 

 

Station Data 

To modify the data of a given variable of the current station right-click on the particular 
variable in the current sample list window and select Edit Data. The Edit Data dialog ap-
pears showing the data value and quality flags of the variable for all samples of the cur-
rent station. You may change data values and quality flags for the current sample (initial 
selection) or for a user defined sample subset. You define a sample subset in the data 
list by pressing the standard extended selection keys Ctrl and Shft while left-clicking the 
mouse. Click on Select All to select all samples, or press Invert Selection to invert the cur-
rent selection.  

If you have selected a single data item you can change its value by clicking on the 
Change Value and entering a new numerical value. If you have selected more than one 
sample in the data list, the Change Value button is deactivated. Pressing the Delete 
Value(s) button removes the data values of all selected samples. You should use this 
button with great care, as the original data values will be lost permanently.  
WARNING: Please note that editing values of the primary variable (e.g., Depth, Pressure, 
Time, etc.) via the Change Value option is dangerous and can have unexpected side ef-
fects. Specifically, value changes of the primary variable may affect the order of the sam-
ples within the current station, and the sample being edited may move up or down in 
the profile (or time series) causing its sample ID to change after editing. Please be 
aware that if this happens the Current Sample Window after editing will no longer show 



Version 5.1.0 

 130 

the edited sample, but the sample that takes the slot of the edited sample after re-sort-
ing. 

Editing and deleting sample values should only be done when absolutely necessary. 
Usually, you should leave the actual data value unchanged and modify the data quality 
flags of the selected samples instead. This is done by clicking the Change Quality Flag(s) 
button and selecting a new quality flag from the list of available flags. Pressing OK saves 
the changes to disk, pressing Cancel aborts the edit session and leaves the station data 
in their original form. 

Note that you can filter data using their quality flag values. Also note that edit opera-
tions are logged in the station’s history (ODVCF6) or the logfile of the collection 
(ODVCF5 and ODVGENERIC). The station’s history can be viewed by resting the mouse 
over the Station ID heading of the Current Station Window. The collection’s logfile can 
be viewed using the Collection > Browse Log File option. 

To modify the data of a given sample of the current station right-click on the current 
sample list window and select Edit Sample Data. The Edit Sample Data dialog appears 
showing the data values and quality flags of all data variables for the current sample. 
You change the data value or quality flag of a particular variable by clicking on that vari-
able and then on the Change Value, Delete Value, or Change Quality Flag buttons.  

You may delete the current sample (including all data values for all data variables) by 
right-clicking on the sample list window and choosing option Delete Current Sample. Al-
ternatively, you may add a new sample by right-clicking on the sample list window and 
choosing option Add New Sample. Enter the primary variable value of the new sample 
and press OK. 

 

 
Figure 12-3: The Edit Data dialog (all sample values for a given variable). 
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Figure 12-4: The Edit Sample Data dialog (all variable values for a given sample). 

 

Quality Flag Values 

In addition to the methods described above, you may also modify the quality flag values 
of the data of a given variable by right-clicking on the variable in the Current Sample 
window and using one of the options of the Assign Quality Flags submenu: (1) Current 
Sample, (2) All Samples of Current Station, (3) All Samples in Window n, (4) All Samples of 
Valid Stations, and (5) All Samples in Collection.  

The set of samples to which the quality flag changes are applied depends on the option 
you choose and ranges from the current sample only (option 1) to all samples of all sta-
tions in the collection (5). Option 3 lets you assign a new quality flag to the data of the 
variable currently shown in data window n, while options 4 and 5 apply the new QF 
value to all samples of all stations currently shown in the map (valid stations) or to all 
samples of all stations in the collection. Options 3 to 5 modify a potentially very large 
set of samples and need to be confirmed by the user before any changes are made. 

After choosing one of the submenu options, ODV presents the Assign Quality Flags dia-
log (Figure 12-5). On this dialog you select the new quality flag value to be assigned and 
you specify whether this flag should be assigned to all samples irrespective of their cur-
rent value, or to samples equal (or not equal) to a specific QF value only. Note that this 
operation is logged in the station’s history (ODVCF6) or the logfile of the collection 
(ODVCF5 and ODVGENERIC). The station’s history can be viewed by resting the mouse 
over the Station ID heading of the Current Station Window. The history records of all 
stations currently shown in the map can be exported to a text file using the Export > Sta-
tion History option. The collection’s logfile can be viewed using the Collection > Browse 
Log File option. 
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Figure 12-5: The Assign Quality Flags dialog. 

 

12.10 Password Protection 
ODVCF6 collections can be password protected using option Collection > Properties > 
Change Password. On the Change Collection Password dialog enter the current password 
(leave empty if collection is currently not password protected) then provide the new pass-
word twice. To remove password protection of a currently protected collection enter the old 
password and leave the New Password and New Password (repeated) empty. 
 
When opening a password protected collection ODV prompts the user for the password. Ac-
cess is denied if the provided password is incorrect. Make sure to keep collection passwords 
in a safe place. A lost password leaves the data collection inaccessible. 
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13 Working with NetCDF Files 

NetCDF is a set of software libraries and self-describing, machine-independent data for-
mats that support the creation, access, and sharing of array-oriented scientific data. 
NetCDF is widely used in climate research and other fields of geo-sciences. Many im-
portant datasets and model output files are distributed in netCDF format. 

NetCDF files have the following properties: 

• Self-Describing. A netCDF file includes information about the data it contains.  
• Architecture-independent. A netCDF file is represented in a form that can be ac-

cessed by computers with different ways of storing integers, characters, and 
floating-point numbers.  

• Direct-access. A small subset of a large dataset may be accessed efficiently, with-
out first reading through all the preceding data.  

• Appendable. Data can be appended to a netCDF dataset along one dimension 
without copying the dataset or redefining its structure. The structure of a netCDF 
dataset can be changed, though this sometimes causes the dataset to be copied.  

• Sharable. One writer and multiple readers may simultaneously access the same 
netCDF file.  

The netCDF data model is very general, and the structure and contents of netCDF files 
can vary considerably. In order to facilitate and promote the interchange and sharing of 
netCDF datasets, a number of conventions have been defined. Two of these conventions 
(CF and COARDS; see http://www.unidata.ucar.edu/packages/netcdf/conventions.html 
for detailed specifications) are widely used by climate researchers and modelers, and 
many datasets are available as CF/COARDS compliant netCDF files. Examples of such 
datasets can be downloaded from http://www.cdc.noaa.gov/PublicData/, http://fer-
ret.wrc.noaa.gov/, http://ingrid.ldeo.columbia.edu/, or 
http://www.epic.noaa.gov/epic/ewb/. For more information on netCDF, see the netCDF 
web page http://www.unidata.ucar.edu/packages/netcdf/. 

13.1 NetCDF Support 

ODV can open a wide range of netCDF files, including but not limited to CF/COARDS 
compliant files. These files may reside on the local file system or on a remote OPeNDAP 
server. Once a netCDF file has been successfully opened, ODV presents the data in the 
file to the user in the same way as if the data were stored in an ODV data collection. ODV 
will produce a clickable station map and supports most types of graphics output as for 
collections. Options requiring write permission are not available and are grayed out. 
ODV treats netCDF files as read-only and will never modify these files. Note that netCDF 
files are platform independent and the same file can be used on all supported platforms. 

The data of a given variable S in a netCDF file are stored as single- or multi-dimensional 
array. The set of dimensions of a space- and time-varying variable include the three 
space coordinates X, Y, and Z as well as a time coordinate T. It is a convention to order 

http://www.unidata.ucar.edu/packages/netcdf/conventions.html
http://www.cdc.noaa.gov/PublicData/
http://ferret.wrc.noaa.gov/
http://ferret.wrc.noaa.gov/
http://ingrid.ldeo.columbia.edu/
http://www.epic.noaa.gov/epic/ewb/
http://www.unidata.ucar.edu/packages/netcdf/
http://opendap.org/
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these dimensions as S(T,Z,Y,X), e.g., X is the fastest and T the slowest changing dimen-
sion. For geo-scientific data X and Y represent longitude and latitude, while Z is a verti-
cal coordinate, such as depth or pressure in the ocean, height in the atmosphere or 
depth in a sediment or ice-core. It is possible that a netCDF file contains more than one 
X, Y, Z, T coordinate system. For instance, it is quite common for model output netCDF 
files to contain data defined at the centers of the model grid (e.g., tracer concentrations) 
as well as the velocity data defined on the grid interfaces. ODV can handle only one X, Y, 
Z, T coordinate system at a time, and the corresponding dimensions must be selected 
during netCDF setup (see below).  

When opening a netCDF file the main challenges for ODV users are to correctly identify 
the space and time dimensions, to detect situations with multiple coordinate systems 
and to choose a proper primary variable. Choosing, for instance, Z as the primary varia-
ble will turn the netCDF file into a vertical profile database with nT stations at every 
(X,Y) position. The total number of stations in this case is  nT * nY * nX, where nK  is the 
length of dimension K. If, alternatively, T is chosen as primary variable the data in the 
netCDF file are interpreted as time-series. In this case there will be one station (time-
series) at every (X,Y,Z) point, and the total number of stations is nZ * nY * nX. 

To provide a maximum level of user control, ODV presents a netCDF setup wizard, 
when a netCDF file is opened for the first time. The various controls on this four-page 
dialog are initialized with automatically determined settings, and in many cases the 
user only needs to confirm the settings by pressing Next on Finish. These settings are re-
membered by ODV, and the setup wizard will not appear when the file is opened again. 
You can force ODV to show the setup wizard in the following ways: (1) open the netCDF 
file (for instance, via the File > Open option) and open the same netCDF file again (for 
instance, via the File > Recent Files option) or (2) use Collection > Properties > NetCDF 
Setup while the netCDF file is open. 

You open a netCDF file on the local file system (extension must be either .nc or .cdf) by 
dropping the file on the ODV icon or window or by choosing File > Open and selecting 
the file in the standard file selection dialog. Once a netCDF file has been opened before 
you can also use the File > Recent Files option to access the file. Additionally, you can 
start ODV from the command line and specify a netCDF file name as a command line ar-
gument.  

You open a netCDF file on a remote OPeNDAP server by using option File > Open Remote 
and entering the URL to the netCDF file (example: http://mother-
lode.ucar.edu:8080/thredds/dodsC/testdods/coads_climatology.nc). URLs to public cli-
mate data resources in netCDF format can be found on the Internet, for instance at 
http://www.esrl.noaa.gov/psd/thredds/catalog.  

ODV opens the netCDF file and retrieves information about dimensions and variables 
contained in the file. ODV will also retrieve all global attributes and all attributes of the 
variables and will write this information to an ASCII file in a format similar to what 
ncdump –h < file> produces. This file can be viewed by clicking the View NetCDF Header 
button on the first page of the setup wizard (see below) or at any time using the Collec-
tion > Browse Info File option. 

http://opendap.org/
http://www.esrl.noaa.gov/psd/thredds/catalog
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13.2 NetCDF Setup 

Once the netCDF file has been analyzed ODV presents a four page wizard to gather nec-
essary information. 

Selecting netCDF dimensions 

On the first page of the setup wizard (Figure 13-1) ODV shows the list of dimensions 
contained in the file. Initially all the dimensions are selected, except in cases of more 
than one X, Y, Z, T coordinate system, when only one of these systems is selected. For a 
given selection of dimensions, the set of netCDF variables defined on these dimensions 
is shown in the Corresponding netCDF variables list. Other variables in the netCDF file 
that depend on dimensions not selected in the NetCDF dimensions list are not shown as 
Corresponding netCDF variables. These variables will remain unavailable unless you se-
lect the corresponding dimensions.  

Using extended selection techniques (hold down the Ctrl or Shft keys while clicking the 
left mouse button) select all the dimensions that should be used. If multiple coordinates 
are provided for the common dimensions X (Longitude), Y (Latitude), Z (Depth/Height), 
and T (Time), make sure to select only one for each direction.  

To view the header information of the netCDF file (similar to a ncdump –h call) press 
the View NetCDF Header button. This should always be done if you are unfamiliar with 
the structure and contents of the file. 

 

 
Figure 13-1: The netCDF setup wizard (step 1 of 4) 

 

Specifying metadata information 

On the second page of the setup wizard (Figure 13-2) you must identify the netCDF var-
iables that provide metadata, such as longitude, latitude, as well as date and time of the 
data. In many cases ODV can identify and associate the respective variables automati-
cally. Such automatically associated meta-variables are marked with an asterisk *. 

In some cases it is necessary to modify the automatic settings and establish associations 
between variables from the netCDF file (NetCDF variables list) and ODV meta-variables 
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(Meta variables list) manually.  

To establish a (1-to-1) association between a netCDF variable and a meta-variable, se-
lect the netCDF variable in the NetCDF variables list and the meta-variable in the Meta 
variables list and press Associate. To establish a conversion between a netCDF and ODV 
meta-variable (usually needed for netCDF time variables), select the two variables as 
above and then press Convert. Choose one of the available conversion options from the 
combo-box and press OK. For the General Linear Transformation provide a scale factor 
and an offset. 

Many netCDF files use relative times given as days or hours since a specific start date. 
You can exploit this information to obtain date and time meta information. To do so se-
lect the relative time in the NetCDF variables list and Year in the Meta variables list, then 
press Convert. ODV will try to establish a conversion automatically. If not successful, 
ODV lets you choose an appropriate conversion algorithm manually. Note that ODV as-
sumes that the reference date is based on the Gregorian calendar. ODV date values are 
Gregorian dates. 

You can modify the default value of a meta-variable (e.g., Cruise, etc.) by selecting it in 
the Meta variables list and pressing Set Default. 

Note that the meta-variables Cruise, Station and Type are set automatically by ODV and 
need not be established manually. If the netCDF file does not contain date and time in-
formation the Year, Month, Day, Hour, Minute and Second meta-variables may remain 
unassociated. However, Longitude and Latitude meta-variables must always be associ-
ated before you can advance to the next page of the wizard. 

 

 
Figure 13-2: The netCDF setup wizard (step 2 of 4) 

 

 Selecting the primary variable 

On the third page of the setup wizard (Figure 13-3) you select the primary variable. 
This variable plays the role of the primary variable in ODV collections and determines 
whether the data are interpreted as vertical profiles or time-series. If, for instance, 
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Depth or other vertical dimensions are used as primary variable, the stations will repre-
sent vertical profiles; if you use a Time variable, the stations will represent sequences in 
time. If the Year meta-variable was defined on page 2 of the wizard, the Use decimal 
date/time item is enabled and you can use a decimal time variable (units=YEARS) de-
rived from the station header as primary variable (note that for time-series, the 
date/time meta information refers to the start of the time series and is a constant 
value). 

Quite often netCDF files contain data values on a horizontal grid (e.g., fluxes across the 
air-sea interface, or concentrations at given depth layers) without providing a variable 
specifying the exact value of the layer (e.g., depth=0 m, or depth=1000 m). In such cases 
you should choose the Use dummy variable item. 

 

 
Figure 13-3: The netCDF setup wizard (step 3 of 4) 

 

Subsetting dimensions 

When working with large netCDF datasets, it is convenient to restrict data access to the 
domain and depth or time ranges of interest. By default, ODV adjusts the increment val-
ues (stride) of the longitude and latitude dimensions such that the total number of sta-
tions does not exceed 300,000.  

You can manually subset any of the coordinate variables, or narrow down the domain 
by zooming into the map. To subset a particular dimension select the corresponding 
item in the NetCDF dimensions list and press the Subset Dimension button. ODV shows a 
list of the respective coordinate values and lets you specify a start index, increment, and 
end index for this coordinate. Press OK to accept the new index set. Repeat this proce-
dure for all dimensions that you want to subset.  

To define a sub-region of interest press the Zoom into Map button, then resize and/or 
move the red zoom box to the desired domain and press the Enter button or double-
click the left mouse to accept your choice. Press ESC or right-click the mouse to abort 
the zoom operation. 
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Figure 13-4: The netCDF setup wizard (step 4 of 4) 

 

Exploring the netCDF file 

Once all four steps of the netCDF setup wizard are completed, ODV draws a station map 
and lets you explore the data in the netCDF file in the same way as if you were using a 
native ODV data collection. Note that ODV treats netCDF files as read-only datasets and 
never writes to these files. Therefore, all options requiring data write access are disa-
bled. This also includes all data import options, the editing of metadata and data op-
tions, and most collection manipulation options. 

ODV stores netCDF setup settings in view files and uses these settings the next time you 
open the netCDF file. If you want to establish a new setup for an already open netCDF 
file, open the netCDF file again using the File > Recent Files option.  

Remote netCDF access 

When working with remote netCDF files data access speed depends on the bandwidth 
of your Internet connection as well as on the particular type of data request issued. 
Fetching the data of individual stations (triggered for instance by clicking on the map) 
can take quite long if the length of the primary variable (see above) is large. This hap-
pens, for instance, if the netCDF file contains profile data for thousands of pressure or 
depth values (e.g., CTD data) or time-series data with thousands of recorded times (e.g., 
current meter data). In such cases try to avoid clicking on the station map unintention-
ally to not trigger unwanted data retrievals. 

Loading the data of ODV SECTION windows is very time consuming when working with 
remote netCDF files. Therefore, the options for defining and managing sections are disa-
bled in such cases. You can still view distributions along zonal (or meridional) sections 
by subsetting the latitude (longitude) dimension on page 4 of the NetCDF Setup wizard 
and choosing just a single value. You can enter the setup wizard at any time via Collec-
tion > Properties > NetCDF Setup. Then proceed by defining the derived variable 
Metadata > Longitude (Metadata > Latitude) and establish a SCATTER window with the 
derived longitude (latitude) variable on X, the vertical coordinate on Y and the variable 
to display as Z. 

In addition to the numeric data, ODV 4.7.4 and later also extract data of text variables 
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from netCDF files and display the texts in the Current Sample Window. There are now 
more variables listed in the Current Sample Window, and the names and order of varia-
bles differ from previous ODV versions. The variables are ordered as follows: the pri-
mary variable, followed by an alphabetically sorted list of numeric variables, followed 
by an alphabetically sorted list of text variables. The ODV variable names are the 
netCDF variable names in the file, and the units entry is taken from the units attribute. 
Every ODV variable has a comment string constructed as concatenation of the netCDF 
variable's long_name, comment and conventions attributes. ODV displays details of the 
ODV variable, including the comment, when the mouse hovers over a variable in the 
Current Sample Window. 

NetCDF variables containing the _QC suffix as part of their variable name are automati-
cally treated as quality flag variables and their values are used by ODV as quality flags of 
the parent variable. NetCDF variables containing the _STD or _ERROR suffixes as part of 
their variable name are automatically treated as data error variables of the parent vari-
able. 

NOTE: Views created for netCDF files using ODV 4.7.3 and before may not display 
properly with ODV 4.7.4 and later due to the differences in the number and order of 
variables introduced with ODV 4.7.4. If you encounter problems please re-define isosur-
face variables and re-assign variables on the X, Y, and Z axis of your data windows.  
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14 Tools 

14.1 Geostrophic Flows 

You may calculate and visualize geostrophic flows perpendicular to the current section 
using the Tools > Geostrophic Flows option. Specify the name of the .odv output collec-
tion receiving the results and define a reference layer by choosing a depth horizon, iso-
pycnal or any other iso-surface. By default, the output collection is written to subdirec-
tory GeoVel of the parent collection directory. This subdirectory is created automati-
cally if not already present. ODV will start the calculations and export the station-pair 
results and geostrophic velocities to the .odv collection specified above.  

Once completed, you should view the log file of the calculations and then open the 
newly created collection containing the station pair and geostrophic velocity data. You 
should define a suitable map domain by zooming, and switch to a SECTION layout by 
pressing F11. Then define Geostr. Vel. [cm/s], Geostr. Vel. (north comp.) [cm/s] and/or 
Geostr. Vel. (east comp.) [cm/s] as Z-variable of one or more plot windows. The station 
label of a given station-pair A->B:alpha consists of the original station numbers A and B 
of the stations used in the pair and the direction alpha of positive Geostr. Vel. flow val-
ues (alpha=0: eastward; alpha=90: northward; etc.). The meta-variable Distance con-
tains the distance between the two stations in km. 

Geostrophic velocities are derived from dynamic height differences between two hydro-
graphic stations. Calculations proceed in two steps: (1) First the data of the two stations 
are mapped to a set of standard depths by piecewise linear least squares. (2) Then dy-
namic heights at the standard depths are calculated for both stations, and the geo-
strophic velocities for the station pair at the standard depths are obtained from the dy-
namic height differences. ODV also calculates average values for all variables in the col-
lection (pair-averages). Both, the pair-averages and the geostrophic velocities are rep-
resentative for the mid-point between the two stations involved, and ODV writes those 
values to the output .odv collection for a virtual pair station located at the mid-point be-
tween the two stations in the pair. The station label of the pair station contains the sta-
tion labels of the original stations involved. 

Note that geostrophic velocities are not calculated close to the Equator or for stations 
with sparse hydrographic observations. Because results are very sensitive to data er-
rors, it is essential to quality control the temperature and salinity data of the section 
carefully prior to invoking the Tools > Geostrophic Flows option. One way to proceed is 
to flag suspicious data as Questionable or Bad using the Edit Data option and to accept 
only Good and Unknown data by applying appropriate sample filter settings. Also, by ap-
plying appropriate station filter settings, you should make sure that only stations for a 
given expedition are included in the calculations and that stations from other cruises 
crossing the section are excluded. You should eliminate stations covering only part of 
the water column and only use full, top-to-bottom profiles. 
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14.2 2D Estimation 

For data windows using the Weighted-average or DIVA gridding methods you can per-
form estimation of Z-values at arbitrary, user-specified X-Y points by choosing the Ex-
tras > 2D Estimation option from the respective data window popup menu. The esti-
mated Z-values at the user-specified X-Y positions are obtained by applying the win-
dow’s current gridding method using the same parameter settings that are also used for 
generating the window’s gridded field shown on the screen.  

As for the gridded field, the results at the user-specified X-Y positions depend on the 
magnitudes of the gridding averaging length scales: large length scales result in smooth 
fields, whereas small scales allow maintaining small-scale features in the data. Also note 
that the length-scales are specified in per mille of the current X and Y ranges. Changing 
the axis ranges by zooming in or out may lead to changes of the averaging length scale 
values which will also affect the 2D Estimation results. Use the data plots Properties dia-
log to adjust the length scales until you are satisfied with the distribution displayed in 
the data window. Then invoke the Extras > 2D Estimation option. 

ODV will prompt you for a file (called input file in the following) with the X-Y coordi-
nates of the points for which estimation is requested. This file has to be prepared prior 
to invoking the 2D Estimation option. It has to be in plain ASCII format with an optional 
header line containing appropriate column labels and an unlimited number of extra 
lines with one X-Y coordinate pair per line. Use spaces or TABs as separators between 
columns. Note that by default ODV searches for the input file in the misc subdirectory of 
the collection. Placing the input file there simplifies the selection process.  

For each X-Y point in the input file ODV will estimate a Z-value, and will write the esti-
mated values together with the respective X and Y coordinate to an output file. The out-
put file is written to the same directory as the input file, and the file name is of the form 
<name>_est.<ext>, where <name>.<ext> is the name of the input file. Each line in the 
output file contains the X, Y, and Z values of one estimation point. A Z value of -1.e10 in-
dicates that the particular X-Y point is far from any data point and that no reliable esti-
mation could be performed. Z values at points outside the window domain or in regions 
exceeding the window’s quality limit (white areas in the plot) are set to -1.e10. 

Please note that the input file may include extra columns in addition to X and Y. The 
original X-Y values as well as the content in the extra columns will be copied to the out-
put file and the estimated Z values are then appended on each line. Including an extra 
column for some variable A will facilitate plotting A versus the estimated Z values and 
analyzing the correlation between the variables. If you add extra columns in the input 
file make sure that X and Y coordinates are in the first two columns. 

14.3 3D Estimation 

You can estimate values for a basic or derived variable at arbitrary geographical loca-
tions by choosing Tools > 3D Estimation. ODV will prompt you for an ASCII file that con-
tains the longitude, latitude, and depth values of the points for which Z-variable esti-
mates are to be obtained. This 3D point definition file has to be prepared prior to invok-
ing the Tools > 3D Estimation option. When creating the point definition file, specify one 
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point per line, and provide decimal longitude, latitude and depth values in this order, 
with one or more spaces separating the individual values. ODV will let you choose the 
variable for which the estimation should be performed and it lets you specify x, y, z av-
eraging length scales used for the estimation. Note that the length scale units for longi-
tude and latitude are in per mille of the current map ranges, whereas the unit of the 
depth length scale is in meters. Choosing large values for the averaging length scales 
will result in smooth estimates. For the 3D Estimation all original data points from all 
stations currently shown in the map will be used. The weight with which a given data 
point influences the estimate at a specific target location is inversely proportional to the 
distance between data and target points. The output file contains one line of results for 
every longitude, latitude and depth point specified in the input file. Each line contains 
six numbers x, y, z, v, d, n with the following meaning: 

 
x, y, z  longitude,  latitude, depth (as specified in the input file) 
v  estimated value 
d normalized distance of averaged data x, y, z positions from estimation 

point (in units of averaging length scales) 
n number of data points used. 
 
Note: The Tools > 3D Estimation option is only enabled if the Depth in Water Column [m] 
and/or Pressure in Water Column [db] key variables have been identified. If necessary 
use option Collection > Identify Key Variables to establish such associations. 

14.4 Box Averaging 

You can use ODV to calculate averages and standard deviations for basic or derived var-
iables in given longitude-latitude-depth boxes. Only stations currently shown in the 
map are considered and only stations and data points inside the requested box are actu-
ally used for the mean and standard deviation. You can specify appropriate station se-
lection criteria prior to invoking the Box Averaging option, to obtain averages for differ-
ent station subsets, years, months, or seasons. To invoke box averaging, choose Tools > 
Box Averaging from the main menu. ODV prompts for the ASCII box definition file con-
taining the geometry information of the boxes for which output is to be produced. ODV 
then shows the list of basic and derived variables and lets you choose one or more vari-
ables for the averaging procedure. The box definition file has to be prepared prior to in-
voking the Box Averaging option.  

The format of the box definition file is as follows: 

• plain ASCII, one box definition per line, 6 numbers 
separated by (one or more) spaces, 

• meaning of numbers (see figure):  
lon lat dep (box center) ∆lon ∆lat ∆dep (box sizes). 
Longitudes and latitudes are in decimal degrees, 
and depth is in meters.  
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Once you have specified a box definition file, ODV will start working. Note that while av-
eraging, ODV will check for data outliers and will use only data within 3 standard devia-
tions of the mean. The output will be written to the directory of the box definition file. 
The output file names consist of the box definition file name, the label of the variable 
that is processed and the extension .est. 

The format of the .est output file is as follows: 

• plain ASCII, one line of output per line in the box definition file, 10 values sepa-
rated by TABS, 

• meaning of values:  
lon lat dep (same as in box definition file)  𝑙𝑙𝑙𝑙𝑙𝑙���� 𝑙𝑙𝑙𝑙𝑙𝑙���� 𝑑𝑑𝑑𝑑𝑑𝑑����� 𝑣𝑣𝑣𝑣𝑣𝑣���� σ nu nr. 

𝑙𝑙𝑙𝑙𝑙𝑙���� 𝑙𝑙𝑙𝑙𝑙𝑙���� 𝑑𝑑𝑑𝑑𝑑𝑑����� 𝑣𝑣𝑣𝑣𝑣𝑣���� are average longitude, latitude, depth and variable values of the data 
used, σ is the standard deviation of the variable values, nu is the number of data points 
used and nr is the number of data points rejected. A data point is rejected if its value dif-
fers from the mean 𝑣𝑣𝑣𝑣𝑣𝑣���� by more than 3 standard deviations σ. Note that the error of the 
mean 𝑣𝑣𝑣𝑣𝑣𝑣���� can be calculated as 

𝜎𝜎𝑚𝑚 = 𝜎𝜎 �𝑛𝑛𝑢𝑢⁄  

If no data point is found within a box, 𝑣𝑣𝑣𝑣𝑣𝑣���� is set to -1.e10; if only one data point is found, 
σ is set to 1.e10. 

Also note that all individual data values used for given boxes are exported to ASCII files 
with names of the form #<box-number>_<var-name>.dat, where <box-number> repre-
sents the respective box number (e.g., line number in the box definition file) and <var-
name> represents the variable name for which the average is calculated. In the .dat files 
the meaning of values is as follows: sample ID, longitude, latitude, depth, decimal year, 
day-of-year, value, weight, used/rejected-flag. Note that the .dat files are overwritten by 
subsequent box averaging requests. No .dat files are written if the total number of re-
quested averages exceeds 5000. 
 
Note: The Tools > Box Averaging option is only enabled if the Depth in Water Column [m] 
key variable has been identified. If necessary use option Collection > Identify Key Varia-
bles to establish the association. 

14.5 Finding Outliers 

You can scan the currently selected stations for samples with data values inside or out-
side a user specified value range by choosing Tools > Find Outliers (Range Check). Select 
the variable to be scanned from the list of variables and enter the range values under 
Range. Under Action choose whether you want to find values inside or outside the speci-
fied range. Press OK to start the scan. ODV will report the number of outliers found and 
lets you view the list of outliers. ODV also lets you inspect and modify the data values 
and/or quality flags of the outlier samples. 

If you check Inspect and Edit Outliers, ODV will visit all identified outliers and allows you 



ODV User’s Guide  
 

    145 

to delete the respective value or to modify the quality flag associated with the value. If 
you press Apply to All, ODV applies the selected operation to all outliers; otherwise the 
user is prompted for an action for each individual outlier. Note that the currently edited 
outlier is marked in the data plots. 

14.6 Finding Duplicate Stations 

You can scan the currently valid station set (the stations shown in the map) for stations 
with identical or nearly identical positions and times of occupation (duplicate stations) 
by choosing Tools > Find Duplicate Stations. Information about the detected groups of 
duplicate stations is written to a file. Specify the maximum allowed differences in time 
of occupation and geographical position for two stations to be considered duplicates, 
press OK, and then select the file that will receive the output of the duplicates search.  

ODV will perform the duplicates search and will write information about detected du-
plicate station groups to the selected output file. The following information is provided 
for each station: (1) station ID, (2) cruise label, (3) station label, (4) station type, (5) 
date and time, (6) longitude, (7) latitude,  (8) number of samples, (9) deepest sample, 
(10) availability indicators for basic variables 2 to nVar (e.g., 7 indicates between 70 
and 79% of the samples contain data for a given variable). 

ODV will report the number of groups and duplicate stations found. You may view the 
duplicate station list and inspect and edit the duplicate stations by checking the respec-
tive boxes. If you choose to edit the duplicate stations the Duplicate Station Action dia-
log (Figure 14-1) will appear for every duplicate station group. You may either delete 
all but one of the stations in the group or merge the data of all stations in the group into 
the first station of the group. Note that these operations change the contents of the col-
lection files and cannot be undone. 

 

 
Figure 14-1: The Duplicate Station Action dialog. 

 

If you want to apply the specified action to all remaining duplicate station groups click 
on Apply to All. If you want to keep a group unchanged press Keep; to abort the editing 
of duplicate stations press Cancel. 

NOTE: The computational load of the duplicate station scan scales with the square of 
the station number and may take hours for large collections with millions of stations. In 
such cases the map domain should be divided into sub-regions (by zooming or manu-
ally setting the map domain) and scans should be performed separately for every sub-
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domain. 

14.7 Ocean Calculator 

ODV allows calculation and plotting of more than 40 commonly used variables from 
physical and chemical oceanography by invoking the Tools > Ocean Calculator option. 
On the Ocean Calculator dialog (Figure 14-2) you first select in the Variables list the var-
iable you want to be calculated. Then you enter input values under Input values, and fi-
nally press the Evaluate button to receive the variable value at the specified inputs in 
the Result field.  

You may request calculations for sets of input values for one or more of the input varia-
bles by specifying start : increment : end triples. For instance, specifying Temperature 
input values as -2:1:35 will result in repeated calculations of the chosen variable for in-
put temperatures at every degree C between -2 and 35. If multi-inputs are specified 
ODV copies all input variable values and calculated results to the clipboard for further 
processing or plotting using other software of your choice.  
 

 
Figure 14-2: The Ocean Calculator tool. 

 

ODV automatically produces 1D curve or 2D contour plots as shown in Figures 14-3 and 
14-4 if one or two input variables have multi input values.  
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Figure 14-3: Curve plot for one input variable with multiple input values. 

 

  

Figure 14-4: Contour plot for two input variables with multiple input values. 

 

You change the calculator settings by pressing the Settings button. On the Calculator 
Settings dialog (Figure 14-5) you may specify the vertical coordinate in the water col-
umn (Pressure [dbar] or Depth [m]), the default salinity input variable (Practical Salinity 
[psu] or Absolute Salinity [g/kg]), the set of equilibrium constants, the carbon data input 
pair and the pH-scales (input and output) used for the calculation of carbon parameters 
in seawater. ODV remembers your settings and the last input values between Ocean Cal-
culator invocations. You can continue using ODV while the Ocean Calculator is open. 

Note that a number of functions natively require absolute salinity as input. When practi-
cal salinity is chosen as input variable ODV will automatically convert the entered prac-
tical salinity value into absolute salinity and then call the native function with the con-
verted absolute salinity value. The conversion from practical to absolute salinity de-
pends on geographical position. Therefore longitude and latitude input fields are availa-
ble in addition to practical salinity field. A few functions are only available for one type 
of salinity input, regardless of the salinity input setting. If absolute salinity is required 
as input but only practical salinity data are available use the Absolute Salinity SA [g/kg] 
function to convert from practical to absolute salinity in a first step. Alternatively, if 
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practical salinity is required as input but only absolute salinity data are available use 
the Practical Salinity from Absolute Salinity [psu] function to convert between the two 
salinity types. 
 
 

 
Figure 14-5: The Calculator Settings dialog. 
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15 Miscellanea 

15.1 Drag-and-Drop 

On most supported platforms you can drag and drop ODV supported files onto the ODV 
window or icon. Depending on the extension of the dropped file, ODV will perform the 
following actions: 

.odv or .var: close current collection or netCDF file and open the dropped collection. 
 
.nc or .cdf: close current collection or netCDF file and open dropped netCDF file. 
 
.txt (ODV spreadsheet files): import the data into the currently open collection, or, if 

no collection is open, create a new collection with the same name as the .txt file 
and import the data into the newly created collection.  

 
ODV supported file names can also be used as command line arguments. Start ODV from 
any terminal window by typing: odv  [file name[.extension]]. Note that for file name you 
either use absolute pathnames or pathnames relative to the directory from which you 
start ODV. If you use a relative pathname, “.” and “..” are not allowed. You can use com-
mand line arguments to  

1. start ODV and open an existing collection: use the collection name for file name. 
If you omit an extension, the default .odv is used. 

2. create a new collection and import data: use the name of the data file (must be 
one of ODV’s import types, e.g., .o4x, .txt) to be imported for file name. In this 
case you must provide the extension. ODV will create a new collection in the di-
rectory of the import file and will import the data from the file. The data varia-
bles are determined from information in the data file. 

15.2 ODV Command Files 

You can store commands for frequently used operations, such as opening a collection, 
loading specific view files and creating graphics or data output files in ODV command 
files. ODV command files can be executed at any time (batch mode) using the File > Exe-
cute Command File option or using the “–x cmd_file” command line option. The default 
extension of ODV command files is .cmd. The default location is the directory 
ODV/cmd_files in the user’s document directory. Create directory cmd_files, if it is not al-
ready present and place your command files in this directory. 

The following commands are currently supported in ODV command files. Note that a 
slash “/” should be used as path separation character in all filenames appearing in ODV 
command files to ensure platform independence. Once a base directory is defined using 
the set_base_directory command, all subsequent relative filenames are considered rela-
tive to base directory. If no base directory is defined and a collection or netCDF file has 
been opened, relative filenames are considered relative to the collection or netCDF di-
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rectory. Multiple arguments must be separated by commas “,” except in the set_var com-
mand, where “=” is used as separator between variable name and value. The window 
index parameter iw used in some commands can have the following values: -1 for the 
graphics canvas, 0 for the map, and positive integer values for data windows. Lines in 
ODV command files may not exceed 255 characters in length. Everything to the right of 
the comment character # is considered a comment and not executed.  

 
create_annotation iw, x, y, orientation, textAlign, “text” 

Create a text annotation text for window iw  at position x, y (window iw  coordinates) oriented 
along orientation degrees measured counter-clockwise from positive x-axis. textAlign determines 
the alignment of the text relative to (x, y): center_center 0, center_top 1, center_bottom 2, right_top 
3, right_bottom 4, left_top 5, left_bottom 6, right_center 7, left_center 8. Note that iw  and textAlign 
are integers, x, y, and orientation are floats. Note that the annotation text has to be enclosed in “” 
characters. 

Example:  create_annotation -1, 10., 8., 30., 0, “Some Text” 

create_collection  collection,  collection_type 
Create collection collection using the template set of data variables collection_type.  collection_type 
may be one of the following: ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASBOTTLE, 
MEDATLASCTD, MEDATLASTIMESERIES, MEDATLASPROFILES, MEDATLASSEDIMENTTRAP, 
WORLDOCEANDATABASE. 

Note: If collection already exists the existing version is deleted before the new version is created.  

Example:  create_collection c:/data/ARGO_Atlantic.odv, ARGOPROFILES 

delete_collection  collection 
Delete the currently open collection collection. The collection argument must be the same as was 
used in the previous open_collection call. 

Example:  delete_collection c:/data/ARGO_Atlantic.odv 

export_data    data_file 
Export the data of the current station set to file data_file using the generic ODV spreadsheet for-
mat. 

Example:  export_data c:/output/odv_data.txt 

export_graphics   iw, graphics_file, dpi 
Save graphics of window iw in file graphics_file using a resolution of dpi dots-per-inch. Use 
graphics_file extensions .eps, .gif, .png or .jpg for PostScript, GIF, PNG or JPEG output, respectively. 
Although the dpi argument is not used for PostScript output, it must still be provided.  

Example:  export_graphics –1, c:/output/odv_graph.eps, 300 

import_data    file_spec,  import_type 
Import the data from all files satisfying file_spec using import route import_type. import_type may 
be one of the following: ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASPROFILES, 
MEDATLASTIMESERIES, MEDATLASSEDIMENTTRAP, WORLDOCEANDATABASE. file_spec may be the 
pathname of a single import file, or a wildcard file specification, or the pathname of a .lst list file 
containing the pathnames of the files to import. file_spec must be an absolute pathname or relative 
to the base directory specified in a previous set_base_directory command. Entries in .lst list files 
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must be absolute pathnames. 

Example:  import_data c:/data/*.nc, ARGOPROFILES 

load_view   view_file 
Load view file view_file. View_file can be a .xview or .cfg file. load_view is equivalent to load_cfg, 
which is still supported for backwards compatibility. Use $FullScreenMap$, $OnePickWin$, $Two-
PickWin$, $SixPickWin$, $OneScatterWin$, $TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, 
$TwoSectionWin$, $ThreeSectionWin$, $FiveSectionWin$, $SixSectionWin$, $OneIsoSurfaceWin$, 
$TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, $FiveIsoSurfaceWin$, $EightIsoSurfaceWin$, $ElevenI-
soSurfaceWin$, $FiveMixedWin$, $FromFileWin$, or $OneIsoSurfaceOneScatterWin$ for loading one 
of the template views. 

Example:  load_view c:/views/abc.xview 

open_collection  collection[, view_file] 
Open collection collection and load the view view_file. The view_file argument is optional. Use $Full-
ScreenMap$, $OnePickWin$, $TwoPickWin$, $SixPickWin$, $OneScatterWin$, $TwoScatterWin$, 
$SixScatterWin$, $OneSectionWin$, $TwoSectionWin$, $ThreeSectionWin$, $FiveSectionWin$, $Six-
SectionWin$, $OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, $FiveIsoSurface-
Win$, $EightIsoSurfaceWin$, $ElevenIsoSurfaceWin$, $FiveMixedWin$, $FromFileWin$, or $OneI-
soSurfaceOneScatterWin$ for loading one of the template views. Note that password protected col-
lections cannot be opened and used in ODV command files. 

Example: open_collection c:/ewoce/WoceBtl.odv 
open_collection c:/ewoce/WoceBtl.odv, $FullScreenMap$ 

open_data_file   data_file 
Create and open a collection using the set of variables in data_file and import the data from 
data_file into the newly created collection. data_file must  be generic ODV spreadsheet format com-
pliant and must have the .txt extension. The new collection is created in the directory of the data 
file and its name is the basename of the data file. Note that any existing collection with this name 
and path is deleted without asking for user permission. 

Example:  open_data_file c:/ewoce/WoceData.txt 

quit 
Terminate and exit ODV. 

Example:  quit 

save_view   view_file 
Save the current view to file view_file. View_file must have the .xview extension.  

Example:  save_view c:/cfg_files/abc.xview 

set_annotation_style ptSize, textColor, bckgrdColor, frameColor, frameWidth 
Set the style of text annotations subsequently created with create_annotation. ptSize is the font size 
in points, textColor is the color of the text, bckgrdColor is the background color of the text bounding 
box, frameColor is the frame color of the text bounding box, and frameWidth is the width of the 
frame around the text bounding box. All colors are specified as index values into the current color 
palette. Specify –1 for bckgrdColor and/or frameColor to avoid drawing of a background box or 
frame. Note that all arguments to set_annotation_style are integers. Default values are: 16, 0, -1, -1, 
0, which will produce 16pt black text without box or frame.  

Example:  set_annotation_style 24, 8, 7, 0, 1 
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set_axis_full_ranges iw 
Sets x, y, and z axis ranges of data window iw (1-based window index) or of all data windows (iw=-
1) to full ranges. For iw=0 sets the map's domain to the domain covered by the currently valid sta-
tions. 

Examples: set_axis_full_ranges -1 
set_axis_full_ranges 0 

set_axis_range iw, axis, v0, v1 
Set the value range of axis axis (possible values: x, y, or z) of window iw (-1 and 0 not allowed) to v0 
(left/lower) and v1 (right/upper). Full axis ranges accommodating all window data are used if v0 
and v1 are not provided.  

Examples: set_axis_range 1, x, 34, 37 
set_axis_range 1, y, ,  

set_base_directory  base_directory 
Define a base directory. All subsequent file names are assumed to be absolute pathnames or names 
relative to base_directory. 

Example:  set_base_directory c:/ewoce/data 

set_var  var_name = string 
Sets the value of variable var_name to string. You can use the variable on subsequent lines as 
%var_name%. 

Example:  set_var OUTDIR = c:/tmp 
export_data %OUTDIR%/A15_OXYGEN.txt 

 

Following below is an example ODV command file that opens a collection, loads a view, 
adds an annotation, writes two image files of the entire canvas and of data window 1, 
respectively, exports the data of the currently selected stations to an ODV spreadsheet 
file, and finally shuts down ODV. 

 
set_var   OUTDIR = c:/tmp 
set_base_directory   c:/data/eWOCE/data/whp/bottle 
set_annotation_style  18, 0, 7, 0, 1 

open_collection   WoceBtl.var 

load_view          atlanticSections/A15_OXYGEN.xview 
create_annotation   1, -13.18,65.83,0, 6, "Test" 

export_graphics   -1, %OUTDIR%/A15_OXYGEN.png, 100 
export_graphics    1, %OUTDIR%/A15_OXYGEN_1.png, 200 
export_data       %OUTDIR%/A15_OXYGEN.txt 

quit 

15.3 Color Palettes 

ODV-style color palettes define 177 colors (see Figure 15-1):  
• 0-15:  basic colors, 
• 16-31: gray-scale, 
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• 32-144: main palette used for color-shading, 
• 145-160: colors used for map bathymetry and continents, 
• 161-176 colors used for map land topography. 
 
 

 
Figure 15-1: The ODV default color palette. 

 

ODV comes with a set of different rainbow palettes, single- or two-color palettes 
(BlueOnly, BlueRed, etc.) as well as a range of greyscale palettes. In addition, ODV also 
includes the Viridis palette (courtesy Anton Velo) providing improved perception for 
people affected by various types of colorblindness. 

 
Figure 15-2: The Viridis color palette. 

 

You can select a different color palette of the map or any data window by right-clicking 
on the window, choosing the Properties option and selecting one of the available palette 
files from the Palette combo-box on the General page. ODV will redraw the map or data 
window using the new palette.  

On Windows you can modify existing palettes or create new ones using the PalEdt.exe 
application. PalEdt.exe can be invoked from ODV by choosing Tools > Palette Editor. 

15.4 Animations 

ODV lets you produce animated GIF files of the map or any data window by right-click-
ing on the respective window and choosing Extras > Animation and one of the sub-op-
tions Metadata Time, Metadata Time of Year, Variable Range, or Isosurface. Then follow 



Version 5.1.0 

 154 

the instructions below. 

(1) Metadata Time: 

Specify a start date t0, the interval step tStep (in days), the interval width tWidth (in 
days), the number of frames n to be produced and the interval type. ODV will then con-
struct n time intervals and use the respective start and end dates for the Date/Time > 
Period station filter settings.  

Depending on the selected interval type, the start and end dates of interval i (i=0,…,n-1) 
are defined as follows:  

 

Interval Type Start of Interval i End of Interval i 

Zero Width 𝑡𝑡0 + 𝑖𝑖 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡  𝑡𝑡0 + 𝑖𝑖 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡   
Fixed Width 𝑡𝑡0 + 𝑖𝑖 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡   𝑡𝑡0 + 𝑖𝑖 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡+ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡ℎ   
Fixed Start 𝑡𝑡0  𝑡𝑡0 + (𝑖𝑖 + 1) ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡   
Fixed End 𝑡𝑡0 + 𝑖𝑖 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡   𝑡𝑡0 + 𝑛𝑛 ∙ 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡   

 

For each such time interval, the map will be re-build, including only those stations with 
metadata dates in the respective time window. If the animation is for a data window, 
this data window will also be redrawn using data from the currently selected station set 
only. The current map or data window will then be added to the animation file.  

(2) Metadata Time of Year: 

Specify a start month and day t0, the interval step tStep (in days), the interval width 
tWidth (in days), the number of frames n to be produced and the interval type. ODV will 
then construct n time intervals and use the respective start and end dates for the 
Date/Time > Season station filter settings. Depending on the selected interval type, the 
start and end dates of interval i (i=0,…,n-1) are defined as in the table above.  

For each such time interval, the map will be re-build, including only those stations with 
metadata months and days in the respective time window. Note that data from more 
than one year may be used if the data collection contains stations from multiyear pe-
riod. If the animation is for a data window, this data window will also be redrawn using 
data from the currently selected station set only. The current map or data window will 
then be added to the animation file.  

(3) Variable Range: 

This option is available for non-isosurface data windows only. Select a validate variable 
and specify a start value v0, the interval step vStep, the interval width vWidth, the num-
ber of frames n to be produced and the interval type. ODV will then construct n intervals 
for the validate variable and use the respective start and end values for the sample filter 
settings of the chosen variable. 

Depending on the selected interval type, the start and end values of interval i (i=0,…,n-1) 
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are defined as follows:  

Interval Type Start of Interval i End of Interval i 

Zero Width 𝑣𝑣0 + 𝑖𝑖 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0 + 𝑖𝑖 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 

Fixed Width 𝑣𝑣0 + 𝑖𝑖 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0 + 𝑖𝑖 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣+ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣ℎ 

Fixed Start 𝑣𝑣𝑐𝑐  𝑣𝑣0 + (𝑖𝑖 + 1) ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 

Fixed End 𝑣𝑣0 + 𝑖𝑖 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0 + 𝑛𝑛 ∙ 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 
 

For each such interval the data window will be redrawn, including only data from the 
respective variable value interval. The current data window snapshot will then be 
added to the animation file.  

(4) Isosurface : 

This option is available for isosurface data windows only. Select a start value s0, the in-
terval step ds, and the number of frames n to be produced. ODV will then construct n 
isosurface values and will re-build the data window for each such value. The current 
data window snapshot will then be added to the animation file.  

For all animations ODV will draw an animation bar indicating the current animation in-
terval. The animation bar is centered below the respective window. 

15.5 Gazetteer of Undersea Features 

ODV can be used to identify undersea features like seamounts, ridges, fracture zones, 
troughs, basins, etc. To invoke the gazetteer option, choose Extras > Gazetteer from the 
map popup menu. The gazetteer dialog box is shown, which lets you select a specific da-
tabase, lets you specify feature selection criteria as well as size and color of the gazet-
teer marks drawn by ODV. When you press the Switch On button (or Update, if you have 
modified the gazetteer settings), the information from the selected gazetteer database 
is loaded, and the feature positions are marked in the map. Moving the mouse close to a 
feature point invokes a popup window displaying the name of the feature. To switch off 
the gazetteer marks, invoke the gazetteer dialog box again and press the Switch Off but-
ton.  

A number of gazetteer files are provided with the ODV distribution. These include: (1) 
GazetteerGEBCO.gzt from the International Hydrographic Bureau (IHB), (2) Gazet-
teerBGN.gzt from the US Defense Mapping Agency, and (3) WHP_Sections.gzt, which is a 
compilation of the sections occupied during the WOCE Hydrographic Programme. You 
can select feature subsets by specifying a feature type and/or feature name sub-string 
using the gazetteer dialog box. Note that the name and type selections are case-insensi-
tive. Use the gazetteer feature selection if you know the name of a feature (or part of the 
name) and want to identify its location (note that you might have to open the map to 
global extent in order to see the feature mark). Gazetteer settings are not saved in con-
figuration files. Whenever you open a collection, the gazetteer option is switched off ini-
tially. 
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Gazetteer files can be edited and extended. You can also create your own, new gazetteer 
databases. In order to use a private gazetteer with ODV, the file must have the extension 
.gzt, it must be located in the ODV gazetteer directory (<home>\odv_local\gazetteers, 
where <home> represents your home directory) and its format must satisfy the specifi-
cations below: 

The first line of the file must start with % GZT01: followed by the name of the file.  

Then there are 7 lines starting with % and containing arbitrary comments.  

The next line must be: Feature;Type;No;East-Longitude;North-Latitude; there has to 
be  one blank line following.  

The rest of the file contains the actual item definitions. Each feature is listed on a 
separate line. 

The name of the feature, its type, the number of longitude/latitude points and the longi-
tude/latitude entries are separated by semicolons ”;”. Longitude is specified in degrees 
East (0 - 360 or -180 - 180). The number of longitude/latitude points can be up to 1500, 
and the length of a line may be up to 200,000 characters. 
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16 Appendix 

16.1 Mouse and Keyboard Actions 

Table 16-1: Mouse actions in ODV’s Ready status. 

Action Object Response 

   
L-Click Map 

 
Data Window 

Selects the closest station as current station. 
 
Selects the closest sample as current sample and the parent station as 
current station. 

   
Shft L-Click Map 

 
 
Data Window 

Selects the closest station as current station. Allows selection from list 
of multiple stations at the same location. 
 
Selects the closest sample as current sample. Allows selection from list 
of multiple samples at the same location. 

   
L-DbleClick Map Adds the closest station to the pick list and adds the data of this station 

to STATION data windows. 
   
L-Drag GObject 

 
Canvas, Map, 
Data Window 

Drags the graphics object (if object allows dragging). 
 
Drags the canvas (if scroll bars are present). 

   
Ctrl L-Drag 1) Map 

 
Data Window 

Quick-zooms into the map. 
 
Quick-zooms into the data window. 

   
R-Click 2) Canvas, Map, 

Data Win-
dow, GObject, 
Data List 
Windows 

Invokes element-specific context menu. 

   
Shft R-Click 3) Map, Data 

Window 
Invokes the Extras menu of the map or data window. 

1) On Mac OS systems hold down the cmd key and click-and-drag the mouse. 
2) On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 
3) On Mac OS systems with a single-button mouse hold down the Alt and Shft keys while clicking the mouse to simulate a Shft right 
mouse button click. 
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Table 16-2: Common key press actions. 

Key Response 

  

Enter or 
Return 

Adds the current station to the pick list and adds the data of this station to the STATION 
data windows (if any). In window layout mode, accepts the current layout and returns 
to normal mode. 

  

Del or 
Backspace 

Deletes the graphics object pointed to by the mouse, or, if not over a graphics object, 
removes the current station from the pick list and removes the data of this station from 
STATION data windows (if any). In window layout mode, deletes the window contain-
ing the mouse. 

  

# Allows selection of a new current station by internal sequence numbers. 

→ Selects the next station as current station. 

← Selects the previous station as current station. 

HOME Selects the first sample as current sample. 

↓ Selects the next sample as current sample. 

↑ Selects the previous sample as current sample. 

END Selects the last sample as current sample. 

PgDn Steps down (forward) the current sample. 

PgUp Steps up (backward) the current sample. 
  

Ctrl-? 1) (Mac) 

F1 2) (others) 
Shows the ODV help document. 

F4 2) Shows the data statistics of the window containing the mouse. 

F5 2) Redraws the entire canvas or the window containing the mouse. 

F8 2) Switches to full-screen map layout. 

F9 2) Switches to six STATION window layout. 

F10 2) Switches to two SCATTER window layout. 

F11 2) Switches to three SECTION window layout. 

F12 2) Switches to one SURFACE window layout. 
  

Ctrl-Plus or 
Ctrl-Wheel 1) 

Zoom in at mouse position. 

Ctrl-Minus or 
Ctrl-Wheel 1) 

Zoom out at mouse position. 

Ctrl-A 1) Adds an annotation to the window containing the mouse. 
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Ctrl-C 1) Copies the data or gridded field of the window containing the mouse to the clipboard, 
or, if the mouse is over a graphics object, creates a copy of that object. 

Ctrl-F 1) Adjusts the X, Y, Z ranges of the window containing the mouse (or of all data windows) 
to full range.  

Ctrl-N 1) Creates a new ODV collection. 

Ctrl-O 1) Opens an ODV collection, netCDF file, or supported ASCII data file. 

Ctrl-R 1) Move or resize the window containing the mouse (window layout mode only). 

Ctrl-S 1) Saves the window containing the mouse (or the entire canvas) to an image file (gif, png, 
jpg, or PostScript). 

Ctrl-W or 
Ctrl+F4 1) 

Closes the current collection or netCDF file. 

Ctrl-Y Redo last undone view change. 

Ctrl-Z Undoes the last view change. 
  

Alt-D Allows definition of derived variables. 

Alt-P Allows property changes of the window or graphics object containing the mouse. 

Alt-S Allows change of the station filter settings. 

Alt-W Allows change of the window layout. 

Alt-Z Undoes all changes. 
  

Shft-E Edits the meta- or sample data. 

Shft-L Loads view settings from a file. 

Shft-S Allows change of the sample filter settings (range and quality filters). 
  

Ctrl-, 1) 
 (Mac only) 

Opens the general settings dialog. 

ESC Aborts the current operation (if supported by operation). In window layout mode can-
cels all layout changes made and returns to normal mode. 

Ctrl-Q 1) 
(Mac) 
Alt-F4 (oth-
ers) 

Exit ODV. 

1) On Mac OS systems hold down the cmd key while pressing the other key. 
2) On Mac OS systems hold down the fn key while pressing the function keys. The fn key is not necessary if you check the 

Use all F1, F2 etc. keys as standard function keys box in the keyboard tab of the Mac system preferences. 

 

 

Table 16-3: Mouse and key press actions in Zoom or Z-Zoom modes. 
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Action Object Response 

   
L-Drag Boundaries and cor-

ners of zoom rectan-
gle 

Resizes the zoom rectangle. 
 

   
L-DbleClick or 
ENTER 

anywhere Accepts current settings and terminates zooming. 

   
R-Click 1) or 
ESC 

anywhere Discards changes and aborts zooming. 

1) On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 

 
Table 16-4: Mouse and key press actions in GetPoints modes. 

Action Object Response 

   
L-Click Canvas, Map, Data 

Window 
Add current point to list. 

   
R-Click 1) Canvas, Map, Data 

Window 
Remove closest point from list. 

   
ENTER anywhere Accept current settings and terminate GetPoints. 
   
ESC anywhere Abort GetPoints. 

1) On Mac OS systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 

 

16.2 Quality Flag Schemes 

ODV supports most quality flag schemes currently used in the oceanographic commu-
nity. Any one of these schemes can be used to encode the quality flags of a given 
metadata or data variable. See Table 16-5 and file ODV_QualityFlagSets.pdf for summar-
ies of supported schemes, lists of quality flag codes and their meaning as well as code 
mappings between the schemes.  

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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Table 16-5: Quality flag schemes supported by ODV. For full lists of quality flag values and value mappings 
between the different schemes see file ODV_QualityFlagSets.pdf.  

SchemaID Comment 

ARGO Argo quality codes. Reference: Argo data management, User’s manual, Version 2.1, 
http://www.usgodae.org/argo/argo-dm-user-manual.pdf  

BODC BODC quality codes. Reference: http://www.bodc.ac.uk/data/codes_and_formats/re-
quest_format/  

ESEAS European Sea Level Service quality codes. Reference: www.eseas.org/eseas-ri/deliv-
erables/d1.2/ESEAS_QC_29032005.doc  

GTSPP GTSPP quality codes. Reference: http://www.meds-sdmm.dfo-mpo.gc.ca/meds/Data-
bases/OCEAN/GTSPPcodes_e.htm  

IODE IODE data quality flags. Reference: http://www.iode.org/index.php?op-
tion=com_oe&task=viewDocumentRecord&docID=10762 

OCEANSITES OceanSITES quality flags. Reference: http://www.oceansites.org/docs/oceans-
ites_user_manual_version1.2.doc 

ODV ODV generic quality flags. Reference: ODV User’s Guide, http://odv.awi.de/en/docu-
mentation/ 

QARTOD Qartod quality flags. Reference: 
http://dmac.ocean.us/dacsc/docs/apr2005_post_mtg/QARTODI_II.ppt  

PANGAEA PANGAEA generic quality flags. Reference: http://wiki.pangaea.de/wiki/Quality_flag  

SEADATANET SeaDataNet quality codes. Reference:  http://seadatanet.maris2.nl/v_bodc_vo-
cab/browse_export.asp?l=L201&order=entrykey&all=yes   

SMHI Swedish Meteorological and Hydrographic Institute quality codes. 

WOCEBOTTLE WOCE bottle value quality codes. Reference: 
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOCECTD WOCE CTD value quality codes. Reference: 
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf 

WOCESAMPLE WOCE WHP quality flags for the water bottle itself. Reference: 
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf 

WOD World Ocean Database individual observed level quality codes. Reference: 
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

WODSTATION World Ocean Database entire station quality flags. Reference: 
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.usgodae.org/argo/argo-dm-user-manual.pdf
http://www.bodc.ac.uk/data/codes_and_formats/request_format/
http://www.bodc.ac.uk/data/codes_and_formats/request_format/
http://www.eseas.org/eseas-ri/deliverables/d1.2/ESEAS_QC_29032005.doc
http://www.eseas.org/eseas-ri/deliverables/d1.2/ESEAS_QC_29032005.doc
http://www.meds-sdmm.dfo-mpo.gc.ca/meds/Databases/OCEAN/GTSPPcodes_e.htm
http://www.meds-sdmm.dfo-mpo.gc.ca/meds/Databases/OCEAN/GTSPPcodes_e.htm
http://www.iode.org/index.php?option=com_oe&task=viewDocumentRecord&docID=10762
http://www.iode.org/index.php?option=com_oe&task=viewDocumentRecord&docID=10762
http://www.oceansites.org/docs/oceansites_user_manual_version1.2.doc
http://www.oceansites.org/docs/oceansites_user_manual_version1.2.doc
http://odv.awi.de/en/documentation/
http://odv.awi.de/en/documentation/
http://dmac.ocean.us/dacsc/docs/apr2005_post_mtg/QARTODI_II.ppt
http://wiki.pangaea.de/wiki/Quality_flag
http://vocab.ndg.nerc.ac.uk/term/L201/1/
http://vocab.ndg.nerc.ac.uk/term/L201/1/
http://vocab.ndg.nerc.ac.uk/term/L201/1/
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
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16.3 Generic ODV Spreadsheet Format 

The ODV generic spreadsheet format is the recommended format for exchange of data 
between data producers and data users. The generic spreadsheet format allows auto-
matic import of data into ODV collections, not requiring any user interaction. ODV also 
uses the generic spreadsheet format when exporting data from collections, and the ex-
ported datasets may easily be re-imported into the same or a different collection, possi-
bly after editing and modifying the data in the file. Exporting data from the open collec-
tion into a generic spreadsheet file is done via the Export > ODV Spreadsheet option. 

ODV generic spreadsheet files use the ASCII encoding, and the preferred file extension 
is .txt. Station metadata and data are provided in separate columns, where metadata 
and data columns can be in arbitrary order. Every metadata and data column may have 
an optional quality flag column. A quality flag column may appear anywhere after the 
metadata or data column it belongs to. Quality flag values may be in any one of the sup-
ported quality flag schemes (see Table 16-5). The total number of columns in the file is 
unlimited. All non-comment lines (see below) in the file must have the same number of 
columns. Individual columns are separated by TAB or semicolon.  

Typically, ODV spreadsheet files hold the data of many stations from many cruises. The 
number of lines in a file, as well as the length of individual lines is unlimited. There are 
three types of lines in ODV generic spreadsheet files: (1) comment lines, (2) the column 
labels line, and (3) data lines.  

16.3.1 Comment Lines 

Comment lines start with two slashes // as first two characters of the line and may con-
tain arbitrary text in free format. Comment lines may, in principle, appear anywhere in 
the file, most commonly, however, they are placed at the beginning of the file and con-
tain descriptions of the data, information about the originator or definitions of the vari-
ables included in the file. Comment lines are optional. 

Comment lines may be used to carry structured information that may be exploited by 
ODV or other software. Examples are the //SDN_parameter_mapping block employed by 
the SeaDataNet project containing references to variable definitions in official parame-
ter dictionaries, or the //<attribute_name> lines defined by ODV, containing values for 
given attribute names. The currently defined attribute names are summarized in Table 
16-6. All structured comment lines except //<History> must appear at the top of the file 
before the column labels line and the first data line. //<History> comment lines contain 
history information for a given station. They appear after the last data line of the station 
they belong to and before the first data line of the next station. 

//<MetaVariable> and //<DataVariable> comment lines contain specifications for 
metadata and data variables in the file. These lines are optional. If present, values may 
be provided for the following tags: label, value_type, qf_schema, significant_digits, and 
comment. //<MetaVariable> comment lines may also contain the var_type tag; 
//<DataVariable> comment lines may also contain the is_primary_variable tag. All tags 
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except the label tag are optional. Tag values must be enclosed by double-quotes. The la-
bel value must match the name and units part of one of the column labels in the file, 
value_type must be one of BYTE, SIGNED_BYTE, SHORT, UNSIGNED_SHORT, INTEGER, 
UNSIGNED_INTEGER, FLOAT, DOUBLE, TEXT:nn (nn is the byte-length of the text), or 
INDEXED_TEXT, qf_schema must be one of ARGO, BODC, ESEAS, GTSPP, IODE, 
OCEANSITES, ODV, QARTOD, PANGAEA, SEADATANET, SMHI, WOCEBOTTLE, 
WOCECTD, WOCESAMPLE, WOD, or WODSTATION. If the var_type tag is present in 
//<MetaVariable> comment lines the value must be one of METABASIC, METACRUISE, 
METASTATION, METATYPE, METALONGITUDE, METALATITUDE, METADAY, 
METAMINUTE, METAMONTH, METAHOUR, METAYEAR, METASECOND, 
METABOTDEPTH, METALOCALCDIID, METAEDMOCODE, METASENSORDEPTH, 
METADURATION, METAEXTRACRUISEINFO, METAORIGCRUISE, METAORIGSTATION, 
METAINVESTIGATOR, METAGTSPPDATATYPE, METACOMMENTSLINK, 
METACRUISEREPORTLINK, METAREFERENCE, METASDNINSTRUMENTINFO. is_pri-
mary_variable is set to “T” for the primary data variable and “F” for all other variables. 
Example //<MetaVariable> and //<DataVariable> comment lines are given in the table 
below. All ODV spreadsheet files produced via Export > Station Data > ODV Spreadsheet 
File contain such lines for all metadata and data variables. 

 

Table 16-6: Summary of comment line attributes names supported by ODV. 

Attribute Name Possible Values 

File information 

Creator Free text specifying the creator of the file. 
Example: //<Creator>rschlitz@GSYSP168</Creator> 

CreateTime Time of file creation in ISO 8601 extended format. 
Example: //<CreateTime>2008-05-16T09:53:45.2</CreateTime> 

Encoding Encoding used in the file. Valid entries include: UTF-8, ISO-8859-1, latin1, 
windows-1258, MacRoman, macintosh. 
Example: //<Encoding>UTF-8</Encoding> 

MissingValueIndicators List of missing value indicators in the file. Multiple entries are separated 
by spaces. 
Example:  
//<MissingValueIndicators>-9 -99.9 -9999</MissingValueIndicators> 

Software Software used to create the file. 
Example: //<Software>Ocean Data View - Version 4.7.7</Software> 

Source Absolute path of source collection. 
Example: //<Source>C:/eWOCE/data/whp/bottle/WoceBtl</Source> 

SourceLastModified Last modified time of source collection in ISO 8601 extended format. 
Example:  
//<SourceLastModified>2003-11-11T19:53:45.2</SourceLastModified> 
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Version Version of the file. 
Example: //<Version>ODV Spreadsheet V4.6</Version> 

Data information 

DataField Description of the field of data in the file. Valid entries are: GeneralField, 
Ocean, Atmosphere, Land, IceSheet, SeaIce, Sediment 
Example: //<DataField>Ocean</DataField> 

DataType Description of the type of data in the file. Valid entries are: GeneralType, 
Profiles, TimeSeries, Trajectories  
Example: //<DataType>Profiles</DataType> 

History History record for the given station. History records must be placed after 
the last data line of the station.  
Example:  
//<History>2015-10-09T09:28:18 xxx@yyy IMPORT (ADD) from D:/data/ARK-
XXVII-1_cnv_seabird/d003-01.cnv (last modified: 2015-10-08T13:21:45; 
byte size: 524146427 MD5: 9c567f786c781d78865ecb589afd2bd8)</History> 

Metadata- and  data variable information 

MetaVariable Description of a meta variable contained in the file (see details above).  
Example:  
//<MetaVariable>label="Cruise Report" value_type="INDEXED_TEXT" 
qf_schema="ODV" significant_digits="0" comment=""</MetaVariable> 

DataVariable Description of a data variable contained in the file (see details above).  
Example: //<DataVariable>label="SALNTY [pss-78]" value_type="FLOAT" 
qf_schema="ODV" significant_digits="3" is_primary_variable="F" com-
ment="Practical salinity from bottle sample"</DataVariable> 

 

16.3.2 Column Labels 

There has to be exactly one line containing the labels of the columns. This column labels 
line must always be present, it must appear before any data line and it must be the first 
non-comment line in the file. 

ODV generic spreadsheet files must provide columns for all mandatory meta-variables 
(see Table 3-3), and the following labels must be used as column labels: Cruise, Station, 
Type, one of the supported date/time formats, Longitude [degrees_east], Latitude [de-
grees_north], Bot. Depth [m]. Longitude and latitude values must be provided as decimal 
degrees. The recommended date/time format is ISO 8601, which combines date and 
time as yyyy-mm-ddThh:mm:ss.sss in a single column.  

As an alternative, longitude and latitude values may also be provided as degrees, 
minutes, and seconds (seconds are optional) as long as all specs are separated by one or 
more spaces and appear in a single column. Supported formats include: "32 18 23.1 N", 
"32 18.756 N", "32° 18' 23.1'' N", or "32°18'23.1''N". Note that usage of the degree char-
acter ° may cause problems with non-Latin1 file encodings. You must use Latitude [deg 
min] and Longitude [deg min] as column headers when specifying longitude and latitude 
as degrees, minutes, and seconds. The labels Lon (°E) and Lat (°N) for decimal longitude 
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and latitude are deprecated but still supported for backwards compatibility.  

Note: The metadata- and data column label qualifiers described below are deprecated. 
Instead, please use //<MetaVariable> and //<DataVariable> comment lines for specify-
ing metadata and data variable properties (see above). 

Metadata column labels 

Metadata labels may have qualifiers of the form  

:METAVAR:<valueType>:<valueBytes> 

to indicate that the column represents a meta-variable of a given value type and byte-
length. valueType may be one of the following: BYTE, SIGNED_BYTE, SHORT, 
UNSIGNED_SHORT, INTEGER, UNSIGNED_INTEGER, FLOAT,  DOUBLE, TEXT, or 
INDEXED_TEXT. valueBytes represents the number of bytes per value and only needs to 
be specified for valueType=TEXT.  The valueBytes value represents the maximum num-
ber of characters to be stored in the text field (default length: 21 Bytes). Note that one 
of the characters is used for string termination and is not available for actual metadata 
text. A TEXT field of 21 bytes, for instance, can store a maximum of 20 characters of 
metadata text. INDEXED_TEXT variables can store strings of arbitrary length. You 
should use this value type if the strings are long, of variable length, or the same string is 
used many times. 

Examples:  Longitude [degrees_east]:METAVAR:DOUBLE 
Citation:METAVAR:TEXT:81 
URL:METAVAR:INDEXED_TEXT 

Note:  The qualifiers are only used when the spreadsheet file is used as a template for 
collection creation, e.g., when dropping the file onto ODV, opening the file via File > 
Open or choosing the file as template when creating a new collection via File > New. 
They have no effect if you import the file into an existing collection. 

Data column labels 

Data variable labels should include unit specifications enclosed in brackets [ ], such as 
Depth [m]. Variables without units should not contain the [ ] units part (e.g., Species 
Count).  

Data variable labels may have qualifiers of the form  

:PRIMARYVAR:<valueType>:<valueBytes>:<SchemaID> 

where valueType may be one of the following: BYTE, SIGNED_BYTE, SHORT, 
UNSIGNED_SHORT, INTEGER, UNSIGNED_INTEGER, FLOAT,  DOUBLE, TEXT, or 
INDEXED_TEXT. valueBytes represents the number of bytes per value and only needs to 
be specified for valueType=TEXT or if the SchemaID entry is present.  In case of TEXT 
the valueBytes value represents the maximum number of characters to be stored in the 
text field (default length: 21Bytes). Note that one of the characters is used for string ter-
mination and is not available for actual data text. A TEXT field of 21 bytes, for instance, 
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can store a maximum of 20 characters of metadata text.  INDEXED_TEXT variables can 
store strings of arbitrary length. You should use this value type if the strings are long, of 
variable length, or the same string is used many times. 

SchemaID may be one of the following: ARGO, BODC, ESEAS, GTSPP, IODE, OCEANSITES, 
ODV, QARTOD, PANGAEA, SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, 
WOCESAMPLE, WOD, or WODSTATION. Note that if the variable has an associated qual-
ity flag column (see below), the SchemaID of the quality flag column will prevail. 

Only one column label may have the :PRIMARYVAR qualifier to indicate that this column 
is the primary variable. 

Examples: Depth [m]:PRIMARYVAR:DOUBLE 
  Sample Number:SHORT 
  Salinity [psu] 
  Phosphate [~$m~#mol/kg]:FLOAT:4:WOCEBOTTLE 
  Sediment Type:INDEXED_TEXT:4:SEADATANET 

Note: The qualifiers are only used when the spreadsheet file is used as a template for 
collection creation, e.g., when dropping the file onto ODV, opening the file via File > 
Open or choosing the file as template when creating a new collection via File > New. 
They have no effect if you import the file into an existing collection. 

Data columns can have associated quality flag, data error and data info columns. These 
ancillary columns normally follow immediately after the data column to which they be-
long.  

Quality flag column labels 

Quality flag column labels must comply with the following naming conventions to ena-
ble automatic identification of the metadata or data variable they belong to, as well as of 
the particular quality flag scheme used.  

ODV generic spreadsheet quality flag labels may be specified in one of the following 
forms:   

• QV<Text>:<SchemaID>:<ParentColumnLabel> 
• QV<Text>:<SchemaID>:STATION 
• QV<Text>:<SchemaID>:SAMPLE 
• QF 

<Text> is an arbitrary and optional string, <SchemaID> is one of the supported quality 
flag schema identifier (see Table 16-5) and <ParentColumnLabel> is the column label of 
the variable to which the quality flag column belongs. The <Text>, <SchemaID> and 
<ParentColumnLabel> parts of the quality flag label are optional. If the <SchemaID> item 
is missing, it is assumed that the quality flag values are ODV generic quality flags. If the 
<ParentColumnLabel> part is missing, it is assumed that the quality flags belong to the 
variable preceding the quality flag column. Note that if the <Text> item is present, it 
may not contain the ‘:’ separation character. Also note that <Text> is not evaluated or 
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used by ODV. This item is only included to allow unique column labels for applications 
that require this feature (e.g., QV1, QV2, etc.). 

<SchemaID> may be one of the following: ARGO, BODC, ESEAS, GTSPP, IODE, 
OCEANSITES, ODV, QARTOD, PANGAEA, SEADATANET, SMHI, WOCEBOTTLE, 
WOCECTD, WOCESAMPLE, WOD, or WODSTATION. See Table 16-5 for more infor-
mation on quality flag schemas. 

In addition to quality flag values for individual data values, ODV also supports entire 
station quality flags describing general quality aspects of the entire station (single flag 
for a given station; e.g., WOCE entire station flags), as well as sample quality flags that 
may be used to indicate problems with the sampling device, possibly affecting the qual-
ity of all measurements made on that sample (one flag for every sample). Entire station 
and sample quality flags are indicated with the words STATION or SAMPLE in the 
<ParentColumnLabel> part of the column label. 

Note that the QV syntax of quality flag labels is not recognized by ODV versions 3 or ear-
lier. To be compatible with ODV3, you must use QF as the label of quality flag columns. 
In such cases, it is assumed that the quality flag values are ODV generic flags and that 
they belong to the variable preceding the quality flag column.  

 
Table 16-7: Example quality flag column labels 

Quality Flag Column Label Comment 

QV or QF ODV generic quality flags for the closest data variable to the left. 

QV:SEADATANET SeaDataNet quality flags for the closest data variable to the left.  

QV:ARGO:Nitrate [umol/kg] Argo quality flags for variable with label Nitrate [umol/kg]. 

QV:ODV:Nitrate [umol/kg] 
or 
QV::Nitrate [umol/kg] 

ODV generic quality flags for variable with label Nitrate [umol/kg]. 

QV:WOCESAMPLE:SAMPLE WOCESAMPLE sampler quality flags. 

QV:WODSTATION:STATION WODSTATION entire station quality flags. 

QV::STATION ODV generic quality flags for entire station. 

 

Data error column labels 

Every data column can have an associated data error column containing the 1-σ uncer-
tainties of the respective data values. Data error column labels must comply with the 
following naming conventions to enable automatic identification of the data variable 
they belong to: 

• STANDARD_DEV<Text><::ParentColumnLabel> 

<Text> is an arbitrary and optional string and <ParentColumnLabel> is the column label 
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of the variable to which the data error column belongs. The <Text> and <ParentColumn-
Label> parts are optional. If the <ParentColumnLabel> part is missing, it is assumed that 
the data errors belong to the data variable preceding the data error column. Note that if 
the <Text> item is present, it may not contain the ‘:’ separation character. Also note that 
<Text> is not evaluated or used by ODV. This item is only included to allow unique col-
umn labels for applications that require this feature (e.g., STANDARD_DEV1, 
STANDARD_DEV2, etc.). 

 
Table 16-8: Example data error column labels 

Data Error Column Label Comment 

STANDARD_DEV Data errors for the closest data variable to the left. 

STANDARD_DEV::Nitrate [umol/kg] Data errors for variable with label Nitrate [umol/kg]. 

 

Data info column labels 

Every data column can have an associated data info column containing info texts or 
URLs to info documents for the respective data values. Data info column labels must 
comply with the following naming conventions to enable automatic identification of the 
data variable they belong to: 

• INFOS<Text><::ParentColumnLabel> 

<Text> is an arbitrary and optional string and <ParentColumnLabel> is the column label 
of the variable to which the data error column belongs. The <Text> and <ParentColumn-
Label> parts of the quality flag label are optional. If the <ParentColumnLabel> part is 
missing, it is assumed that the data infos belong to the data variable preceding the data 
info column. Note that if the <Text> item is present, it may not contain the ‘:’ separation 
character. Also note that <Text> is not evaluated or used by ODV. This item is only in-
cluded to allow unique column labels for applications that require this feature (e.g., 
INFOS1, INFOS2, etc.). 

 
Table 16-9: Example data info column labels 

Data Info Column Label Comment 

INFOS Data infos for the closest data variable to the left. 

INFOS::Nitrate [umol/kg] Data infos for variable with label Nitrate [umol/kg]. 

 

 

IMPORTANT NOTE: Column labels must not contain the column separation character 
used in the spreadsheet file. 
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16.3.3 Data Lines 

Every non-comment line following the column labels line is considered a data line. All 
data lines must have the same number of columns as the column labels line. Each data 
line contains metadata and data for one sample. All samples of a given station must be 
in consecutive order but need not be sorted. Missing values may be indicated by an 
empty field, the value -1.e10, or by a text indicator, such as na (not available) or NaN 
(not a number). If special numeric values, such as -9 or -9999, are used as missing value 
indicators in the file, the special values must be specified in an attribute line of the form 
//<MissingValueIndicators>-9 -9999</MissingValueIndicators> near the top of the file 
before any data line. 

Station labels are limited to the length of the Station meta-variables (default: 20 charac-
ters). The use of numbers for station labels will enable enhanced internal sorting and 
selection functionality and is recommended. 

Station Type is a single character string. You should use B for stations with less than 
about 250 samples (e.g., bottle data) and C for stations with more than about 250 sam-
ples (e.g., CTD, XBT, etc.). Specifying * for Type lets ODV make the choice. If Bot. Depth 
values are not available, you should leave this field empty. 

The station metadata must be provided on the first line of a given station. The metadata 
fields on the remaining lines of the station may remain empty to reduce file size (com-
pact spreadsheet format). An ODV generic spreadsheet file usually stores the data of 
many stations from many cruises. The metadata and data of the first sample of the next 
station follow immediately after the last sample of the previous station. There are no 
separator lines between stations. 

Numeric values may have periods ‘.’ or commas ‘,’ to indicate decimals (e.g., 2,57 or 2.57 
are both valid entries). If entries are enclosed in double quotes “, these are automati-
cally removed before processing. 

Data variables of type TEXT use a one byte per character encoding. ODV collections re-
main platform and country independent if the text values are strictly confined to the 
ASCII character set (codes 0-126). Usage of non-ASCII characters will work fine on the 
same platform and within the same locale (country), however, non-ASCII characters 
likely display incorrectly on different platforms or in different countries. ASCII-only text 
should always be used for the sake of platform independence of data collections. 

The maximum number of bytes that can be stored per value of a text data variable (byte 
length) is fixed and must be specified at collection creation time. The actual requested 
byte length must include one extra byte for text termination. If, for instance, a text vari-
able must be able to store 40 characters of text, the requested byte length must be 41. 
The byte-length of a text variable cannot be smaller than 2 and is otherwise arbitrary. 
Choosing large byte-lengths, such as 5001, accommodates long texts, but also leads to 
large collection files, because all individual text values occupy the specified number of 
bytes. If a given text value represents a DOI or a URL of a website, ODV will allow click-
ing on the value and will open the DOI or URL in a web browser. Using URLs or DOIs 
should be considered as alternative to using large amounts of text directly. 
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16.4 Supported Date and Time Formats in ODV Spreadsheet Files 

ODV supports the single column ISO 8601 date/time format. This is the recommended 
date/time format for ODV import and export files. In addition, ODV also supports a wide 
range of other date and time formats to allow easy import of data provided in one of the 
many custom file formats, commonly used in the scientific community. This includes 
many date and time specifications that differ in the order of the day, month, year values, 
and cases with day, month, year, hour and minute data in individual columns.  

Use of the column labels in Table 16-10 is strongly recommended (lower, upper or 
mixed case) as this allows automatic date/time identification by ODV. The default 
date/time format in ODV spreadsheet output files is ISO 8601.  

 
Table 16-10: Supported date formats (column labels may be upper, lower or mixed case) 

Column label Comment 

yyyy-mm-dd hh:mm 
or 
yyyy-mm-ddThh:mm 
or 
yyyy-mm-ddThh:mm:ss.sss 

ISO 8601. Recommended ODV date/time format. Combines date 
and time in a single column. 
Examples: 2006-02-23 10:23 or 2006-02-23T10:23 for 
Feb/23/2006 10:23h. 

Time [xxx since yyyy-mm-dd] 

Date and time as a decimal value in units of  xxx (days or years) 
since the specified reference date yyyy-mm-dd. 
Example: Time [days since 2012-01-01] = 1.5 
for Jan/02/2012 12h. 

mon/day/yr 
or  
mm/dd/yyyy 

Date in one column. Time provided separately. 
Example: 02/23/2006 for Feb/23/2006. 

dd/mm/yyyy 
Date in one column. Time provided separately. 
Example: 23/02/2006 for Feb/23/2006. 

yyyy/mm/dd 
Date in one column. Time provided separately. 
Example: 2006/02/23 for Feb/23/2006. 

mmddyyyy 
Date in one column. Time provided separately. 
Example: 02232006 for Feb/23/2006. 

ddmmyyyy 
Date in one column. Time provided separately. 
Example: 23022006 for Feb/23/2006. 

yyyymmdd 
Date in one column. Time provided separately. 
Example: 20060223 10:23 for Feb/23/2006 10:23h. 

year 
month 
day 

Date information in individual columns (any order). Time pro-
vided separately. 
Example: 2006 02 23 for Feb/23/2006. 
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Table 16-11: Supported time formats (column labels may be upper, lower or mixed case) 

Column label Comment 

hh:mm Time in one column. Date provided separately. 
Example: 10:23 for 10:23h. 

hhmm Time in one column. Date provided separately. 
Example: 1023 for 10:23h. 

hour 
minute 

Time information in individual columns (any order). Date provided separately. 
Example: 10 23 for 10:23h. 

 

16.5 Control Sequences and Functions in Annotations 

 

Table 16-12: Formatting control sequences in ODV annotations.  

Control Sequence Action 

~$ Switches to Symbol font (Greek symbols) 

~# Switches to normal text font 

~% Produces per mille character (‰) 

~^ Next character drawn as superscript 

~_ Next character drawn as subscript 

&#<code>; Produces Unicode character <code>. <code> can be a decimal (e.g., 169) or 
hexadecimal (e.g., x00A9) code 

Examples: “~$S~#CO~_2 [~$m~#mol/kg]” will produce “ΣCO2 [µmol/kg]”,  
“&#x00A9; No Name” will produce “© No Name”. 
 

 

 
Figure 16-1: Greek symbols and Latin equivalents 
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Table 16-13: Available auto-functions in ODV annotations. 

Function Substituted Text 

=collection() Full path of current collection 

=collectionName() Name of current collection (excluding extension) 

=collectionStationCount() Number of stations in current collection 

=date() Current date 

=section() Full path of current section file 

=time() Current time 

=user() User and host name 

=validStationCount() Number of stations currently shown in station map 

=view() Full path of current view file 

=viewName() Name of current view file (excluding extension) 

 

16.6 Gridding Methods 

ODV lets the user project irregularly spaced original data onto equi- or non-equidistant 
rectangular grids (for contouring and graphical display or output of gridded values) us-
ing one of three available methods: Quick gridding, Weighted-average gridding, and 
DIVA gridding.  

Quick gridding is a weighted averaging algorithm optimized for speed that calculates es-
timates at all grid nodes requiring only one loop over the available data. Quick gridding 
should only be used in cases when the other algorithms are too slow, e.g., in cases with 
millions of data points. Weighted-average gridding uses a more sophisticated weighted 
averaging algorithm and yields good results in cases with good and homogeneous data 
coverage. Weighted-average gridding is the default gridding method. DIVA gridding is 
more advanced and computationally more expensive than the other methods. DIVA 
gridding should always be used when preparing final graphs for publications or 
webpages. Note that the Isopycnic gridding feature is only available for DIVA gridding. 

16.6.1 Weighted-Average Gridding 

In contrast to Quick gridding, for which an equidistant, rectangular grid is used, ODV 
constructs and uses a variable resolution, rectangular grid if Weighted-average or DIVA 
gridding is requested. In this case, grid-spacing along the X and Y directions varies ac-
cording to data density. High resolution (small grid-spacing) is provided in regions with 
high data density, whereas in areas of sparse sampling a coarser grid with reduced res-
olution is used. For hydrographic sections, this typically yields high spatial resolution in 
the upper water column and in boundary current regions, where data coverage is usu-
ally good, and a coarser resolution grid in open ocean regions and the deep sea with 
sparser data coverage.  
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After construction of the grid, property estimates ∑⋅∑=
i

ii
i

ie dc αα are calculated at every 

grid point (+) using a simple weighted-averaging scheme. For efficiency reasons, only 
data values di from a small neighborhood of the grid-point are considered for summa-
tion (see figure below). The weights αi decrease exponentially with increasing distance 
between data and grid-point: r

i e−=α , with 22 )/()/( yx LyLxr ∆+∆=  and separate aver-
aging length-scales Lx and Lx in X and Y directions, respectively. Averaging length-scales 
vary over the domain, and are 

 
Figure 16-2: Weighted averaging of data values (red symbols) at a grid node (+). See text for details. 

 

proportional to local grid-spacing. Thus, small averaging length-scales are used in areas 
with small grid-spacing (high grid resolution, e.g., in the upper water column or in 
boundary current regions, etc.), whereas in regions with large grid-spacing, large aver-
aging length-scales are applied automatically.  This approach of spatially varying 
length-scales allows resolving small-scale features in areas of dense data coverage and 
at the same time provides smooth and stable fields in other regions with sparse data 
coverage. The user-provided length-scales Lx0 and Ly0 on the Display Options dialog are 
measured in per-mille of the respective axis range and are representative for the area of 
poorest data coverage (coarsest grid). The ODV implementation of the weighted averag-
ing algorithm is highly optimized for speed to allow field estimations within seconds, 
even for fields with thousands of data points. 

Once estimates have been obtained for all grid points, the field is passed to shading and 
contouring routines for display on the screen. 

16.6.2 DIVA Gridding 

DIVA is a gridding software developed at the University of Liege 
(http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA) that offers a number of ad-
vantages over the weighted averaging methods built into ODV. DIVA allows analyzing 
and interpolating data in an optimal way, comparable to optimal interpolation (OI). Un-
like OI, DIVA also takes into account coastlines and bathymetry features to structure 
and subdivide the domain on which estimation is performed. Calculations are per-
formed on a finite element mesh adapted to the specific gridding domains.  

http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA
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The necessary DIVA tools to generate the finite element mesh, optimize the parameters 
of the analysis and calculate the gridded field are included in the ODV installation pack-
age, and the DIVA gridding option is available by default on the Properties > Display Style 
dialog of data windows with a Z-variable. You activate DIVA gridding by choosing this 
option and specifying appropriate X and Y correlation length scales or checking the Au-
tomatic scale lengths check-box. ODV creates all necessary files for the operation of 
DIVA automatically (in work directory <user>/diva/work/yyyy-mm-ddThh-mm-ss, 
where <user> represents your ODV user directory and yyyy-mm-ddThh-mm-ss is the 
launch date and time of  the particular ODV instance), runs the DIVA mesh generation 
and field estimation steps, and reads the DIVA output for graphical display of the field 
by ODV.  

As for the other gridding algorithms, the smoothness of the estimated field is controlled 
by adjusting the X- and Y- length scales on the Display Style page of the data window’s 
Properties dialog. Note that the scale length values are in per mille of the respective axis 
range and that large values result in smooth fields. Other DIVA parameters, such as the 
data signal-to-noise ratio and the method for setting up the gridding domain (see Do-
main Separation below) may be accessed on the DIVA Settings page of the data win-
dow’s Properties dialog. Note that the DIVA work directory and all its contents is de-
leted when ODV is shut down. 

DIVA experts may adjust additional DIVA parameters by editing the DIVA settings file 
<user>/diva/diva.settings.  

Non-negativity Constraint 

Weighted-averaging methods, such as Quick gridding or Weighted-average gridding, al-
ways generate estimates strictly lying in the interval between smallest and largest data 
values, and these estimates never exceed the observed value range. DIVA gridding is dif-
ferent in this respect and occasionally produces gridded field values beyond the data 
range. As a special case, you may encounter negative gridded values in some regions of 
the X/Y domain, even if all data values are positive (or zero) and you are expecting a 
non-negative field. If you are gridding a variable that is guaranteed to be non-negative 
(for instance the concentration of a chemical tracer) and DIVA generates areas with 
negative concentrations, please check the Prevent negative gridded values checkbox on 
the DIVA Settings page to prevent such unrealistic values. 

Domain Separation 

DIVA gridding generally produces better results than Quick gridding or Weighted-aver-
age gridding in cases of sparse and heterogeneous data coverage (see Figure 16-3) and 
in cases where sub-regions with quite different property values are separated by land 
masses, ridges or other bathymetric barriers (see Figure 16-4). Whereas the weighted 
averaging schemes used for Quick gridding or Weighted-average gridding wrongly 
transmit information across the barriers, this does not happen with DIVA gridding.  

The DIVA domain separation feature is activated for two types of data windows: (1) 
section plots that have Depth or Pressure on the Y-axis and have section bathymetry 
shown in the plot, and (2) data windows with longitude and latitude on the X- and Y-
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axis, respectively, and a collection or isosurface variable as Z-variable (maps). Note that 
the surface variable of the Z isosurface variable must be a Depth or Pressure in Water 
Column variable (see Key Variable Associations). 

(1) In section plots there is a choice to use the section bathymetry polygon for domain 
separation, or to not use domain separation and treat the entire X/Y window range as a 
single domain (see DIVA Settings page in Figure 10-5). 
 

 
Figure 16-3: Comparison of (a) weighted-average and (b) DIVA gridding methods for a field with inhomoge-

neous data coverage. 

 

(2) Domain separation in maps is based on gridded bathymetric data and a threshold 
depth value. All areas with water depths shallower than the specified threshold depth 
are considered barriers. ODV allows selecting an appropriate bathymetry file containing 
elevation data on a regular grid, as well as the threshold depth value (see DIVA Settings 
page in Figure 10-5). By default, ODV uses the 6’x6’ subsampled global GEBCO bathyme-
try (file GEBCO1.nc in the include directory), which provides sufficient resolution for ba-
sin-scale or global map domains (Figures 16-3 and 16-4). For very small domains the 
6’x6’ resolution of the default bathymetry file is too coarse for reliable land-mass bar-
rier detection, and custom bathymetry files must be provided by the user.  Files con-
taining regional subsets of the new 0.5’ resolution GEBCO_08 bathymetry can be deliv-
ered on request.  

The custom bathymetry files must be in netCDF format, they must have the same logical 
structure as <install>/include/GEBCO1.nc and they must be located in <install>/include 
(where < install> represents your ODV installation directory). To use a custom bathym-
etry file for DIVA, select the file under Domain Selection>Map on the DIVA Settings page 
of the window’s Properties dialog.  

Note that ODV switches domain separation off automatically if the selected bathymetry 
file provides insufficient resolution for the given domain. 

For the threshold depth you may enter a specific depth value or the keyword (auto-
matic). If (automatic) is used and the Z variable is an isosurface variable defined on a 
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Depth or Pressure surface, the depth (or pressure) of the surface is used as threshold 
depth. In these cases ODV needs to be able to identify your Depth (or Pressure) variable. 
Please use option Collection > Identify Key Variables and ensure that the key variable 
Depth in Water Column [m] (or Pressure in Water Column [db]) is associated with your 
Depth (or Pressure) variable. If the isosurface variable is defined using the keyword first 
(e.g. XXX @ Depth [m]=first) an automatic threshold depth of  1m is used.  
 

 
Figure 16-4: Comparison of (a) weighted-average and (b) DIVA gridding methods for separated ocean ba-

sins. Note the influence of Pacific values in the Caribbean in the weighted-average gridding case (a). 

 

DIVA execution times are somewhat larger than for the other gridding methods; never-
theless, you should always consider using DIVA gridding for publication-quality figures. 

System requirements and troubleshooting: For successful operation of the DIVA package 
you need a computer with at least 2GB of RAM. If you run DIVA and the plot window re-
mains white, please try to free some memory by closing other applications and try 
again. 

 

16.6.3 Isopycnic Gridding 

Transport of water and constituents in the ocean are most effective along surfaces of 
constant density (isopycnals), and in regions of strongly sloping isopycnals (frontal ar-
eas) gridding along Cartesian coordinates is inappropriate and can lead to significant 
misrepresentations of the observed data.  

As an example, Figure 16-5 shows nitrate data along a zonal section in the Gulf Stream 
region near 30°N. The original data in (a) clearly show a pronounced nitrate maximum 
following the σ0=27.725 isopycnal, which in this region deepens from about 300 m 
depth near the coast to about 1000 m further offshore. Cartesian gridding (b) is not able 
to reproduce the continuous nitrate maximum over the entire depth range of the iso-
pycnal, and especially at about 500 m the influence of low nitrate waters further in- and 
offshore lead to too small estimates. In contrast, isopycnic gridding does not suffer from 
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this effect and creates a more realistic distribution (c). 

Isopycnic gridding should always be used in areas with sharply sloping isopycnals, such 
as regions with strong currents and fronts. 

 

 
Figure 16-5: (a) Original nitrate data in the Gulf Stream region and comparison between (b) Cartesian and 

(c) isopycnic gridding. 

You may request isopycnic gridding in sections by checking the Isopycnic gridding box 
on the Display Style page of the window’s Properties dialog (see Figure 10-1). Note that 
this option is only enabled if neutral density γn or a potential density derived variable is 
defined and DIVA gridding is used. Also note that neutral density γn is not available in 
some parts of the ocen (e.g., Arctic); in such cases use a potential density variable in-
stead.  

Isopycnic gridding can yield poor results if the hydrographic data are not of highest 
quality. Use this option only for quality controlled datasets and ensure that data outliers 
are excluded by applying suitable sample quality filters. It is also essential that the val-
ues of the density variable used for isopycnic gridding (γn, if defined, or the first defined 
potential density anomaly variable otherwise) are strictly monotonically increasing 
with depth (requirement may be violated for potential density variables far from the 
reference pressure). It is recommended to always use neutral density γn; in the Arctic, 
where γn is not defined use σ0. 

 

16.7 ODV Directory Structure 

The default installation directory for ODV is c:\Program Files\Ocean Data View (mp) on 
Windows, /Applications/ODV on Mac OS and /usr/local/odv for Linux and UNIX (indi-
cated as <install> below; for Mac OS, Linux and UNIX replace backslashes \ by slashes / 
in the following path specifications). The installation directory contains various subdi-
rectories containing files needed for specific purposes. Installation files that may be 
modified by the user, such as macro files, palette files or sample data collections, are in-
stalled in subdirectory ODV under the user’s document directory (indicated as <user> 
below). 
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Following below is a list of directories used by ODV: 
<install>\bin_w32   on Windows platforms, ...or... 
<install>\bin_macx   on Mac OS platforms, ...or... 
<install>\bin_linux-i386  on Linux i386 platforms, ...or... 
<install>\bin_solaris-sparc  on SUN Solaris Sparc platforms, ...or... 
<install>\bin_irix6.5_mips  on SGI Irix platforms, ...or... 
<install>\bin_aix-powerpc  on IBM AIX powerpc platforms: 

ODV executable, tools, and PostScript preamble file. 

<install>\coast\GlobHR: 
Medium-resolution coastline and topography files for the whole globe. 

<install>\doc: 
ODV html help files (pdf versions available from ODV web page). 

<install>\include: 
Default directory for ODV include files (e.g., GEBCO1 global topography). Note 
that there are several sub-directories containing specific files. 

<install>\include\atmhist: 
Atmospheric concentration histories of various trace gases. 

<install>\samples: 
Directory for ODV sample files. Use these files as templates for data import or 
macro files. 

<user>\cmd_files: 
ODV command files (.cmd). 

<user>\data: 
Base directory for ODV data collections. While ODV data collections may, in 
principle, reside anywhere on a read-write (hard-disk, memory stick, etc.) or 
read-only (DVD, CD-ROM, etc.) storage medium, it is recommended to main-
tain all your collections under this directory. Every collection should be 
stored in its own sub-directory. 

<user>\diva: 
DIVA working directory (only present if DIVA has been used). 

<user>\export: 
Base directory for datasets exported via Export > X, Y, Z Window Data. 

<user>\gazetteers: 
ODV gazetteer database files. 

<user>\macros: 
ODV macro files (.mac). 

<user>\palettes: 
ODV palette files (.pal). 

<user>\reference: 
Base directory for reference datasets exported via Export > X, Y, Z Window 
Data as Reference. 
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